Emergency mode after trying to install NVIDIA driver

Hi everyone. Hope all is well.
I was following this guide on how to install nvidia drivers for a 1070ti and after step 2.7 (Reboot to runlevel 3 ) the system went to emergency mode.
When I exit the emergency mode I can read:
Warning: Not all disks have been found
Warning: You might want to regenerate your initramsfs
I really would appreciate some help here. I would not mind paying for this help too.
Here is the link for the guide: https://www.if-not-true-then-false.c…-nvidia-guide/
THANK YOU !

Hello @cheapcigar, there is no need to offer money in order to ask for help. Here, like in many free software communities, there is a lot of kindly people that is happy to collaborate with each other in order to solve issues.

1 Like

Hi @cheapcigar!

First of all – as written here on Ask Fedora quite a few times already – there is much better way to install NVidia drivers on Fedora.

https://rpmfusion.org/Howto/NVIDIA
https://fedoramagazine.org/install-nvidia-gpu/

Both links have info on how to install the same driver from the the same source, first one is short and to the point, second is with longer explanations aimed at newer / less experienced users.


As you haven’t yet done the installation of driver, I would suggest reverting changes you’ve done already, and then installing the driver from the repository.

I (and I hope other people here too) will try to provide you the help you’ll need to undo the changes.
How about such a plan? Are you with me?

The other possible way will be trying to proceed with installation – but I don’t like this approach (that’s me personally). Chances are (from your description of the problem) something went wrong for you on step 2.6.5 Generate initramfs, and that’s why you are dropped to emergency mode. I can’t be sure, of course. Also keep in mind I’ve never installed NVidia’s driver using that guide.

5 Likes

Thank you so much @nightromantic

2.6 Enable nouveau

2.6.1 Create or edit /etc/modprobe.d/blacklist.conf

edit sudo nano /etc/modprobe.d/blacklist.conf, and delete this line
:arrow_right: blacklist nouveau

2.6.2 Edit /etc/sysconfig/grub

Append this file sudo nano /etc/sysconfig/grub and delete rd.driver.blacklist=nouveau at the end, that file should look like this ‘GRUB_CMDLINE_LINUX=”… rhgb quiet`

2.6.3 Update grub2 conf

## BIOS ##
grub2-mkconfig -o /boot/grub2/grub.cfg

## UEFI ##
grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

2.6.4 Install xorg-x11-drv-nouveau

If you have following row on /etc/dnf/dnf.con file, then you can remove it:

sudo nano /etc/dnf/dnf.conf/ and delete the following line, exclude=xorg-x11*

then install it

sudo dnf install xorg-x11-drv-nouveau

2.6.5 Generate initramfs

## Restore Original initramfs nouveau image ##
sudo mv /boot/initramfs-$(uname -r)-nouveau.img /boot/initramfs-$(uname -r).img 
 
or

## Create new initramfs image ##
sudo dracut /boot/initramfs-$(uname -r).img $(uname -r)

2.7 Reboot to runlevel 5

Run level 5 is emulated by graphical.target (and runlevel5.target is a symbolic link to graphical.target ).

systemctl isolate graphical.target

reboot

NOTE: Now you can test with other tools like the official way

Regards.,

1 Like

Actually, you have nothing to thank me for ) @hhlp did all the work, I was waiting for your confirmation you’re ready to take path I’ve suggested before writing detailed instructions.

Please tell us – have you succeeded in undoing changes?