Enabling fractional scaling on X.Org Fedora 34

Before I begin. I did read (Fractional Scaling GNOME on X.Org. How I can enable it? - #5 by grsm) and the op couldn’t get it working.

So, I did enable fractional scaling on Wayland using the command gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']", it showed up in the display setting and it works, at least on supported apps.

When I try to enbale scalling on the X11 session, with the command gsettings set org.gnome.mutter experimental-features "['x11-randr-fractional-scaling']" the display options in the setting app only show 100% and 200% , not 125% or 150%?

Therefore how do I enable fractional scalling on X.Org session in Fedora 34?