Enabling ibus-typing-booster on Fedora 30

While doing some updates I noticed ibus-typing-booster on my Fedora 30 computer. The idea looked great for speeding up typing using suggestions (bit like Android). I have not tried it before now.

I am using the Cinnamon desktop BTW. (cinnamon-4.4.8-1.fc30.x86_64)

I have been trying to get it activated to work but have not seen the popup panel of suggestions. I cannot find where to enable the plugin. As you can see below, the package is installed but does not show in the process list

[graham@gm-ws1 ~]$ sudo dnf list ibus-typing-booster
Installed Packages
ibus-typing-booster.noarch    2.7.7-1.fc30    @updates

[graham@gm-ws1 ~]$ ps ax |grep ibus
1827 tty1     Sl     0:00 ibus-daemon --xim --panel disable [^1]
1830 tty1     Sl     0:00 /usr/libexec/ibus-dconf
1833 tty1     Sl     0:00 /usr/libexec/ibus-x11 --kill-daemon
1838 ?        Ssl    0:00 /usr/libexec/ibus-portal
2020 tty1     Sl     0:00 /usr/libexec/ibus-engine-simple
3137 ?        Sl     0:21 /usr/bin/ibus-daemon -r --xim
3146 ?        Sl     0:00 /usr/libexec/ibus-dconf
3147 ?        Sl     0:03 /usr/libexec/ibus-ui-gtk3
3148 ?        Sl     0:09 /usr/libexec/ibus-extension-gtk3
3150 ?        Sl     0:00 /usr/libexec/ibus-x11 --kill-daemon
3155 ?        Ssl    0:00 /usr/libexec/ibus-portal
3167 ?        Sl     0:06 /usr/libexec/ibus-engine-simple

[^1]: Interesting that this line has --panel disable

When I run ibus-setup, on the ‘Input Method’ tab, when clicking button ‘Add’ and choose ‘English’, I don’t see any methods that have (typing booster) in their description. (Just several English US keyboard layouts). There is a single entry in that tab: ‘English = English(US)’

Using the command im-chooser I see ‘Use IBus (recommended)’ is highlighted. Si it looks like it is ready to go.

Please help me out. What am I missing?

TIA

I would think, since the ibus-typing-booster is an extension of the Gnome Desktop, that you would need to use gconf/gconf2 to configure it outside of the settings GUI. At least on my F31SB install that is how it is handled. On my system it is installed as an add-on to Gnome via Gnome Software (automatically during installation process as I didn’t add it after). There will be some difference since you are using F30WS (standard Workstation), and I am using Silverblue (F31). So if not already installed sudo dnf install GConf2 gconf-editor to install gconf2 and an editor for it.