Error al actualizar fedora 34

Buenos Días, he instalado fedora 34, todos los paquetes de software aplicativo, plugings de audio y demás, he reiniciado el sistema pero al intentar actualizar despues de descargar los paquetes me aparece el siguiente mensaje:

Error: Error de prueba de transacción:
el archivo /usr/bin/h264enc de la instalación de openh264-2.1.1-7.git50a1fcf.fc34.x86_64 entra en conflicto con el archivo del paquete h264enc-1:10.4.7-11.fc34.noarch

Por favor si alguno presento el mismo error y pudo resolver, indicarme como solucionar. Gracias comunidad.

1 Like

Hola @waltgio …! ¡Bienvenido a la comunidad! Tómese unos minutos cuando tenga tiempo para repasar las publicaciones introductorias en #start-here. Contienen mucha información útil.

Tomado de Aqui:

https://docs.fedoraproject.org/en-US/quick-docs/dnf-system-upgrade/

Especificamente :slight_smile:

If some of your packages have unsatisfied dependencies, the upgrade will refuse to continue until you run it again with an extra --allowerasing option. This often happens with packages installed from third-party repositories for which an updated repositories hasn’t been yet published. Study the output very carefully and examine which packages are going to be removed. None of them should be essential for system functionality, but some of them might be important for your productivity.

En otras Palabras:

sudo dnf upgrade --refresh
sudo dnf system-upgrade download --releasever=34 --allowerasing
sudo dnf system-upgrade reboot

o

sudo dnf system-upgrade download --refresh --releasever=34 --best --allowerasing

Saludos.,

Hola @Hector lo siento pero eso no funciona. continua igual

Puedes compartir el resultado de estos dos cmandos:

openh264 viene del repo → fedora-cisco-openh264
h264enc viene del repo → rpmfusion-free

rpm -qa h264enc\*
rpm -qa openh264\*

Saludos.,