Error en compartir pantalla zoom (no da audio) Fedora 34

Hola, buenos dias, tardes y noches a todos, me registre hace poco exactamente por este problema en especifico, uso para ciertas reuniones y clases la aplicación zoom, pasa que al compartir pantalla en wayland el audio se escucha pero no comparte video, entonces cuando decido probar con xorg me comparte video pero no audio, ya revise y el plugin de pulseaudio esta instalado, no pienso cambiar pipeware amenos que sea la ultima opción, agradezco cualquier ayuda, no soy un usuario experimentado para nada, trato de defenderme como puedo

Tengo estos paquetes instalados:

pipewire.x86_64                                  0.3.33-3.fc34         @updates 
pipewire-alsa.x86_64                             0.3.33-3.fc34         @updates 
pipewire-gstreamer.x86_64                        0.3.33-3.fc34         @updates 
pipewire-jack-audio-connection-kit.x86_64        0.3.33-3.fc34         @updates 
pipewire-libs.x86_64                             0.3.33-3.fc34         @updates 
pipewire-pulseaudio.x86_64                       0.3.33-3.fc34         @updates 
pipewire-utils.x86_64                            0.3.33-3.fc34         @updates 
pipewire0.2-libs.x86_64                          0.2.7-5.fc34          @anaconda

y estos son los paquetes instalados gstreamer:

gstreamer1.x86_64                             1.19.1-2.1.18.4.fc34 @updates     
gstreamer1-libav.x86_64                       1:1.18.4-3.fc34      @rpmfusion-free-updates
gstreamer1-plugin-openh264.x86_64             1.18.2-1.fc34        @fedora-cisco-openh264
gstreamer1-plugins-bad-free.x86_64            1.19.1-3.1.18.4.fc34 @updates     
gstreamer1-plugins-bad-free-extras.x86_64     1.19.1-3.1.18.4.fc34 @updates     
gstreamer1-plugins-bad-free-fluidsynth.x86_64 1.19.1-3.1.18.4.fc34 @updates     
gstreamer1-plugins-bad-free-wildmidi.x86_64   1.19.1-3.1.18.4.fc34 @updates     
gstreamer1-plugins-bad-free-zbar.x86_64       1.19.1-3.1.18.4.fc34 @updates     
gstreamer1-plugins-bad-freeworld.x86_64       1:1.18.4-4.fc34      @rpmfusion-free-updates
gstreamer1-plugins-base.x86_64                1.19.1-2.1.18.4.fc34 @updates     
gstreamer1-plugins-good.x86_64                1.19.1-2.1.18.4.fc34 @updates     
gstreamer1-plugins-good-extras.x86_64         1.19.1-2.1.18.4.fc34 @updates     
gstreamer1-plugins-good-gtk.x86_64            1.19.1-2.1.18.4.fc34 @updates     
gstreamer1-plugins-good-qt.x86_64             1.19.1-2.1.18.4.fc34 @updates     
gstreamer1-plugins-ugly.x86_64                1:1.18.4-2.fc34      @rpmfusion-free-updates
gstreamer1-plugins-ugly-free.x86_64           1.19.1-2.1.18.4.fc34 @updates     

Te fijaste la configuracion de sonido en Zoom y en Configuration (Sistema) ?
Intenta hacer pruebas con otro tipo de programa, gmail, skype.

es el mismo problema que aqui,

Prueba a remover la version del repositorio e instalar la version de flatpak:

https://www.flathub.org/apps/details/us.zoom.Zoom

  1. sudo dnf remove zoom
  2. flatpak install flathub us.zoom.Zoomcontent

NOTA

Te recomendaria que pasaras a pipewire cuando puedas…

Saludos, HTH

Hola @hhlp muchas gracias por la respuesta, de hecho estoy usando la version flatpak y en ese caso sigfue pasando lo mismo, almenos en xorg puedo compartir contenido pero el audio es nulo igual, y si esa pregunta fue lo primero que revise, solo que como esta algo desactualizada. reespecto a lo de pipeware no lo entendi, estoy en pipeware, por eso principalmente creo que es el problema en zoom, Saludos!

Si @zurdenro me fije en la configuracion de zoom, esos paquetes tambien los tengo, aunque lo de gstreamer tendria que revisarlo, estas cosas no me pasan con otros servicios(almenos en xorg), Saludos!

Si usas la version de flatpak entonces haz lo contrario desintala la version de flatpak e instala la de zoom:

Desintalar

  1. flatpak uninstall flathub us.zoom.Zoomcontent

Instalar la de Zoom

sudo dnf install wget -y 
wget https://zoom.us/client/latest/zoom_x86_64.rpm 
sudo dnf install zoom_x86_64.rpm 

Esta version deberia funcionar bien… por lo menos a mi me funciona bien…

zoom-5.7.31792.0820-1.x86_64

NOTA

y verifica que tienes los paquetes que @zurdenro te comento con estos comandos …

rpm -qa \*pipewire\*
rpm -qa \*gstreamer1\*

Saludos.,

Hola @hhlp , perdon la demora en la respuesta, probe con la version rpm y esta me pedia pulseaudio para poder compartir audio, claro, tengo pensado comprobar los paquetes, puede que me falte alguno, solo que ahorita no ando en fedora, apenas tenga el equipo conmigo denuevo lo hare, muchas gracias a ti y a @zurdenro