Error: ../../grub-core/commands/loadenv.c:216:sparse file not allowed

I installed 34 onto my computer in uefi mode, and i am using btrfs file system

but i am getting the following error on every boot:

error: …/…/grub-core/commands/loadenv.c:216:sparse file not allowed.

how can i solve this?

1 Like

Reinstall the system with /boot on Ext4.
1955901 – loadenv.c:216:sparse file not allowed on boot with btrfs /boot

1 Like

Isn’t this an fedora bug?

fedora should work fine in uefi on btrfs!

You need to create a separate /boot partition or use automatic partitioning.
Installing Using Anaconda :: Fedora Docs

1 Like

if i create separate /boot partition, then my system will have both legacy and uefi partition,
since i am new to linux, i have a question

is it ok to have both legacy and uefi partition on my machine?

and also currently i had disabled legacy boot in my bios settings. do i had to enabled it?

ones again thanx for reply :slight_smile:

The /boot partition is different from BIOS Boot.
Installing Using Anaconda :: Fedora Docs

1 Like

Thank you once again , :heart:

1 Like

No it won’t have legacy boot enabled unless you install that way.

The auto install method using uefi creates an esp partition for the efi files, an ext partition for /boot, and the rest is btrfs with 2 subvolumes, /root and /home.
On my VM with a clean install using the automatic partitioning the /boot/efi esp partition is ~400 MB, the /boot ext4 partition is ~1 GB, and the remainder of 35 GB is btrfs.

3 Likes