Error on `dnf upgrade`

Hello,

I tried running sudo dnf upgrade today, and it failed with this error:

Last metadata expiration check: 3:13:19 ago on Wed 25 Aug 2021 16:30:10 BST.
Error: 
 Problem 1: package kernel-modules-extra-5.12.6-300.fc34.x86_64 requires kernel-uname-r = 5.12.6-300.fc34.x86_64, but none of the providers can be installed
  - conflicting requests
 Problem 2: package kernel-5.12.6-300.fc34.x86_64 requires kernel-core-uname-r = 5.12.6-300.fc34.x86_64, but none of the providers can be installed
  - conflicting requests
(try to add '--skip-broken' to skip uninstallable packages)

After some googling, I saw that this might have something to do with duplicate packages, and to check the output of dnf check --duplicates. Sure enough, here is its output:

SDL2-2.0.14-3.fc34.x86_64 is a duplicate with SDL2-2.0.16-1.fc34.x86_64
appstream-0.14.3-2.fc34.x86_64 is a duplicate with appstream-0.14.4-2.fc34.x86_64
at-spi2-core-2.40.1-1.fc34.x86_64 is a duplicate with at-spi2-core-2.40.3-1.fc34.x86_64
audit-libs-3.0.3-1.fc34.x86_64 is a duplicate with audit-libs-3.0.5-1.fc34.x86_64
avahi-libs-0.8-9.fc34.i686 is a duplicate with avahi-libs-0.8-14.fc34.x86_64
avahi-libs-0.8-9.fc34.i686 is a duplicate with avahi-libs-0.8-9.fc34.x86_64
binutils-2.35.1-41.fc34.x86_64 is a duplicate with binutils-2.35.2-4.fc34.x86_64
binutils-gold-2.35.1-41.fc34.x86_64 is a duplicate with binutils-gold-2.35.2-4.fc34.x86_64
clang-resource-filesystem-12.0.0-2.fc34.x86_64 is a duplicate with clang-resource-filesystem-12.0.1-1.fc34.x86_64
code-1.58.2-1626302881.el8.x86_64 is a duplicate with code-1.59.0-1628120127.el8.x86_64
compiler-rt-12.0.0-3.fc34.x86_64 is a duplicate with compiler-rt-12.0.1-1.fc34.x86_64
emacs-common-1:28.0.50-1.20210717.git6376722.fc34.x86_64 is a duplicate with emacs-common-1:28.0.50-1.20210814.git92bc69e.fc34.x86_64
emacs-filesystem-1:28.0.50-1.20210717.git6376722.fc34.noarch is a duplicate with emacs-filesystem-1:28.0.50-1.20210814.git92bc69e.fc34.noarch
evince-40.1-2.fc34.x86_64 is a duplicate with evince-40.4-1.fc34.x86_64
evince-djvu-40.1-2.fc34.x86_64 is a duplicate with evince-djvu-40.4-1.fc34.x86_64
evince-libs-40.1-2.fc34.x86_64 is a duplicate with evince-libs-40.4-1.fc34.x86_64
evince-previewer-40.1-2.fc34.x86_64 is a duplicate with evince-previewer-40.4-1.fc34.x86_64
evince-thumbnailer-40.1-2.fc34.x86_64 is a duplicate with evince-thumbnailer-40.4-1.fc34.x86_64
evolution-data-server-3.40.3-1.fc34.x86_64 is a duplicate with evolution-data-server-3.40.4-1.fc34.x86_64
evolution-data-server-langpacks-3.40.3-1.fc34.noarch is a duplicate with evolution-data-server-langpacks-3.40.4-1.fc34.noarch
folks-1:0.15.2-2.fc34.x86_64 is a duplicate with folks-1:0.15.3-1.fc34.x86_64
glib2-2.68.2-1.fc34.x86_64 is a duplicate with glib2-2.68.3-1.fc34.x86_64
glib2-devel-2.68.2-1.fc34.x86_64 is a duplicate with glib2-devel-2.68.3-1.fc34.x86_64
gnome-desktop3-40.1-1.fc34.x86_64 is a duplicate with gnome-desktop3-40.3-1.fc34.x86_64
hwdata-0.349-1.fc34.noarch is a duplicate with hwdata-0.350-1.fc34.noarch
libX11-1.7.0-3.fc34.i686 is a duplicate with libX11-1.7.0-3.fc34.x86_64
libX11-1.7.0-3.fc34.i686 is a duplicate with libX11-1.7.2-3.fc34.x86_64
libX11-common-1.7.0-3.fc34.noarch is a duplicate with libX11-common-1.7.2-3.fc34.noarch
libX11-devel-1.7.0-3.fc34.x86_64 is a duplicate with libX11-devel-1.7.2-3.fc34.x86_64
libX11-xcb-1.7.0-3.fc34.i686 is a duplicate with libX11-xcb-1.7.0-3.fc34.x86_64
libX11-xcb-1.7.0-3.fc34.i686 is a duplicate with libX11-xcb-1.7.2-3.fc34.x86_64
libblockdev-2.25-2.fc34.x86_64 is a duplicate with libblockdev-2.26-1.fc34.x86_64
libblockdev-btrfs-2.25-2.fc34.x86_64 is a duplicate with libblockdev-btrfs-2.26-1.fc34.x86_64
libblockdev-crypto-2.25-2.fc34.x86_64 is a duplicate with libblockdev-crypto-2.26-1.fc34.x86_64
libblockdev-dm-2.25-2.fc34.x86_64 is a duplicate with libblockdev-dm-2.26-1.fc34.x86_64
libblockdev-fs-2.25-2.fc34.x86_64 is a duplicate with libblockdev-fs-2.26-1.fc34.x86_64
libblockdev-kbd-2.25-2.fc34.x86_64 is a duplicate with libblockdev-kbd-2.26-1.fc34.x86_64
libblockdev-loop-2.25-2.fc34.x86_64 is a duplicate with libblockdev-loop-2.26-1.fc34.x86_64
libblockdev-lvm-2.25-2.fc34.x86_64 is a duplicate with libblockdev-lvm-2.26-1.fc34.x86_64
libblockdev-mdraid-2.25-2.fc34.x86_64 is a duplicate with libblockdev-mdraid-2.26-1.fc34.x86_64
libblockdev-mpath-2.25-2.fc34.x86_64 is a duplicate with libblockdev-mpath-2.26-1.fc34.x86_64
libblockdev-nvdimm-2.25-2.fc34.x86_64 is a duplicate with libblockdev-nvdimm-2.26-1.fc34.x86_64
libblockdev-part-2.25-2.fc34.x86_64 is a duplicate with libblockdev-part-2.26-1.fc34.x86_64
libblockdev-swap-2.25-2.fc34.x86_64 is a duplicate with libblockdev-swap-2.26-1.fc34.x86_64
libblockdev-utils-2.25-2.fc34.x86_64 is a duplicate with libblockdev-utils-2.26-1.fc34.x86_64
libepoxy-1.5.8-1.fc34.i686 is a duplicate with libepoxy-1.5.8-1.fc34.x86_64
libepoxy-1.5.8-1.fc34.i686 is a duplicate with libepoxy-1.5.9-1.fc34.x86_64
libhandy-1.2.2-1.fc34.x86_64 is a duplicate with libhandy-1.2.3-1.fc34.x86_64
libmwaw-0.3.19-1.fc34.x86_64 is a duplicate with libmwaw-0.3.20-1.fc34.x86_64
libomp-devel-12.0.0-1.fc34.x86_64 is a duplicate with libomp-devel-12.0.1-1.fc34.x86_64
libpwquality-1.4.4-2.fc34.x86_64 is a duplicate with libpwquality-1.4.4-6.fc34.x86_64
libreoffice-data-1:7.1.5.2-1.fc34.noarch is a duplicate with libreoffice-data-1:7.1.5.2-5.fc34.noarch
librsvg2-2.50.6-1.fc34.x86_64 is a duplicate with librsvg2-2.50.7-1.fc34.x86_64
libudisks2-2.9.2-2.fc34.x86_64 is a duplicate with libudisks2-2.9.3-1.fc34.x86_64
libwebp-1.2.0-1.fc34.i686 is a duplicate with libwebp-1.2.0-1.fc34.x86_64
libwebp-1.2.0-1.fc34.i686 is a duplicate with libwebp-1.2.1-1.fc34.x86_64
libxcrypt-4.4.23-1.fc34.i686 is a duplicate with libxcrypt-4.4.23-1.fc34.x86_64
libxcrypt-4.4.23-1.fc34.i686 is a duplicate with libxcrypt-4.4.25-1.fc34.x86_64
llvm-libs-12.0.0-2.fc34.i686 is a duplicate with llvm-libs-12.0.0-2.fc34.x86_64
llvm-libs-12.0.0-2.fc34.i686 is a duplicate with llvm-libs-12.0.1-1.fc34.x86_64
mesa-libGL-21.1.5-1.fc34.i686 is a duplicate with mesa-libGL-21.1.5-1.fc34.x86_64
mesa-libGL-21.1.5-1.fc34.i686 is a duplicate with mesa-libGL-21.1.7-1.fc34.x86_64
mesa-libgbm-21.1.5-1.fc34.x86_64 is a duplicate with mesa-libgbm-21.1.7-1.fc34.x86_64
mesa-libglapi-21.1.5-1.fc34.i686 is a duplicate with mesa-libglapi-21.1.5-1.fc34.x86_64
mesa-libglapi-21.1.5-1.fc34.i686 is a duplicate with mesa-libglapi-21.1.7-1.fc34.x86_64
nautilus-extensions-40.1-2.fc34.x86_64 is a duplicate with nautilus-extensions-40.2-1.fc34.x86_64
net-snmp-libs-1:5.9.1-3.fc34.x86_64 is a duplicate with net-snmp-libs-1:5.9.1-4.fc34.x86_64
nspr-4.31.0-1.fc34.i686 is a duplicate with nspr-4.31.0-1.fc34.x86_64
nspr-4.31.0-1.fc34.i686 is a duplicate with nspr-4.32.0-1.fc34.x86_64
nss-3.67.0-1.fc34.i686 is a duplicate with nss-3.67.0-1.fc34.x86_64
nss-3.67.0-1.fc34.i686 is a duplicate with nss-3.69.0-1.fc34.x86_64
nss-softokn-3.67.0-1.fc34.i686 is a duplicate with nss-softokn-3.67.0-1.fc34.x86_64
nss-softokn-3.67.0-1.fc34.i686 is a duplicate with nss-softokn-3.69.0-1.fc34.x86_64
nss-softokn-freebl-3.67.0-1.fc34.i686 is a duplicate with nss-softokn-freebl-3.67.0-1.fc34.x86_64
nss-softokn-freebl-3.67.0-1.fc34.i686 is a duplicate with nss-softokn-freebl-3.69.0-1.fc34.x86_64
nss-sysinit-3.67.0-1.fc34.x86_64 is a duplicate with nss-sysinit-3.69.0-1.fc34.x86_64
nss-util-3.67.0-1.fc34.i686 is a duplicate with nss-util-3.67.0-1.fc34.x86_64
nss-util-3.67.0-1.fc34.i686 is a duplicate with nss-util-3.69.0-1.fc34.x86_64
pango-1.48.7-1.fc34.x86_64 is a duplicate with pango-1.48.8-1.fc34.x86_64
selinux-policy-34.14-1.fc34.noarch is a duplicate with selinux-policy-34.16-1.fc34.noarch
selinux-policy-targeted-34.14-1.fc34.noarch is a duplicate with selinux-policy-targeted-34.16-1.fc34.noarch
shadow-utils-2:4.8.1-8.fc34.x86_64 is a duplicate with shadow-utils-2:4.8.1-9.fc34.x86_64
systemd-248.6-1.fc34.x86_64 is a duplicate with systemd-248.7-1.fc34.x86_64
systemd-libs-248.6-1.fc34.i686 is a duplicate with systemd-libs-248.6-1.fc34.x86_64
systemd-libs-248.6-1.fc34.i686 is a duplicate with systemd-libs-248.7-1.fc34.x86_64
systemd-networkd-248.6-1.fc34.x86_64 is a duplicate with systemd-networkd-248.7-1.fc34.x86_64
systemd-pam-248.6-1.fc34.x86_64 is a duplicate with systemd-pam-248.7-1.fc34.x86_64
systemd-rpm-macros-248.6-1.fc34.noarch is a duplicate with systemd-rpm-macros-248.7-1.fc34.noarch
systemd-udev-248.6-1.fc34.x86_64 is a duplicate with systemd-udev-248.7-1.fc34.x86_64
udisks2-2.9.2-2.fc34.x86_64 is a duplicate with udisks2-2.9.3-1.fc34.x86_64
usbutils-013-2.fc34.x86_64 is a duplicate with usbutils-014-1.fc34.x86_64
vim-common-2:8.2.3223-1.fc34.x86_64 is a duplicate with vim-common-2:8.2.3318-1.fc34.x86_64
vim-filesystem-2:8.2.3223-1.fc34.noarch is a duplicate with vim-filesystem-2:8.2.3318-1.fc34.noarch
volume_key-libs-0.3.12-11.fc34.x86_64 is a duplicate with volume_key-libs-0.3.12-14.fc34.x86_64
yelp-libs-2:40.0-1.fc34.x86_64 is a duplicate with yelp-libs-2:40.3-1.fc34.x86_64
yelp-xsl-40.0-1.fc34.noarch is a duplicate with yelp-xsl-40.2-1.fc34.noarch
Error: Check discovered 96 problem(s)

Where do I go from here? I cannot upgrade, and apparently I have a bunch of duplicate packages on my system.

Thanks

Does the answer here

help?

1 Like

It does not work.

$ sudo dnf distro-sync
Last metadata expiration check: 0:00:16 ago on Wed 25 Aug 2021 20:15:40 BST.
Error: 
 Problem 1: package kernel-modules-extra-5.12.6-300.fc34.x86_64 requires kernel-uname-r = 5.12.6-300.fc34.x86_64, but none of the providers can be installed
  - conflicting requests
 Problem 2: package kernel-5.12.6-300.fc34.x86_64 requires kernel-core-uname-r = 5.12.6-300.fc34.x86_64, but none of the providers can be installed
  - conflicting requests
(try to add '--skip-broken' to skip uninstallable packages)

and

$ sudo dnf remove --duplicates
Last metadata expiration check: 0:03:27 ago on Wed 25 Aug 2021 20:15:40 BST.
Installed package glib2-devel-2.68.3-1.fc34.x86_64 not available.
Installed package glib2-2.68.3-1.fc34.x86_64 not available.
Installed package binutils-gold-2.35.2-4.fc34.x86_64 not available.
Installed package binutils-2.35.2-4.fc34.x86_64 not available.
Installed package pango-1.48.8-1.fc34.x86_64 not available.
Installed package gnome-desktop3-40.3-1.fc34.x86_64 not available.
Installed package vim-filesystem-2:8.2.3318-1.fc34.noarch not available.
Installed package vim-common-2:8.2.3318-1.fc34.x86_64 not available.
Error: 
 Problem 1: problem with installed package pango-devel-1.48.7-1.fc34.x86_64
  - package pango-devel-1.48.9-1.fc34.x86_64 requires pango(x86-64) = 1.48.9-1.fc34, but none of the providers can be installed
  - package pango-devel-1.48.4-1.fc34.x86_64 requires pango(x86-64) = 1.48.4-1.fc34, but none of the providers can be installed
  - package pango-devel-1.48.7-1.fc34.x86_64 requires pango(x86-64) = 1.48.7-1.fc34, but none of the providers can be installed
  - conflicting requests
 Problem 2: problem with installed package vim-enhanced-2:8.2.3223-1.fc34.x86_64
  - package vim-enhanced-2:8.2.3354-1.fc34.x86_64 requires vim-common = 2:8.2.3354-1.fc34, but none of the providers can be installed
  - package vim-enhanced-2:8.2.2637-1.fc34.x86_64 requires vim-common = 2:8.2.2637-1.fc34, but none of the providers can be installed
  - package vim-enhanced-2:8.2.3223-1.fc34.x86_64 requires vim-common = 2:8.2.3223-1.fc34, but none of the providers can be installed
  - conflicting requests
(try to add '--skip-broken' to skip uninstallable packages)

Could this have anything to do with the repos I have available? I was thinking I might have repos providing the same package:

$ dnf repolist
repo id                                                            repo name
code                                                               Visual Studio Code
copr:copr.fedorainfracloud.org:deathwish:emacs-pgtk-nativecomp     Copr repo for emacs-pgtk-nativecomp owned by deathwish
copr:copr.fedorainfracloud.org:name:OpenRGB                        Copr repo for OpenRGB owned by name
copr:copr.fedorainfracloud.org:zirix:gdm-wallpaper                 Copr repo for gdm-wallpaper owned by zirix
fedora                                                             Fedora 34 - x86_64
fedora-cisco-openh264                                              Fedora 34 openh264 (From Cisco) - x86_64
fedora-modular                                                     Fedora Modular 34 - x86_64
gh-cli                                                             packages for the GitHub CLI
google-chrome                                                      google-chrome
mysql-connectors-community                                         MySQL Connectors Community
mysql-tools-community                                              MySQL Tools Community
mysql80-community                                                  MySQL 8.0 Community Server
rpmfusion-free                                                     RPM Fusion for Fedora 34 - Free
rpmfusion-free-updates                                             RPM Fusion for Fedora 34 - Free - Updates
rpmfusion-nonfree                                                  RPM Fusion for Fedora 34 - Nonfree
rpmfusion-nonfree-steam                                            RPM Fusion for Fedora 34 - Nonfree - Steam
rpmfusion-nonfree-updates                                          RPM Fusion for Fedora 34 - Nonfree - Updates
teams                                                              teams
teamviewer                                                         TeamViewer - x86_64
updates                                                            Fedora 34 - x86_64 - Updates
updates-modular                                                    Fedora Modular 34 - x86_64 - Updates

What happens if you add --skip-broken?

1 Like
sudo rpm --rebuilddb
sudo rpm --nodeps -e kernel-modules-extra-5.12.6-300.fc34.x86_64
sudo dnf install kernel-modules-extra

Then proceed with the above instructions to remove duplicates.

$ sudo dnf upgrade --skip-broken
Last metadata expiration check: 0:01:01 ago on Thu 26 Aug 2021 10:20:52 BST.
Error: 
 Problem 1: package kernel-modules-extra-5.12.6-300.fc34.x86_64 requires kernel-uname-r = 5.12.6-300.fc34.x86_64, but none of the providers can be installed
  - conflicting requests
 Problem 2: package kernel-5.12.6-300.fc34.x86_64 requires kernel-core-uname-r = 5.12.6-300.fc34.x86_64, but none of the providers can be installed
  - conflicting requests

I tried the fix and it made the original error go away, but now I’m getting something else.

$ sudo rpm --rebuilddb
$ sudo rpm --nodeps -e kernel-modules-extra-5.12.6-300.fc34.x86_64

$ sudo dnf install kernel-modules-extra
Last metadata expiration check: 0:03:00 ago on Thu 26 Aug 2021 10:20:52 BST.
Package kernel-modules-extra-5.11.20-300.fc34.x86_64 is already installed.
Package kernel-modules-extra-5.13.6-200.fc34.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!

$ sudo dnf distro-sync
Last metadata expiration check: 0:03:10 ago on Thu 26 Aug 2021 10:20:52 BST.
Error: 
 Problem: package kernel-5.12.6-300.fc34.x86_64 requires kernel-core-uname-r = 5.12.6-300.fc34.x86_64, but none of the providers can be installed
  - conflicting requests
(try to add '--skip-broken' to skip uninstallable packages)

$ sudo rpm --nodeps -e kernel-5.12.6-300.fc34.x86_64

$ sudo dnf install kernel
Last metadata expiration check: 0:03:52 ago on Thu 26 Aug 2021 10:20:52 BST.
Package kernel-5.11.20-300.fc34.x86_64 is already installed.
Package kernel-5.13.6-200.fc34.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!

$ sudo dnf distro-sync
Last metadata expiration check: 0:03:59 ago on Thu 26 Aug 2021 10:20:52 BST.
Error: 
 Problem: The operation would result in removing the following protected packages: systemd, systemd-udev
(try to add '--skip-broken' to skip uninstallable packages)
1 Like
sudo dnf -q repoquery --duplicates
sudo dnf remove --duplicates
$ sudo dnf -q repoquery --duplicates
[sudo] password for mpardalos: 
SDL2-0:2.0.14-3.fc34.x86_64
SDL2-0:2.0.16-1.fc34.x86_64
appstream-0:0.14.3-2.fc34.x86_64
appstream-0:0.14.4-2.fc34.x86_64
at-spi2-core-0:2.40.1-1.fc34.x86_64
at-spi2-core-0:2.40.3-1.fc34.x86_64
audit-libs-0:3.0.3-1.fc34.x86_64
audit-libs-0:3.0.5-1.fc34.x86_64
avahi-libs-0:0.8-14.fc34.x86_64
avahi-libs-0:0.8-9.fc34.i686
avahi-libs-0:0.8-9.fc34.x86_64
binutils-0:2.35.1-41.fc34.x86_64
binutils-0:2.35.2-4.fc34.x86_64
binutils-gold-0:2.35.1-41.fc34.x86_64
binutils-gold-0:2.35.2-4.fc34.x86_64
clang-resource-filesystem-0:12.0.0-2.fc34.x86_64
clang-resource-filesystem-0:12.0.1-1.fc34.x86_64
code-0:1.58.2-1626302881.el8.x86_64
code-0:1.59.0-1628120127.el8.x86_64
compiler-rt-0:12.0.0-3.fc34.x86_64
compiler-rt-0:12.0.1-1.fc34.x86_64
emacs-common-1:28.0.50-1.20210717.git6376722.fc34.x86_64
emacs-common-1:28.0.50-1.20210814.git92bc69e.fc34.x86_64
emacs-filesystem-1:28.0.50-1.20210717.git6376722.fc34.noarch
emacs-filesystem-1:28.0.50-1.20210814.git92bc69e.fc34.noarch
evince-0:40.1-2.fc34.x86_64
evince-0:40.4-1.fc34.x86_64
evince-djvu-0:40.1-2.fc34.x86_64
evince-djvu-0:40.4-1.fc34.x86_64
evince-libs-0:40.1-2.fc34.x86_64
evince-libs-0:40.4-1.fc34.x86_64
evince-previewer-0:40.1-2.fc34.x86_64
evince-previewer-0:40.4-1.fc34.x86_64
evince-thumbnailer-0:40.1-2.fc34.x86_64
evince-thumbnailer-0:40.4-1.fc34.x86_64
evolution-data-server-0:3.40.3-1.fc34.x86_64
evolution-data-server-0:3.40.4-1.fc34.x86_64
evolution-data-server-langpacks-0:3.40.3-1.fc34.noarch
evolution-data-server-langpacks-0:3.40.4-1.fc34.noarch
folks-1:0.15.2-2.fc34.x86_64
folks-1:0.15.3-1.fc34.x86_64
glib2-0:2.68.2-1.fc34.x86_64
glib2-0:2.68.3-1.fc34.x86_64
glib2-devel-0:2.68.2-1.fc34.x86_64
glib2-devel-0:2.68.3-1.fc34.x86_64
gnome-desktop3-0:40.1-1.fc34.x86_64
gnome-desktop3-0:40.3-1.fc34.x86_64
hwdata-0:0.349-1.fc34.noarch
hwdata-0:0.350-1.fc34.noarch
libX11-0:1.7.0-3.fc34.i686
libX11-0:1.7.0-3.fc34.x86_64
libX11-0:1.7.2-3.fc34.x86_64
libX11-common-0:1.7.0-3.fc34.noarch
libX11-common-0:1.7.2-3.fc34.noarch
libX11-devel-0:1.7.0-3.fc34.x86_64
libX11-devel-0:1.7.2-3.fc34.x86_64
libX11-xcb-0:1.7.0-3.fc34.i686
libX11-xcb-0:1.7.0-3.fc34.x86_64
libX11-xcb-0:1.7.2-3.fc34.x86_64
libblockdev-0:2.25-2.fc34.x86_64
libblockdev-0:2.26-1.fc34.x86_64
libblockdev-btrfs-0:2.25-2.fc34.x86_64
libblockdev-btrfs-0:2.26-1.fc34.x86_64
libblockdev-crypto-0:2.25-2.fc34.x86_64
libblockdev-crypto-0:2.26-1.fc34.x86_64
libblockdev-dm-0:2.25-2.fc34.x86_64
libblockdev-dm-0:2.26-1.fc34.x86_64
libblockdev-fs-0:2.25-2.fc34.x86_64
libblockdev-fs-0:2.26-1.fc34.x86_64
libblockdev-kbd-0:2.25-2.fc34.x86_64
libblockdev-kbd-0:2.26-1.fc34.x86_64
libblockdev-loop-0:2.25-2.fc34.x86_64
libblockdev-loop-0:2.26-1.fc34.x86_64
libblockdev-lvm-0:2.25-2.fc34.x86_64
libblockdev-lvm-0:2.26-1.fc34.x86_64
libblockdev-mdraid-0:2.25-2.fc34.x86_64
libblockdev-mdraid-0:2.26-1.fc34.x86_64
libblockdev-mpath-0:2.25-2.fc34.x86_64
libblockdev-mpath-0:2.26-1.fc34.x86_64
libblockdev-nvdimm-0:2.25-2.fc34.x86_64
libblockdev-nvdimm-0:2.26-1.fc34.x86_64
libblockdev-part-0:2.25-2.fc34.x86_64
libblockdev-part-0:2.26-1.fc34.x86_64
libblockdev-swap-0:2.25-2.fc34.x86_64
libblockdev-swap-0:2.26-1.fc34.x86_64
libblockdev-utils-0:2.25-2.fc34.x86_64
libblockdev-utils-0:2.26-1.fc34.x86_64
libepoxy-0:1.5.8-1.fc34.i686
libepoxy-0:1.5.8-1.fc34.x86_64
libepoxy-0:1.5.9-1.fc34.x86_64
libhandy-0:1.2.2-1.fc34.x86_64
libhandy-0:1.2.3-1.fc34.x86_64
libmwaw-0:0.3.19-1.fc34.x86_64
libmwaw-0:0.3.20-1.fc34.x86_64
libomp-devel-0:12.0.0-1.fc34.x86_64
libomp-devel-0:12.0.1-1.fc34.x86_64
libpwquality-0:1.4.4-2.fc34.x86_64
libpwquality-0:1.4.4-6.fc34.x86_64
libreoffice-data-1:7.1.5.2-1.fc34.noarch
libreoffice-data-1:7.1.5.2-5.fc34.noarch
librsvg2-0:2.50.6-1.fc34.x86_64
librsvg2-0:2.50.7-1.fc34.x86_64
libudisks2-0:2.9.2-2.fc34.x86_64
libudisks2-0:2.9.3-1.fc34.x86_64
libwebp-0:1.2.0-1.fc34.i686
libwebp-0:1.2.0-1.fc34.x86_64
libwebp-0:1.2.1-1.fc34.x86_64
libxcrypt-0:4.4.23-1.fc34.i686
libxcrypt-0:4.4.23-1.fc34.x86_64
libxcrypt-0:4.4.25-1.fc34.x86_64
llvm-libs-0:12.0.0-2.fc34.i686
llvm-libs-0:12.0.0-2.fc34.x86_64
llvm-libs-0:12.0.1-1.fc34.x86_64
mesa-libGL-0:21.1.5-1.fc34.i686
mesa-libGL-0:21.1.5-1.fc34.x86_64
mesa-libGL-0:21.1.7-1.fc34.x86_64
mesa-libgbm-0:21.1.5-1.fc34.x86_64
mesa-libgbm-0:21.1.7-1.fc34.x86_64
mesa-libglapi-0:21.1.5-1.fc34.i686
mesa-libglapi-0:21.1.5-1.fc34.x86_64
mesa-libglapi-0:21.1.7-1.fc34.x86_64
nautilus-extensions-0:40.1-2.fc34.x86_64
nautilus-extensions-0:40.2-1.fc34.x86_64
net-snmp-libs-1:5.9.1-3.fc34.x86_64
net-snmp-libs-1:5.9.1-4.fc34.x86_64
nspr-0:4.31.0-1.fc34.i686
nspr-0:4.31.0-1.fc34.x86_64
nspr-0:4.32.0-1.fc34.x86_64
nss-0:3.67.0-1.fc34.i686
nss-0:3.67.0-1.fc34.x86_64
nss-0:3.69.0-1.fc34.x86_64
nss-softokn-0:3.67.0-1.fc34.i686
nss-softokn-0:3.67.0-1.fc34.x86_64
nss-softokn-0:3.69.0-1.fc34.x86_64
nss-softokn-freebl-0:3.67.0-1.fc34.i686
nss-softokn-freebl-0:3.67.0-1.fc34.x86_64
nss-softokn-freebl-0:3.69.0-1.fc34.x86_64
nss-sysinit-0:3.67.0-1.fc34.x86_64
nss-sysinit-0:3.69.0-1.fc34.x86_64
nss-util-0:3.67.0-1.fc34.i686
nss-util-0:3.67.0-1.fc34.x86_64
nss-util-0:3.69.0-1.fc34.x86_64
pango-0:1.48.7-1.fc34.x86_64
pango-0:1.48.8-1.fc34.x86_64
selinux-policy-0:34.14-1.fc34.noarch
selinux-policy-0:34.16-1.fc34.noarch
selinux-policy-targeted-0:34.14-1.fc34.noarch
selinux-policy-targeted-0:34.16-1.fc34.noarch
shadow-utils-2:4.8.1-8.fc34.x86_64
shadow-utils-2:4.8.1-9.fc34.x86_64
systemd-0:248.6-1.fc34.x86_64
systemd-0:248.7-1.fc34.x86_64
systemd-libs-0:248.6-1.fc34.i686
systemd-libs-0:248.6-1.fc34.x86_64
systemd-libs-0:248.7-1.fc34.x86_64
systemd-networkd-0:248.6-1.fc34.x86_64
systemd-networkd-0:248.7-1.fc34.x86_64
systemd-pam-0:248.6-1.fc34.x86_64
systemd-pam-0:248.7-1.fc34.x86_64
systemd-rpm-macros-0:248.6-1.fc34.noarch
systemd-rpm-macros-0:248.7-1.fc34.noarch
systemd-udev-0:248.6-1.fc34.x86_64
systemd-udev-0:248.7-1.fc34.x86_64
udisks2-0:2.9.2-2.fc34.x86_64
udisks2-0:2.9.3-1.fc34.x86_64
usbutils-0:013-2.fc34.x86_64
usbutils-0:014-1.fc34.x86_64
vim-common-2:8.2.3223-1.fc34.x86_64
vim-common-2:8.2.3318-1.fc34.x86_64
vim-filesystem-2:8.2.3223-1.fc34.noarch
vim-filesystem-2:8.2.3318-1.fc34.noarch
volume_key-libs-0:0.3.12-11.fc34.x86_64
volume_key-libs-0:0.3.12-14.fc34.x86_64
yelp-libs-2:40.0-1.fc34.x86_64
yelp-libs-2:40.3-1.fc34.x86_64
yelp-xsl-0:40.0-1.fc34.noarch
yelp-xsl-0:40.2-1.fc34.noarch
$ sudo dnf remove --duplicates
Last metadata expiration check: 0:15:50 ago on Thu 26 Aug 2021 10:20:52 BST.
Installed package glib2-devel-2.68.3-1.fc34.x86_64 not available.
Installed package SDL2-2.0.16-1.fc34.x86_64 not available.
Installed package glib2-2.68.3-1.fc34.x86_64 not available.
Installed package binutils-gold-2.35.2-4.fc34.x86_64 not available.
Installed package binutils-2.35.2-4.fc34.x86_64 not available.
Installed package pango-1.48.8-1.fc34.x86_64 not available.
Installed package gnome-desktop3-40.3-1.fc34.x86_64 not available.
Installed package vim-filesystem-2:8.2.3318-1.fc34.noarch not available.
Installed package vim-common-2:8.2.3318-1.fc34.x86_64 not available.
Error: 
 Problem 1: problem with installed package pango-devel-1.48.7-1.fc34.x86_64
  - package pango-devel-1.48.9-1.fc34.x86_64 requires pango(x86-64) = 1.48.9-1.fc34, but none of the providers can be installed
  - package pango-devel-1.48.4-1.fc34.x86_64 requires pango(x86-64) = 1.48.4-1.fc34, but none of the providers can be installed
  - package pango-devel-1.48.7-1.fc34.x86_64 requires pango(x86-64) = 1.48.7-1.fc34, but none of the providers can be installed
  - conflicting requests
 Problem 2: problem with installed package vim-enhanced-2:8.2.3223-1.fc34.x86_64
  - package vim-enhanced-2:8.2.3367-1.fc34.x86_64 requires vim-common = 2:8.2.3367-1.fc34, but none of the providers can be installed
  - package vim-enhanced-2:8.2.2637-1.fc34.x86_64 requires vim-common = 2:8.2.2637-1.fc34, but none of the providers can be installed
  - package vim-enhanced-2:8.2.3223-1.fc34.x86_64 requires vim-common = 2:8.2.3223-1.fc34, but none of the providers can be installed
  - conflicting requests
(try to add '--skip-broken' to skip uninstallable packages)
1 Like
sudo dnf remove --duplicates --skip-broken
sudo dnf distro-sync --skip-broken

It didn’t work :confused:

Could I maybe remove the duplicate packages directly?

$ sudo dnf remove --duplicates --skip-broken
[sudo] password for mpardalos: 
Last metadata expiration check: 0:08:36 ago on Thu 26 Aug 2021 10:40:46 BST.
Installed package glib2-devel-2.68.3-1.fc34.x86_64 not available.
Installed package SDL2-2.0.16-1.fc34.x86_64 not available.
Installed package glib2-2.68.3-1.fc34.x86_64 not available.
Installed package binutils-gold-2.35.2-4.fc34.x86_64 not available.
Installed package binutils-2.35.2-4.fc34.x86_64 not available.
Installed package pango-1.48.8-1.fc34.x86_64 not available.
Installed package gnome-desktop3-40.3-1.fc34.x86_64 not available.
Installed package vim-filesystem-2:8.2.3318-1.fc34.noarch not available.
Installed package vim-common-2:8.2.3318-1.fc34.x86_64 not available.
Error: 
 Problem 1: problem with installed package pango-devel-1.48.7-1.fc34.x86_64
  - package pango-devel-1.48.9-1.fc34.x86_64 requires pango(x86-64) = 1.48.9-1.fc34, but none of the providers can be installed
  - package pango-devel-1.48.4-1.fc34.x86_64 requires pango(x86-64) = 1.48.4-1.fc34, but none of the providers can be installed
  - package pango-devel-1.48.7-1.fc34.x86_64 requires pango(x86-64) = 1.48.7-1.fc34, but none of the providers can be installed
  - conflicting requests
 Problem 2: problem with installed package vim-enhanced-2:8.2.3223-1.fc34.x86_64
  - package vim-enhanced-2:8.2.3367-1.fc34.x86_64 requires vim-common = 2:8.2.3367-1.fc34, but none of the providers can be installed
  - package vim-enhanced-2:8.2.2637-1.fc34.x86_64 requires vim-common = 2:8.2.2637-1.fc34, but none of the providers can be installed
  - package vim-enhanced-2:8.2.3223-1.fc34.x86_64 requires vim-common = 2:8.2.3223-1.fc34, but none of the providers can be installed
  - conflicting requests

$ sudo dnf distro-sync --skip-broken
Last metadata expiration check: 0:08:51 ago on Thu 26 Aug 2021 10:40:46 BST.
Error: 
 Problem: The operation would result in removing the following protected packages: systemd, systemd-udev

$ sudo dnf -q repoquery --duplicates
SDL2-0:2.0.14-3.fc34.x86_64
SDL2-0:2.0.16-1.fc34.x86_64
appstream-0:0.14.3-2.fc34.x86_64
appstream-0:0.14.4-2.fc34.x86_64
at-spi2-core-0:2.40.1-1.fc34.x86_64
at-spi2-core-0:2.40.3-1.fc34.x86_64
audit-libs-0:3.0.3-1.fc34.x86_64
audit-libs-0:3.0.5-1.fc34.x86_64
avahi-libs-0:0.8-14.fc34.x86_64
avahi-libs-0:0.8-9.fc34.i686
avahi-libs-0:0.8-9.fc34.x86_64
binutils-0:2.35.1-41.fc34.x86_64
binutils-0:2.35.2-4.fc34.x86_64
binutils-gold-0:2.35.1-41.fc34.x86_64
binutils-gold-0:2.35.2-4.fc34.x86_64
clang-resource-filesystem-0:12.0.0-2.fc34.x86_64
clang-resource-filesystem-0:12.0.1-1.fc34.x86_64
code-0:1.58.2-1626302881.el8.x86_64
code-0:1.59.0-1628120127.el8.x86_64
compiler-rt-0:12.0.0-3.fc34.x86_64
compiler-rt-0:12.0.1-1.fc34.x86_64
emacs-common-1:28.0.50-1.20210717.git6376722.fc34.x86_64
emacs-common-1:28.0.50-1.20210814.git92bc69e.fc34.x86_64
emacs-filesystem-1:28.0.50-1.20210717.git6376722.fc34.noarch
emacs-filesystem-1:28.0.50-1.20210814.git92bc69e.fc34.noarch
evince-0:40.1-2.fc34.x86_64
evince-0:40.4-1.fc34.x86_64
evince-djvu-0:40.1-2.fc34.x86_64
evince-djvu-0:40.4-1.fc34.x86_64
evince-libs-0:40.1-2.fc34.x86_64
evince-libs-0:40.4-1.fc34.x86_64
evince-previewer-0:40.1-2.fc34.x86_64
evince-previewer-0:40.4-1.fc34.x86_64
evince-thumbnailer-0:40.1-2.fc34.x86_64
evince-thumbnailer-0:40.4-1.fc34.x86_64
evolution-data-server-0:3.40.3-1.fc34.x86_64
evolution-data-server-0:3.40.4-1.fc34.x86_64
evolution-data-server-langpacks-0:3.40.3-1.fc34.noarch
evolution-data-server-langpacks-0:3.40.4-1.fc34.noarch
folks-1:0.15.2-2.fc34.x86_64
folks-1:0.15.3-1.fc34.x86_64
glib2-0:2.68.2-1.fc34.x86_64
glib2-0:2.68.3-1.fc34.x86_64
glib2-devel-0:2.68.2-1.fc34.x86_64
glib2-devel-0:2.68.3-1.fc34.x86_64
gnome-desktop3-0:40.1-1.fc34.x86_64
gnome-desktop3-0:40.3-1.fc34.x86_64
hwdata-0:0.349-1.fc34.noarch
hwdata-0:0.350-1.fc34.noarch
libX11-0:1.7.0-3.fc34.i686
libX11-0:1.7.0-3.fc34.x86_64
libX11-0:1.7.2-3.fc34.x86_64
libX11-common-0:1.7.0-3.fc34.noarch
libX11-common-0:1.7.2-3.fc34.noarch
libX11-devel-0:1.7.0-3.fc34.x86_64
libX11-devel-0:1.7.2-3.fc34.x86_64
libX11-xcb-0:1.7.0-3.fc34.i686
libX11-xcb-0:1.7.0-3.fc34.x86_64
libX11-xcb-0:1.7.2-3.fc34.x86_64
libblockdev-0:2.25-2.fc34.x86_64
libblockdev-0:2.26-1.fc34.x86_64
libblockdev-btrfs-0:2.25-2.fc34.x86_64
libblockdev-btrfs-0:2.26-1.fc34.x86_64
libblockdev-crypto-0:2.25-2.fc34.x86_64
libblockdev-crypto-0:2.26-1.fc34.x86_64
libblockdev-dm-0:2.25-2.fc34.x86_64
libblockdev-dm-0:2.26-1.fc34.x86_64
libblockdev-fs-0:2.25-2.fc34.x86_64
libblockdev-fs-0:2.26-1.fc34.x86_64
libblockdev-kbd-0:2.25-2.fc34.x86_64
libblockdev-kbd-0:2.26-1.fc34.x86_64
libblockdev-loop-0:2.25-2.fc34.x86_64
libblockdev-loop-0:2.26-1.fc34.x86_64
libblockdev-lvm-0:2.25-2.fc34.x86_64
libblockdev-lvm-0:2.26-1.fc34.x86_64
libblockdev-mdraid-0:2.25-2.fc34.x86_64
libblockdev-mdraid-0:2.26-1.fc34.x86_64
libblockdev-mpath-0:2.25-2.fc34.x86_64
libblockdev-mpath-0:2.26-1.fc34.x86_64
libblockdev-nvdimm-0:2.25-2.fc34.x86_64
libblockdev-nvdimm-0:2.26-1.fc34.x86_64
libblockdev-part-0:2.25-2.fc34.x86_64
libblockdev-part-0:2.26-1.fc34.x86_64
libblockdev-swap-0:2.25-2.fc34.x86_64
libblockdev-swap-0:2.26-1.fc34.x86_64
libblockdev-utils-0:2.25-2.fc34.x86_64
libblockdev-utils-0:2.26-1.fc34.x86_64
libepoxy-0:1.5.8-1.fc34.i686
libepoxy-0:1.5.8-1.fc34.x86_64
libepoxy-0:1.5.9-1.fc34.x86_64
libhandy-0:1.2.2-1.fc34.x86_64
libhandy-0:1.2.3-1.fc34.x86_64
libmwaw-0:0.3.19-1.fc34.x86_64
libmwaw-0:0.3.20-1.fc34.x86_64
libomp-devel-0:12.0.0-1.fc34.x86_64
libomp-devel-0:12.0.1-1.fc34.x86_64
libpwquality-0:1.4.4-2.fc34.x86_64
libpwquality-0:1.4.4-6.fc34.x86_64
libreoffice-data-1:7.1.5.2-1.fc34.noarch
libreoffice-data-1:7.1.5.2-5.fc34.noarch
librsvg2-0:2.50.6-1.fc34.x86_64
librsvg2-0:2.50.7-1.fc34.x86_64
libudisks2-0:2.9.2-2.fc34.x86_64
libudisks2-0:2.9.3-1.fc34.x86_64
libwebp-0:1.2.0-1.fc34.i686
libwebp-0:1.2.0-1.fc34.x86_64
libwebp-0:1.2.1-1.fc34.x86_64
libxcrypt-0:4.4.23-1.fc34.i686
libxcrypt-0:4.4.23-1.fc34.x86_64
libxcrypt-0:4.4.25-1.fc34.x86_64
llvm-libs-0:12.0.0-2.fc34.i686
llvm-libs-0:12.0.0-2.fc34.x86_64
llvm-libs-0:12.0.1-1.fc34.x86_64
mesa-libGL-0:21.1.5-1.fc34.i686
mesa-libGL-0:21.1.5-1.fc34.x86_64
mesa-libGL-0:21.1.7-1.fc34.x86_64
mesa-libgbm-0:21.1.5-1.fc34.x86_64
mesa-libgbm-0:21.1.7-1.fc34.x86_64
mesa-libglapi-0:21.1.5-1.fc34.i686
mesa-libglapi-0:21.1.5-1.fc34.x86_64
mesa-libglapi-0:21.1.7-1.fc34.x86_64
nautilus-extensions-0:40.1-2.fc34.x86_64
nautilus-extensions-0:40.2-1.fc34.x86_64
net-snmp-libs-1:5.9.1-3.fc34.x86_64
net-snmp-libs-1:5.9.1-4.fc34.x86_64
nspr-0:4.31.0-1.fc34.i686
nspr-0:4.31.0-1.fc34.x86_64
nspr-0:4.32.0-1.fc34.x86_64
nss-0:3.67.0-1.fc34.i686
nss-0:3.67.0-1.fc34.x86_64
nss-0:3.69.0-1.fc34.x86_64
nss-softokn-0:3.67.0-1.fc34.i686
nss-softokn-0:3.67.0-1.fc34.x86_64
nss-softokn-0:3.69.0-1.fc34.x86_64
nss-softokn-freebl-0:3.67.0-1.fc34.i686
nss-softokn-freebl-0:3.67.0-1.fc34.x86_64
nss-softokn-freebl-0:3.69.0-1.fc34.x86_64
nss-sysinit-0:3.67.0-1.fc34.x86_64
nss-sysinit-0:3.69.0-1.fc34.x86_64
nss-util-0:3.67.0-1.fc34.i686
nss-util-0:3.67.0-1.fc34.x86_64
nss-util-0:3.69.0-1.fc34.x86_64
pango-0:1.48.7-1.fc34.x86_64
pango-0:1.48.8-1.fc34.x86_64
selinux-policy-0:34.14-1.fc34.noarch
selinux-policy-0:34.16-1.fc34.noarch
selinux-policy-targeted-0:34.14-1.fc34.noarch
selinux-policy-targeted-0:34.16-1.fc34.noarch
shadow-utils-2:4.8.1-8.fc34.x86_64
shadow-utils-2:4.8.1-9.fc34.x86_64
systemd-0:248.6-1.fc34.x86_64
systemd-0:248.7-1.fc34.x86_64
systemd-libs-0:248.6-1.fc34.i686
systemd-libs-0:248.6-1.fc34.x86_64
systemd-libs-0:248.7-1.fc34.x86_64
systemd-networkd-0:248.6-1.fc34.x86_64
systemd-networkd-0:248.7-1.fc34.x86_64
systemd-pam-0:248.6-1.fc34.x86_64
systemd-pam-0:248.7-1.fc34.x86_64
systemd-rpm-macros-0:248.6-1.fc34.noarch
systemd-rpm-macros-0:248.7-1.fc34.noarch
systemd-udev-0:248.6-1.fc34.x86_64
systemd-udev-0:248.7-1.fc34.x86_64
udisks2-0:2.9.2-2.fc34.x86_64
udisks2-0:2.9.3-1.fc34.x86_64
usbutils-0:013-2.fc34.x86_64
usbutils-0:014-1.fc34.x86_64
vim-common-2:8.2.3223-1.fc34.x86_64
vim-common-2:8.2.3318-1.fc34.x86_64
vim-filesystem-2:8.2.3223-1.fc34.noarch
vim-filesystem-2:8.2.3318-1.fc34.noarch
volume_key-libs-0:0.3.12-11.fc34.x86_64
volume_key-libs-0:0.3.12-14.fc34.x86_64
yelp-libs-2:40.0-1.fc34.x86_64
yelp-libs-2:40.3-1.fc34.x86_64
yelp-xsl-0:40.0-1.fc34.noarch
yelp-xsl-0:40.2-1.fc34.noarch
1 Like

You can try this:

sudo rpm --nodeps -e $(sudo dnf -q repoquery --duplicates)

But be ready for recovery if something goes wrong.

Removing packages individually with sudo rpm --nodeps -e <package> worked! I only had to remove the ones that sudo dnf remove --duplicates --skip-broken mentioned in the error, and then it was able to remove the rest.

My only problem was emacs-common which had two packages with the exact same name and version, but reinstalling emacs fixed that.

Thanks a lot for the help!

2 Likes