Error on dual booting

I dual boot windows 10 and fedora. fedora is working properly but when I want to use the windows, it shows error
Error: grub-core/disk/1386/pc/biosdisk.c:419:hd1 cannot get C/H/S values.

Error: grub-core/loader/1386/pc/linux.c:413:you need to load the kernel first.
press any key to continue.

when I press a key it directed me back to the OS menu to select windows or fedora. can someone help we this error, I m new to fedora

You can try doing grub-update from fedora terminal and the boot Windows

How to grub update from fedora terminal and the BOOT WINDOWS. PLEASE TELL ME

Hi @yuval welcome to the community

Could you post back the output of this commands. You just only need open the terminal and paste these.

1. To know a bit about your filesystem and your partitions

lsblk -f

sudo fdisk -l

2. To know if you have one UEFI install of fedora

ls /sys/firmware/efi

3. To know a bit more about your efi partition (in case of EFI install) and to see if Windows in in the same place

sudo ls /boot/efi/EFI

4. To see boot entries in case of UEFI install

efibootmgr -v

Once provide this information the members of forum will have a better way to help you with the issue.

Regards.

hi thank you for helping me here is what you were asking

the second command which you asked for

the last one
Screenshot from 2019-12-27 16-57-07
now please help me someone

Okej the problem is that you did a installation of fedora in mode legacy in place of UEFI mode and it is not leaving you start windows from grub entry because windows was installed in UEFI mode. But it has solution. I will can help you a bit but i am out of access to one pc right now. But while you can looking for it in the option of search in the forum where you will find information about this.

Regards

1 Like

Ok the first one thing that you will need is patience. If you did a backup of your personal files or all that you did need before you did install fedora we can go to next step if no the first one is go into fedora and do a backup to one external disk of them, because you will can see them through linux.

Now I will explain 2 ways that would help you.

A) Change the boot option to windows in the BIOS

It is perhaps the easy way to go into windows again, you will need go into your BIOS and select/change (manually the entry) into the menu of boot options, you would see a entry called fedora and you need select this options and in the first place choose one called “windows boot manager” save the changes and reboot, if the entry was not damage you would boot in you windows system, if it did work just reboot again to check that this entry stay and you go direct to windows again out of problems. Once you checked that you can go in windows every time out of problems, you can just delete all fedora partitions and entries from windows too and so began with a clean install if you wish but always in mode UEFI. if the entry is damage or is not the right one you will can not boot and you will need change again it.

Note that i can not advice where this menu is in your BIOS because it is your BIOS and every BIOS is different but the options is there 100% because it is present in all of them. Maybe you need take time or google for it.

B) Installing Fedora in UEFI mode

You can install fedora in UEFI mode but you need select this option when you plug in the USB with fedora there would be a prefix called “UEFI: USB fedora …” and other option without the prefix (the option without prefix will conform a legacy install like you did) it would be due at your BIOS in the UEFI options has selected the option compatibility so called LEGACY+UEFI so that one can choose that type of installation do.

So you can delete your fedora preview install in mode legacy and replace it for UEFI mode but you will need also disable Secure Boot in your BIOS options related with security to avoid problems with multiple entries created after every reboot or others issues and also is recommended disable fast boot if you wish have acces to write in your windows partitions. You can read about it in google.

Next I will leave you a bit of information from others post and links that you would read to understand more about it.

https://fedoraproject.org/wiki/Unified_Extensible_Firmware_Interface

It is all than i can advice you here.

Regards.

2 Likes

Here is my bios boot menu

Changing boot priority UEFI first to legacy gives same EFI and legacy information


Where is windows and fedora😅

When i choose uefi this comes

And then pc restarts and this comes again and again
And then i changes boot mode to legacy then fedora runs not windows

Maybe windows entry is missing in some part

Try looking for boot order into configuration options, there would be something sure. It is a few thing i did find out but look around your Bios in the configuration stuff if you can change the boot order.

It is difficult to say and see

I know how to boot from usb, you want me to reinstall windows? What should i do after i boot through usb and go into windows boot manager. It says to reinstall windows and gives option either to install it again or repair your computer. If you want mento choose repair your computer then what should i do

Look this

https://support.microsoft.com/en-us/help/12415/windows-10-recovery-options

Just recovery your windows with your windows media you will lose fedora entry but you can after install in right mode again. you don’t need reinstall whole windows only recovery mode to repair entry. In the next reboot this would only boot into windows.

select the option startup repair like here --> https://www.groovypost.com/howto/fix-windows-10-wont-boot-startup-repair-bootrec/

Try first with this option.

Hi @yuval, I also had a lot of trouble with the UEFI vs Legacy boot during my installation (I had the opposite problem that you have, Windows was installed in Legacy and Linux in UEFI) and researching the web I found that everybody said combining these two is not a good idea.

I would recommend to leave Windows alone for the moment, and follow the instructions @xtym gave you at step B of Error on dual booting . By what I see you already know how to change your boot mode to “UEFI only” in your Bios. After you do that, boot from the fedora USB (or other installation media), which should now boot in UEFI mode and reinstall Fedora (you can write over the old installation) and see what happens. With both systems installed in UEFI mode maybe GRUB will be able to find the windows installation and create a correct dual boot menu.

Only if this doesn’t work, then you can look more into the recovery of the Windows software…

All the best!

I have another question, can you access the files on your Windows drive from the Fedora installation or the live CD?

If you haven’t done it already or don’t know how to do it you can follow these simple steps:

  1. Open the Dolphin File manager
  2. on the left panel you will see “Devices” and some hard-disk like icons.
    I see (from your fdisk output) that your Windows has several partitions with data, and I don’t know what hey will be called in your case, maybe “Windows”, maybe other names.
  3. Try to click on one or more of them, and see if they get mounted correctly and you can browse the files in there. (just checking if you can browse around is enough).

If you can browse and open files you are good. If you can’t, then maybe the hard disk has an encryption enabled and that will make it more complicated to have a dual boot.

well i reinstalled windows and fedora again and installd in uefi so both are working . thanks all of you for help

now i am getting a new error about updating fedora which is not update as updates is not being downloaded.


how to solve this error?