Error when refreshing updates in gnome-software

Hey,
I’ve started getting this error:
“Sorry, something went wrong: Signature made … using RSA key ID”
Full error screenshot:
image
It happens every time I refresh updates in Gnome-Software but everything seems to work properly, it’s just bothering me. I tried deleting cache and stuff like that but it didn’t help.
Anyone has any idea how to troubleshoot this? Is it a faulty repo (I have RPM fusion and flathub)? I couldn’t find any logs or anything specific, I’m lost on this error message.

1 Like

List GPG keys:

rpm -q --qf "%{SUMMARY}\t%{NAME}-%{VERSION}-%{RELEASE}\n" gpg-pubkey | sort

I have the brave/mega/fedy repos currently disabled.

Had to delete links in text form to post :stuck_out_tongue:

Brave Software public key gpg-pubkey-c2d4e821-5e7252b8
Fedora (33) public key gpg-pubkey-9570ff31-5e3006fb
kwizart_fedy (None) public key gpg-pubkey-2da862e5-5d6e89fa
MegaLimited support@mega.co.nz public key gpg-pubkey-7f068e5d-563dc081
RPM Fusion free repository for Fedora (2020) public key gpg-pubkey-d651ff2e-5dadbbc1
RPM Fusion nonfree repository for Fedora (2020) public key gpg-pubkey-94843c65-5dadbc64
1 Like

Does this happen with dnf as well?

No, no errors from dnf.

It seems to be related to flatpak:

3 Likes

That’s probably it, I tried installing citra flatpak a while ago the way they suggested on their page “flatpak install https://flatpak.citra-emu.org/citra-nightly.flatpakref” and it returned an error and I didn’t look back on it. For some reason even though I googled a lot I couldn’t find that reddit post :stuck_out_tongue:

I didn’t expect a failed installation could spill over into gnome-software this way.

I read up a bit about flatpak commands and managed to fix it
List repository names:
flatpak remotes
Delete faulty repositories:
flatpak remote-delete <repository name>

Thanks everyone for help :slight_smile:

2 Likes