Error while loading shared libraries: libnsl.so.1

I can’t run AntConc on Silverblue 35 due to this error message:

error while loading shared libraries: libnsl.so.1: cannot open shared object file: No such file or directory

I’ve installed libnsl.so.1 but the app still doesn’t work… Please, see the screenshot. I’m aware of that AntConc is unsupported by Fedora but this app actually works perfectly on the standard workstation version of Fedora Linux 35–I just can’t run it on Silverblue. So I guess this issue may have some simple solution.

Thanks in advance! :wink:

I think that I’ve figured out what’s going on here. When I run rpm-ostree install libnsl.so.1 and then reboot, here’s what I get:

$ rpm -q libnsl
libnsl-2.34-7.fc35.i686
$ rpm -ql libnsl
/lib/libnsl.so.1
/usr/lib/.build-id
/usr/lib/.build-id/7d
/usr/lib/.build-id/7d/ae77357224e3d7ab6bf0e0049898205eaf249b
$ ./AntConc_64bit
./AntConc_64bit: error while loading shared libraries: libnsl.so.1: cannot open shared object file: No such file or directory

For whatever reason, rpm-ostree installed the 32-bit version of libnsl. AntConc gives you that error message because there isn’t a file called libnsl.so.1 in any of the 64-bit library folders.

When I uninstall libnsl.so.1, run rpm-ostree install libnsl and then reboot, here’s what I get:

$ rpm -q libnsl
libnsl-2.34-7.fc35.x86_64
$ rpm -ql libnsl
/lib64/libnsl.so.1
/usr/lib/.build-id
/usr/lib/.build-id/63
/usr/lib/.build-id/63/2bc65a03a2cfcaeb01e1c7724578495719b113
$ ./AntConc_64bit
$

So, for whatever reason, rpm-ostree install libnsl.so.1 installs the 32-bit version of libnsl, and rpm-ostree install libnsl installs the 64-bit version of libnsl.

1 Like

Thanks a lot, Jason! I installed libnsl instead of libnsl.so.1 and now AntConc runs smoothly. :smiley:

(I’ve been testing Silverblue for a few days on my secondary machine I don’t use for daily work and that libnsl issue was in fact the only problem I had. Now, as all the apps I need seem to work just fine, I think I can switch to Silverblue. :hugs: )