Error with ffmpeg

Hi guys! I already had Youtube-dl installed via the terminal, working normally. However, after installing Video Downloader, there was a problem with Download. After that, using Youtube-dl via terminal, the error “ffmpeg: error while loading shared libraries: libavdevice.so.58: cannot open shared object file: No such file or directory” appears. I tried to fix by uninstalling both, including ffmpeg plugin, and then reinstalling Youtube-dl (via terminal with dnf) and ffmpeg (via terminal with dnf) and nothing.

2 Likes

Check the output:

rpm -q -a ffmpeg libavdevice; rpm -V -a ffmpeg libavdevice
1 Like

[natan@localhost ~]$ rpm -q -a ffmpeg libavdevice; rpm -V -a ffmpeg libavdevice
ffmpeg-4.3.2-2.fc33.x86_64

1 Like
sudo dnf install libavdevice
2 Likes