Everything seems fine, but there's not sound

Hello everyone, I’m facing a problem with my new PC.
There’s no sound and I can’t manage to make it work. I tried many distros and I have the same problem each times. So I don’t think my problem is a Fedora problem, but since it is the distro I am on, I’m asking here (I’m not used to forums !).

So, on Windows (dual boot), everything works fine. In my BIOS, I don’t see anything that could block my computer from producing sound. I’ve tried to select different audio card, I saw a trick using “pulseaudio -k”, but nothing worked.

When I’m looking at my audio setting, everything seems fine.

Here are my audio cards:

sudo lspci  | grep Audio
00:1f.3 Audio device: Intel Corporation CM238 HD Audio Controller (rev 31)
01:00.1 Audio device: NVIDIA Corporation GP104 High Definition Audio Controller (rev a1)
dmseg | grep [Aa]udio
[    0.416851] ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
[   13.914531] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[   14.013961] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC1220: line_outs=1 (0x1b/0x0/0x0/0x0/0x0) type:speaker
[   14.013962] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   14.013963] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x14/0x0/0x0/0x0/0x0)
[   14.013964] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[   14.013964] snd_hda_codec_realtek hdaudioC0D0:    dig-out=0x1e/0x0
[   14.013965] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[   14.013965] snd_hda_codec_realtek hdaudioC0D0:      Mic=0x18
[   14.013966] snd_hda_codec_realtek hdaudioC0D0:      Internal Mic=0x12
[   14.503492] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[   14.570098] snd_hda_intel 0000:01:00.1: bound 0000:01:00.0 (ops nv50_audio_component_bind_ops [nouveau])

I checked if the sound wasn’t turned off or anything like it, I don’t think I missed something here (I tried pulsaudio and pavucontrol to see if there was some settings I could tweak).

So if anyone of you has any idea, it would be great !

Thank you for your time !

Welcome to the community.

Maybe someone has more suggestions, but to me it looks like the 2 different audio devices (intel and nvidia) are conflicting.

I do not have 2 different audio devices, but the kernel loads a lot of modules for the built-in intel device I have on my desktop. It could easily be that the kernel loads one device and the app you are using to play sound is trying to use the other device. Or that both are loaded and the app uses the wrong one.

This is what I see when I check the modules loaded for my intel device.

$  kmod list | grep snd
snd_usb_audio         307200  5
snd_usbmidi_lib        45056  1 snd_usb_audio
snd_rawmidi            45056  1 snd_usbmidi_lib
mc                     61440  1 snd_usb_audio
snd_hda_codec_realtek   135168  1
snd_hda_codec_generic    98304  1 snd_hda_codec_realtek
ledtrig_audio          16384  2 snd_hda_codec_generic,snd_hda_codec_realtek
snd_hda_codec_hdmi     73728  2
snd_hda_intel          57344  13
snd_intel_dspcfg       28672  1 snd_hda_intel
snd_hda_codec         163840  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
snd_hda_core          110592  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
snd_hwdep              16384  2 snd_usb_audio,snd_hda_codec
snd_seq                86016  0
snd_seq_device         16384  2 snd_seq,snd_rawmidi
snd_pcm               135168  5 snd_hda_codec_hdmi,snd_hda_intel,snd_usb_audio,snd_hda_codec,snd_hda_core
snd_timer              49152  2 snd_seq,snd_pcm
snd                   106496  49 snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_usb_audio,snd_usbmidi_lib,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_pcm,snd_rawmidi
soundcore              16384  1 snd

I see the same list when I use “lsmod | grep snd”

Another possibility would be that the sound is being produced on one device and your headphones/speakers/etc are attached to the other device.

If you intend to use one device exclusively then you probably should disable the second one so the conflict does not occur.
I would guess the intel device is built-in on your system and the nvidia device is on your video card. Dmesg shows the nvidia device added and the intel device configured.
You might also try going into settings for sound and select the input and output device you wish to use.

1 Like

Hi, thank you for your response.
Indeed I have 2 sound cards, and the Intel CM238 is, I guess, the card that need to be working.
I can show you the output of kmod, which is the same as lsmod | grep snd:

$ kmod list | grep snd
snd_hda_codec_realtek   139264  1
snd_hda_codec_hdmi     73728  2
snd_hda_codec_generic    98304  1 snd_hda_codec_realtek
ledtrig_audio          16384  2 snd_hda_codec_generic,snd_hda_codec_realtek
snd_hda_intel          57344  6
snd_intel_dspcfg       28672  1 snd_hda_intel
snd_hda_codec         163840  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
snd_hda_core          110592  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
snd_hwdep              16384  1 snd_hda_codec
snd_seq                86016  0
snd_seq_device         16384  1 snd_seq
snd_pcm               135168  4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_core
snd_timer              49152  2 snd_seq,snd_pcm
snd                   106496  22 snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_pcm
soundcore              16384  1 snd

From what I see (and from what I know, which is poor), everything for my Intel CM238 seems setup. The output selected are my speakers (built-in in my PC). I tried to select different sound profiles in audacious, to see if there was one that would work, but none did.

Anyway, thx for your response, I hope that you or someone else will have an idea !

Your list of modules seems the same as mine except I use a USB dongle for my wireless headphones and that loads 4 extra modules to support it.
I still believe the NVIDIA device that shows in your dmesg output is likely interfering with the built-in intel device.

One additional note is that your dmesg output shows [nouveau] bound to the snd_hda_intel module and I am not using the nouveau driver for my video. I am using the nvidia drivers with my nvidia card.
It seems possible that the nouveau driver, since it is generic and not specifically designed to support that video card, could interfere with the audio out

1 Like

dmesg can show much more than you listed in your post above.
This is mine trimmed to show only those parts related to sound. Perhaps you could view the entire dmesg output and spot where things might be going wrong, or post the relevant parts so others can help spot the problem.

[    1.886135] usb 5-3: New USB device found, idVendor=10f5, idProduct=2154, bcdDevice= 1.00
[    1.886140] usb 5-3: New USB device strings: Mfr=3, Product=4, SerialNumber=0
[    1.886143] usb 5-3: Product: Ear Force Stealth 450
[    1.886145] usb 5-3: Manufacturer: Turtle Beach
[    1.905233] input: Turtle Beach Ear Force Stealth 450 Consumer Control as /devices/pci0000:00/0000:00:13.0/usb5/5-3/5-3:1.3/0003:10F5:2154.0001/input/input2
[    1.957322] input: Turtle Beach Ear Force Stealth 450 as /devices/pci0000:00/0000:00:13.0/usb5/5-3/5-3:1.3/0003:10F5:2154.0001/input/input3
[    1.957424] hid-generic 0003:10F5:2154.0001: input,hiddev96,hidraw0: USB HID v1.11 Device [Turtle Beach Ear Force Stealth 450] on usb-0000:00:13.0-3/input3
---------------------------------
[    5.641473] mc: Linux media interface: v0.10
[    5.674917] input: PC Speaker as /devices/platform/pcspkr/input/input21
______________________________________
[    5.845252] snd_hda_intel 0000:01:00.1: enabling device (0000 -> 0002)
[    5.845290] snd_hda_intel 0000:01:00.1: Disabling MSI
[    5.845299] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[    5.845486] snd_hda_intel 0000:03:00.1: enabling device (0000 -> 0002)
[    5.845524] snd_hda_intel 0000:03:00.1: Disabling MSI
[    5.845530] snd_hda_intel 0000:03:00.1: Handle vga_switcheroo audio client
____________________________________________
[    5.885395] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:02.0/0000:01:00.1/sound/card2/input23
[    5.885475] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:02.0/0000:01:00.1/sound/card2/input24
[    5.885606] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:02.0/0000:01:00.1/sound/card2/input25
[    5.885937] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:0b.0/0000:03:00.1/sound/card3/input29
[    5.885969] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:02.0/0000:01:00.1/sound/card2/input26
[    5.886040] input: HDA NVidia HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:02.0/0000:01:00.1/sound/card2/input27
[    5.886106] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:0b.0/0000:03:00.1/sound/card3/input30
[    5.886224] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:0b.0/0000:03:00.1/sound/card3/input31
[    5.886340] input: HDA NVidia HDMI/DP,pcm=11 as /devices/pci0000:00/0000:00:02.0/0000:01:00.1/sound/card2/input28
[    5.886557] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:0b.0/0000:03:00.1/sound/card3/input32
[    5.886622] input: HDA NVidia HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:0b.0/0000:03:00.1/sound/card3/input33
[    5.886816] input: HDA NVidia HDMI/DP,pcm=11 as /devices/pci0000:00/0000:00:0b.0/0000:03:00.1/sound/card3/input34
_______________________________
[    5.895714] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[    5.896686] ieee80211 phy0: Atheros AR9300 Rev:3 mem=0xffffb87680cc0000, irq=57
[    5.898532] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC892: line_outs=4 (0x14/0x15/0x16/0x17/0x0) type:line
[    5.898535] snd_hda_codec_realtek hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    5.898537] snd_hda_codec_realtek hdaudioC1D0:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[    5.898538] snd_hda_codec_realtek hdaudioC1D0:    mono: mono_out=0x0
[    5.898540] snd_hda_codec_realtek hdaudioC1D0:    dig-out=0x11/0x1e
[    5.898544] snd_hda_codec_realtek hdaudioC1D0:    inputs:
[    5.898546] snd_hda_codec_realtek hdaudioC1D0:      Front Mic=0x19
[    5.898547] snd_hda_codec_realtek hdaudioC1D0:      Rear Mic=0x18
[    5.898549] snd_hda_codec_realtek hdaudioC1D0:      Line=0x1a
[    5.916510] EDAC amd64: F15h detected (node 0).
[    5.916550] EDAC amd64: Node 0: DRAM ECC disabled.
[    5.932826] input: HDA ATI SB Front Mic as /devices/pci0000:00/0000:00:14.2/sound/card1/input35
[    5.932903] input: HDA ATI SB Rear Mic as /devices/pci0000:00/0000:00:14.2/sound/card1/input36
[    5.932942] EDAC amd64: F15h detected (node 0).
[    5.932966] input: HDA ATI SB Line as /devices/pci0000:00/0000:00:14.2/sound/card1/input37
[    5.932973] EDAC amd64: Node 0: DRAM ECC disabled.
[    5.933035] input: HDA ATI SB Line Out Front as /devices/pci0000:00/0000:00:14.2/sound/card1/input38
[    5.933143] input: HDA ATI SB Line Out Surround as /devices/pci0000:00/0000:00:14.2/sound/card1/input39
[    5.933193] input: HDA ATI SB Line Out CLFE as /devices/pci0000:00/0000:00:14.2/sound/card1/input40
[    5.933246] input: HDA ATI SB Line Out Side as /devices/pci0000:00/0000:00:14.2/sound/card1/input41
[    5.933310] input: HDA ATI SB Front Headphone as /devices/pci0000:00/0000:00:14.2/sound/card1/input42

Note that my video card shows HDMI sound cards that theoretically would connect to speakers in the monitor but my monitor does not have speakers nor headphone ports.