Extensions are turned off against my will

My Gnome Extensions are being globally deactivated even tough I never asked so.

By that I mean that in the “GNOME Extensions” app, the upper right slider, the one that controlas whether all extensions are on or off, is turned in the “Off” position automatically.

I just experienced this, it seems to happen sometimes when I reboot. I don’t know exactly what causes this or how to reproduce. Reboot is a factor but it doesn’t seem to be the only one.

I think all extensions are disabled after gnome-shell crashes—to ensure that a vanilla gnome-shell runs on the next login. Are you seeing any crashes?

1 Like

I am indeed, but did not get notification because I have “Do Not Disturb”

In Ubuntu 20.10 the screen flashed when the shell crashed. This does not happen here?

Maybe due to Wayland

1 Like

Not sure. Luckily I haven’t had the shell crash on me in a while :slight_smile:

If the shell is crashing repeatedly, check your extensions—you can disable them all and enable them one by one to see which one is buggy and if possible report them to their developers.

It should also be in your system logs:

https://docs.fedoraproject.org/en-US/quick-docs/viewing-logs/

1 Like