External monitors

Since shortly, I have some problems with my external displays. First time I plugged them into my laptop they both worked fine. One with HDMI and one with a DP to USB-C adapter. After a restart it didn’t work properly anymore. I think the screen last plugged in would stay black (the monitor didn’t recognize any input but it was turned on), but the computer still thought of it as on and I could move windows there still. Now if I just want to use 1 extra monitor, Fedora sets it to joined displays, but both screens show my external screen. It looks as if they are duplicated, but I can move windows to and from the second area. The second monitor which I plugged in with usb-c now doesn’t work at all, not even on windows… Did I just break that monitor?

I am using Xorg because with normal GNOME (I think it uses wayland) it was much much laggier. Maybe there is a way to reset Xorg or something?

Just from reading the information you have given so far, this sounds like the case. However, I’d test the monitor as the only display to be sure. Disable all other displays and disconnect any other external ones. Enable only that one you think may have died.

With Xorg, the configuration is discovered and generated in memory upon every boot. It is possible to generate custom Xorg configuration files, but if you haven’t done that, there’s really nothing to be done in regards to resetting Xorg configs.

What model laptop and what type of docking station do you have? (Sounds like it might be a Lenovo with a USB-C type dock?)

Yes I am using a Lenovo ThinkPad P1 Gen 2 laptop. But I’m not using a docking station, only an adapter to plug in my second display.

The USB-C display also doesn’t work if it’s the only display…

My two monitors are both AOC’s if that helps

Could I get the model of the USB-C monitor? Also, the following information if possible:

$ sudo lspci -vvv | fpaste

Both my monitors are AOC G2460V. One is connected via HDMI directly. The other one via DP and then an DP to USB-C adapter and then into my laptop.

lspci information with only my HDMI monitor plugged in: https://paste.centos.org/view/a9fbde8e
lspci information with both monitors: https://paste.centos.org/view/a737456d

Second one was very hard to do because my working HDMI monitor and my internal display both mirrored the broken display which was empty at the time. I had to move my window blindly to the broken display to see it mirrored on the other displays. This is a very weird behavior

The lspci output was really just to tell me what display drivers you are using. I was hoping to see an Intel driver but I didn’t locate it. Does the system come with integrated graphics or only the nVidia controller?

If you have an Intel graphics controller, I’d like for you to try something: Reboot the machine, access the BIOS and disable the nVidia controller (discreet graphics) by switching to only integrated graphics.

The reason for this is because using both nVidia and Intel together has a notorious track record filled with flaws concerning multiple external monitors. Intel code has come a very long way in supporting multiple external monitors and IMO is much more stable in this regard.

That would be a great solution, but unfortunately not possible. I indeed have both integrated Intel and discrete nVidia graphics. However, I set it to discrete only, because my laptop seems to have the HDMI port connected to the nvidia card and not the intel card. If I set it to hybrid graphics (there is no option to only use integrated graphics), the monitors don’t work.

How about just to test to make sure the monitor isn’t blown? You can always switch it back. :slight_smile:

My BIOS doesn’t have an option to only use integrated graphics, but I did try to set it on hybrid graphics. What happened is that my HDMI monitor was black (the leds were on, just black) but it did have a mouse working. Nothing else showed on the display. My USB-C monitor was black but a little darker (even the leds were off), even though the monitor was on. I am fairly certain that monitor actually broke…

Shine a bright light onto it and check to see if the LCD is working (you should be able to see the cursor or moving windows). If it is, it’s a simple matter of getting the backlight controller replaced. If the monitor was bought recently, you could possibly return it for a replacement.

One thing to keep in mind is that DP/HDMI has a voltage of about 3.3v. Compare this with USB-C/Thunderbolt which has 18v.

You may have encountered an issue where the monitors were built without the expectation that someone would have tried converting the USB-C to DP in order to connect the monitor. If so, it would be a simple case of soldering the proper voltage resistors onto the backlight controller.