Extremely slow boot

Hi all, I am getting this error on boot since about kernel 4.20.x in Fedora (does not happen in Ubuntu):

A start job is running for udev wait for Complete Device Initialization – 2.58 min

Top 5 systemd-analyze blame output

[root@localhost saif]# systemd-analyze blame
1min 33.401s systemd-udev-settle.service                                                              
      9.217s NetworkManager-wait-online.service                                                       
      3.497s plymouth-quit-wait.service                                                               
      1.630s dracut-initqueue.service                                                                 
      1.114s fwupd.service                                                                            
       796ms initrd-switch-root.service                                                               
       759ms systemd-logind.service     

Status of such service

[root@localhost saif]# systemctl status systemd-udev-settle.service
● systemd-udev-settle.service - udev Wait for Complete Device Initialization
   Loaded: loaded (/usr/lib/systemd/system/systemd-udev-settle.service; static; vendor preset: disabled)
   Active: active (exited) since Mon 2019-10-14 03:17:36 -03; 7min ago
     Docs: man:systemd-udev-settle.service(8)
  Process: 620 ExecStart=/usr/bin/udevadm settle (code=exited, status=0/SUCCESS)
 Main PID: 620 (code=exited, status=0/SUCCESS)
      CPU: 9ms

Oct 14 03:16:03 localhost.localdomain systemd[1]: Starting udev Wait for Complete Device Initialization...
Oct 14 03:16:03 localhost.localdomain udevadm[620]: systemd-udev-settle.service is deprecated.
Oct 14 03:17:36 localhost.localdomain systemd[1]: Started udev Wait for Complete Device Initialization.

Any clues?
Thanks

1 Like

Hi @revolucion09 check this link, it can be related with your issue the last post was done for the user saifjsl (he is using fedora). Here is a bug report https://access.redhat.com/discussions/4060221 about same issue.

Regards

Hi, that’s myself :slight_smile:

Either masking systemd-udev-settle.service or blacklisting blacklist i2c_nvidia_gpu work, but no idea about the consequences.

Blacklisting i2c + nvidia bumblebee leaves my system where I want it to be

2 Likes

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.