F29 upgrade to F30 hangs

The 'dnf remove" for the four listed files (plus dependencies) appears to have been successful. Going from the repeat step and the remove duplicates - below is information from the execution:
[SKIPPED] xmlsec1-openssl-1.2.27-2.fc30.x86_64.rpm: Already downloaded
Running transaction check
Error: transaction check vs depsolve:
NetworkManager-libnm(x86-64) = 1:1.12.6-5.fc29 is needed by (installed) NetworkManager-1:1.12.6-5.fc29.x86_64
NetworkManager-libnm(x86-64) = 1:1.12.6-5.fc29 is needed by (installed) NetworkManager-1:1.12.6-5.fc29.x86_64
boost-chrono(x86-64) = 1.66.0-14.fc29 is needed by (installed) boost-wave-1.66.0-14.fc29.x86_64
boost-chrono(x86-64) = 1.66.0-14.fc29 is needed by (installed) boost-type_erasure-1.66.0-14.fc29.x86_64
boost-chrono(x86-64) = 1.66.0-14.fc29 is needed by (installed) boost-locale-1.66.0-14.fc29.x86_64
boost-chrono(x86-64) = 1.66.0-14.fc29 is needed by (installed) boost-wave-1.66.0-14.fc29.x86_64
boost-chrono(x86-64) = 1.66.0-14.fc29 is needed by (installed) boost-type_erasure-1.66.0-14.fc29.x86_64
boost-chrono(x86-64) = 1.66.0-14.fc29 is needed by (installed) boost-locale-1.66.0-14.fc29.x86_64
libboost_chrono.so.1.66.0()(64bit) is needed by (installed) boost-wave-1.66.0-14.fc29.x86_64
libboost_chrono.so.1.66.0()(64bit) is needed by (installed) boost-type_erasure-1.66.0-14.fc29.x86_64
libboost_chrono.so.1.66.0()(64bit) is needed by (installed) boost-coroutine-1.66.0-14.fc29.x86_64
libboost_chrono.so.1.66.0()(64bit) is needed by (installed) boost-locale-1.66.0-14.fc29.x86_64
libboost_iostreams.so.1.66.0()(64bit) is needed by (installed) liborcus-0.13.4-3.fc29.x86_64
boost-thread(x86-64) = 1.66.0-14.fc29 is needed by (installed) boost-wave-1.66.0-14.fc29.x86_64
boost-thread(x86-64) = 1.66.0-14.fc29 is needed by (installed) boost-locale-1.66.0-14.fc29.x86_64
boost-thread(x86-64) = 1.66.0-14.fc29 is needed by (installed) boost-wave-1.66.0-14.fc29.x86_64
boost-thread(x86-64) = 1.66.0-14.fc29 is needed by (installed) boost-locale-1.66.0-14.fc29.x86_64
libboost_thread.so.1.66.0()(64bit) is needed by (installed) boost-wave-1.66.0-14.fc29.x86_64
libboost_thread.so.1.66.0()(64bit) is needed by (installed) boost-type_erasure-1.66.0-14.fc29.x86_64
libboost_thread.so.1.66.0()(64bit) is needed by (installed) boost-coroutine-1.66.0-14.fc29.x86_64
libboost_thread.so.1.66.0()(64bit) is needed by (installed) boost-locale-1.66.0-14.fc29.x86_64
coreutils-common = 8.30-7.fc29 is needed by (installed) coreutils-8.30-7.fc29.x86_64
coreutils-common = 8.30-7.fc29 is needed by (installed) coreutils-8.30-7.fc29.x86_64

… and the end of the remove duplicates:
mesa-libGLU(x86-64) = 9.0.0-16.fc29 is needed by (installed) mesa-libGLU-devel-9.0.0-16.fc29.x86_64
mesa-libGLU(x86-64) = 9.0.0-16.fc29 is needed by (installed) mesa-libGLU-devel-9.0.0-16.fc29.x86_64
ncurses-base = 6.1-8.20180923.fc29 is needed by (installed) ncurses-libs-6.1-8.20180923.fc29.x86_64
ncurses-base = 6.1-8.20180923.fc29 is needed by (installed) ncurses-libs-6.1-8.20180923.fc29.x86_64
pixman = 0.34.0-10.fc29 is needed by (installed) pixman-devel-0.34.0-10.fc29.x86_64
pixman = 0.34.0-10.fc29 is needed by (installed) pixman-devel-0.34.0-10.fc29.x86_64
libreadline.so.7()(64bit) is needed by (installed) nftables-1:0.9.0-2.fc29.x86_64
libreadline.so.7()(64bit) is needed by (installed) gnupg2-smime-2.2.17-1.fc29.x86_64
libreadline.so.7()(64bit) is needed by (installed) hivex-1.3.17-1.fc29.x86_64
libreadline.so.7()(64bit) is needed by (installed) gdbm-1:1.18-1.fc29.x86_64
libreadline.so.7()(64bit) is needed by (installed) NetworkManager-1:1.12.6-5.fc29.x86_64
libreadline.so.7()(64bit) is needed by (installed) gawk-4.2.1-3.fc29.x86_64
libreadline.so.7()(64bit) is needed by (installed) gnupg-1.4.23-2.fc29.x86_64
rpm-libs(x86-64) = 4.14.2.1-2.fc29 is needed by (installed) rpm-plugin-selinux-4.14.2.1-2.fc29.x86_64
rpm-libs(x86-64) = 4.14.2.1-2.fc29 is needed by (installed) rpm-plugin-selinux-4.14.2.1-2.fc29.x86_64
subunit(x86-64) = 1.3.0-4.fc29 is needed by (installed) subunit-devel-1.3.0-4.fc29.x86_64
subunit(x86-64) = 1.3.0-4.fc29 is needed by (installed) subunit-devel-1.3.0-4.fc29.x86_64
xz-libs(x86-64) = 5.2.4-3.fc29 is needed by (installed) xz-5.2.4-3.fc29.x86_64
xz-libs(x86-64) = 5.2.4-3.fc29 is needed by (installed) xz-5.2.4-3.fc29.x86_64
libicu < 63 conflicts with compat-libicu62-62.1-2.fc30.x86_64
libvpx < 1.8.0 conflicts with compat-libvpx5-1.7.0-1.fc30.x86_64
glib2(x86-64) < 2.60.3 conflicts with ModemManager-1.10.2-1.fc30.x86_64
libmbim(x86-64) < 1.18.0 conflicts with ModemManager-1.10.2-1.fc30.x86_64
dbus-daemon = 1:1.12.12-1.fc29 is needed by (installed) dbus-1:1.12.12-1.fc29.x86_64
python3 < 3.7.4-1.fc30 conflicts with python3-devel-3.7.4-1.fc30.x86_64
imsettings-desktop-module(x86-64) = 1.7.3-6.fc29 is needed by (installed) imsettings-1.7.3-6.fc29.x86_64
imsettings-desktop-module(x86-64) = 1.7.3-6.fc29 is needed by (installed) imsettings-1.7.3-6.fc29.x86_64
To diagnose the problem, try running: ‘rpm -Va --nofiles --nodigest’.
You probably have corrupted RPMDB, running ‘rpm --rebuilddb’ might fix the issue.
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing ‘dnf clean packages’.

Oh yes - as part of the remove duplicates - the system did prompt with:
Install 9 packages
Upgrade 392 packages
Remove 15 packages

That was prior to the [SKIPPED] line above.

Output from the second command in the repeat list:
[root@DBServe ~]# dnf remove $(dnf repoquery --installed --latest-limit=-1 -q --exclude=kernel*)
Error:
Problem: The operation would result in removing the following protected packages: dnf
(try to add ‘–skip-broken’ to skip uninstallable packages

The end of the output from the ‘dnf check all’ is:
xen-libs-4.11.2-1.fc29.x86_64 is a duplicate with xen-libs-4.11.2-1.fc30.x86_64
xen-licenses-4.11.2-1.fc29.x86_64 is a duplicate with xen-licenses-4.11.2-1.fc30.x86_64
xkeyboard-config-2.24-5.fc29.noarch is a duplicate with xkeyboard-config-2.26-2.fc30.noarch
xml-common-0.6.3-50.fc29.noarch is a duplicate with xml-common-0.6.3-52.fc30.noarch
xmlrpc-c-1.51.0-6.fc29.x86_64 is a duplicate with xmlrpc-c-1.51.0-8.fc30.x86_64
xmlsec1-1.2.25-5.fc29.x86_64 is a duplicate with xmlsec1-1.2.27-2.fc30.x86_64
xorg-x11-font-utils-1:7.5-40.fc29.x86_64 is a duplicate with xorg-x11-font-utils-1:7.5-41.fc30.x86_64
xorg-x11-proto-devel-2018.4-2.fc29.noarch is a duplicate with xorg-x11-proto-devel-2018.4-3.fc30.noarch
xorg-x11-server-common-1.20.4-1.fc29.x86_64 is a duplicate with xorg-x11-server-common-1.20.5-4.fc30.x86_64
xorg-x11-server-utils-7.7-26.fc29.x86_64 is a duplicate with xorg-x11-server-utils-7.7-28.fc30.x86_64
xorg-x11-xauth-1:1.0.9-13.fc29.x86_64 is a duplicate with xorg-x11-xauth-1:1.0.9-14.fc30.x86_64
xorg-x11-xinit-1.4.0-3.fc29.x86_64 is a duplicate with xorg-x11-xinit-1.4.0-4.fc30.x86_64
xorg-x11-xkb-utils-7.7-27.fc29.x86_64 is a duplicate with xorg-x11-xkb-utils-7.7-29.fc30.x86_64
xz-5.2.4-3.fc29.x86_64 is a duplicate with xz-5.2.4-5.fc30.x86_64
xz-devel-5.2.4-3.fc29.x86_64 is a duplicate with xz-devel-5.2.4-5.fc30.x86_64
xz-libs-5.2.4-3.fc29.x86_64 is a duplicate with xz-libs-5.2.4-5.fc30.x86_64
yajl-2.1.0-11.fc29.x86_64 is a duplicate with yajl-2.1.0-12.fc30.x86_64
yelp-xsl-3.30.1-1.fc29.noarch is a duplicate with yelp-xsl-3.32.1-1.fc30.noarch
zchunk-libs-1.1.2-2.fc29.x86_64 is a duplicate with zchunk-libs-1.1.2-2.fc30.x86_64
zerofree-1.1.1-2.fc29.x86_64 is a duplicate with zerofree-1.1.1-3.fc30.x86_64
zip-3.0-23.fc29.x86_64 is a duplicate with zip-3.0-24.fc30.x86_64
zlib-1.2.11-14.fc29.x86_64 is a duplicate with zlib-1.2.11-17.fc30.x86_64
zlib-devel-1.2.11-14.fc29.x86_64 is a duplicate with zlib-devel-1.2.11-17.fc30.x86_64
zstd-1.4.2-1.fc29.x86_64 is a duplicate with zstd-1.4.2-1.fc30.x86_64
Error: Check discovered 1094 problem(s)

I think, it’s too many to resolve automatically and removing them manually one by one is too much work, but there’s a way to automate it:

sudo rpm -e $(rpm -q -a | grep -e fc29)
1 Like

Output from the above command 'rpm -e (rpm -q-a | grep -e fc29)': [root@DBServe ~]# rpm -e (rpm -q -a | grep -e fc29)
error: Failed dependencies:
dbusmenu-qt(x86-64) >= 0.9.2 is needed by (installed) kdelibs-6:4.14.38-15.fc30.x86_64
libdbusmenu-qt.so.2()(64bit) is needed by (installed) kdelibs-6:4.14.38-15.fc30.x86_64
nc is needed by (installed) libvirt-libs-5.1.0-9.fc30.x86_64
libvisio-0.1.so.1()(64bit) is needed by (installed) libreoffice-graphicfilter-1:6.2.6.2-1.fc30.x86_64
polkit >= 0.112 is needed by (installed) libvirt-daemon-5.1.0-9.fc30.x86_64
libgspell-1.so.2()(64bit) is needed by (installed) evince-libs-3.32.0-3.fc30.x86_64
pkgconfig(QtCore) is needed by (installed) phonon-devel-4.10.2-3.fc30.x86_64
pkgconfig(QtDBus) is needed by (installed) phonon-devel-4.10.2-3.fc30.x86_64
pkgconfig(QtGui) is needed by (installed) phonon-devel-4.10.2-3.fc30.x86_64
qt4-devel is needed by (installed) kdelibs-devel-6:4.14.38-15.fc30.x86_64
systemd-container is needed by (installed) libvirt-daemon-driver-qemu-5.1.0-9.fc30.x86_64
httpd-mmn = 20120211x8664 is needed by (installed) php-7.3.8-1.fc30.x86_64
libgfapi.so.0()(64bit) is needed by (installed) libvirt-daemon-driver-storage-gluster-5.1.0-9.fc30.x86_64
libgfapi.so.0(GFAPI_3.4.0)(64bit) is needed by (installed) libvirt-daemon-driver-storage-gluster-5.1.0-9.fc30.x86_64
urw-base35-fonts is needed by (installed) libgs-9.26-5.fc30.x86_64
postgresql-jdbc is needed by (installed) libreoffice-base-1:6.2.6.2-1.fc30.x86_64
libxmlsec1-nss.so.1()(64bit) is needed by (installed) libreoffice-core-1:6.2.6.2-1.fc30.x86_64
liberation-fonts is needed by (installed) google-chrome-stable-76.0.3809.100-1.x86_64
dnsmasq >= 2.41 is needed by (installed) libvirt-daemon-driver-network-5.1.0-9.fc30.x86_64
libgnome-desktop-3.so.17()(64bit) is needed by (installed) evince-3.32.0-3.fc30.x86_64
cyrus-sasl is needed by (installed) libvirt-libs-5.1.0-9.fc30.x86_64
sheepdog is needed by (installed) libvirt-daemon-driver-storage-sheepdog-5.1.0-9.fc30.x86_64
python3-markupsafe >= 0.23 is needed by (installed) python3-jinja2-2.10.1-1.fc30.noarch
python3.7dist(markupsafe) >= 0.23 is needed by (installed) python3-jinja2-2.10.1-1.fc30.noarch
libpolkit-qt-core-1.so.1()(64bit) is needed by (installed) kdelibs-6:4.14.38-15.fc30.x86_64
java-headless >= 1:1.6 is needed by (installed) libreoffice-core-1:6.2.6.2-1.fc30.x86_64
java-headless >= 1:1.5 is needed by (installed) springframework-aop-0:3.2.18-4.fc28.noarch
java-headless >= 1:1.5 is needed by (installed) springframework-expression-0:3.2.18-4.fc28.noarch
java-headless >= 1:1.7 is needed by (installed) javamail-1.6.3-3.module_f29+2697+412960d8.noarch
java-headless >= 1:1.5 is needed by (installed) springframework-context-0:3.2.18-4.fc28.noarch
java-headless >= 1:1.5 is needed by (installed) springframework-0:3.2.18-4.fc28.noarch
java-headless >= 1:1.5 is needed by (installed) springframework-beans-0:3.2.18-4.fc28.noarch
java-headless >= 1:1.5 is needed by (installed) springframework-web-0:3.2.18-4.fc28.noarch
java-headless >= 1:1.6 is needed by (installed) jaf-1.2.1-2.module_f29+2697+412960d8.noarch
libjvm.so()(64bit) is needed by (installed) libreoffice-ure-1:6.2.6.2-1.fc30.x86_64
librdf.so.0()(64bit) is needed by (installed) libreoffice-core-1:6.2.6.2-1.fc30.x86_64
javapackages-tools is needed by (installed) springframework-aop-0:3.2.18-4.fc28.noarch
javapackages-tools is needed by (installed) springframework-expression-0:3.2.18-4.fc28.noarch
javapackages-tools is needed by (installed) springframework-context-0:3.2.18-4.fc28.noarch
javapackages-tools is needed by (installed) springframework-0:3.2.18-4.fc28.noarch
javapackages-tools is needed by (installed) springframework-beans-0:3.2.18-4.fc28.noarch
javapackages-tools is needed by (installed) springframework-web-0:3.2.18-4.fc28.noarch
mvn(org.jruby.extras:bytelist) is needed by (installed) springframework-context-0:3.2.18-4.fc28.noarch
mvn(org.ow2.asm:asm) is needed by (installed) springframework-0:3.2.18-4.fc28.noarch
breeze-icon-theme is needed by (installed) kde-settings-30.3-1.fc30.noarch
pkgconfig(QtWebKit) is needed by (installed) kdelibs-webkit-devel-6:4.14.38-15.fc30.x86_64
libaprutil-1.so.0()(64bit) is needed by (installed) subversion-1.12.2-1.fc30.x86_64
libaprutil-1.so.0()(64bit) is needed by (installed) subversion-libs-1.12.2-1.fc30.x86_64
qemu-kvm is needed by (installed) libvirt-daemon-kvm-5.1.0-9.fc30.x86_64
pkgconfig(libattica) >= 0.4.2 is needed by (installed) kdelibs-devel-6:4.14.38-15.fc30.x86_64
automoc4 >= 0.9.88 is needed by (installed) kdelibs-devel-6:4.14.38-15.fc30.x86_64
libQtWebKit.so.4()(64bit) is needed by (installed) kdelibs-webkit-6:4.14.38-15.fc30.x86_64
libQtWebKit.so.4()(64bit) is needed by (installed) kdelibs-6:4.14.38-15.fc30.x86_64
libappindicator3.so.1()(64bit) is needed by (installed) google-chrome-stable-76.0.3809.100-1.x86_64
kde-l10n is needed by (installed) kdelibs-6:4.14.38-15.fc30.x86_64
glib2-devel >= 2.22 is needed by (installed) gstreamer-devel-0.10.36-18.fc27.x86_64
glib2-devel(x86-64) >= 2.56.1 is needed by (installed) pango-devel-1.43.0-4.fc30.x86_64
pkgconfig(glib-2.0) is needed by (installed) gstreamer-devel-0.10.36-18.fc27.x86_64
pkgconfig(glib-2.0) >= 2.38.0 is needed by (installed) pango-devel-1.43.0-4.fc30.x86_64
pkgconfig(gmodule-no-export-2.0) is needed by (installed) gstreamer-devel-0.10.36-18.fc27.x86_64
pkgconfig(gobject-2.0) is needed by (installed) gstreamer-devel-0.10.36-18.fc27.x86_64
pkgconfig(gobject-2.0) >= 2.38.0 is needed by (installed) pango-devel-1.43.0-4.fc30.x86_64
pkgconfig(gthread-2.0) is needed by (installed) gstreamer-devel-0.10.36-18.fc27.x86_64
gvfs is needed by (installed) libosinfo-1.4.0-4.fc30.x86_64
gtk3(x86-64) >= 3.22.0 is needed by (installed) evince-3.32.0-3.fc30.x86_64
libgdk-3.so.0()(64bit) is needed by (installed) libreoffice-gtk3-1:6.2.6.2-1.fc30.x86_64
libgdk-3.so.0()(64bit) is needed by (installed) libreofficekit-1:6.2.6.2-1.fc30.x86_64
libgdk-3.so.0()(64bit) is needed by (installed) evince-djvu-3.32.0-3.fc30.x86_64
libgdk-3.so.0()(64bit) is needed by (installed) evince-nautilus-3.32.0-3.fc30.x86_64
libgdk-3.so.0()(64bit) is needed by (installed) google-chrome-stable-76.0.3809.100-1.x86_64
libgdk-3.so.0()(64bit) is needed by (installed) evince-3.32.0-3.fc30.x86_64
libgdk-3.so.0()(64bit) is needed by (installed) evince-libs-3.32.0-3.fc30.x86_64
libgtk-3.so.0()(64bit) is needed by (installed) libreoffice-core-1:6.2.6.2-1.fc30.x86_64
libgtk-3.so.0()(64bit) is needed by (installed) libreoffice-gtk3-1:6.2.6.2-1.fc30.x86_64
libgtk-3.so.0()(64bit) is needed by (installed) libreofficekit-1:6.2.6.2-1.fc30.x86_64
libgtk-3.so.0()(64bit) is needed by (installed) evince-djvu-3.32.0-3.fc30.x86_64
libgtk-3.so.0()(64bit) is needed by (installed) evince-nautilus-3.32.0-3.fc30.x86_64
libgtk-3.so.0()(64bit) is needed by (installed) google-chrome-stable-76.0.3809.100-1.x86_64
libgtk-3.so.0()(64bit) is needed by (installed) evince-3.32.0-3.fc30.x86_64
libgtk-3.so.0()(64bit) is needed by (installed) evince-libs-3.32.0-3.fc30.x86_64
iscsi-initiator-utils is needed by (installed) libvirt-daemon-driver-storage-iscsi-5.1.0-9.fc30.x86_64
mvn(org.apache.geronimo.specs:geronimo-validation_1.0_spec) is needed by (installed) springframework-context-0:3.2.18-4.fc28.noarch
glusterfs-client >= 2.0.1 is needed by (installed) libvirt-daemon-driver-storage-gluster-5.1.0-9.fc30.x86_64
GConf2 is needed by (installed) gstreamer-plugins-good-0.10.31-20.fc27.x86_64
libgconf-2.so.4()(64bit) is needed by (installed) gstreamer-plugins-good-0.10.31-20.fc27.x86_64
python3-babel >= 0.8 is needed by (installed) python3-jinja2-2.10.1-1.fc30.noarch
libgxps.so.2()(64bit) is needed by (installed) evince-libs-3.32.0-3.fc30.x86_64
mvn(org.apache.tomcat:tomcat-servlet-api) is needed by (installed) springframework-context-0:3.2.18-4.fc28.noarch
pkgconfig(harfbuzz) >= 1.4.2 is needed by (installed) pango-devel-1.43.0-4.fc30.x86_64
pkgconfig(xft) >= 2.0.0 is needed by (installed) pango-devel-1.43.0-4.fc30.x86_64
imsettings-desktop-module(x86-64) = 1.8.1-1.fc30 is needed by (installed) imsettings-1.8.1-1.fc30.x86_64
gnutls-utils is needed by (installed) libvirt-client-5.1.0-9.fc30.x86_64
mvn(org.apache.tomcat:tomcat-el-api) is needed by (installed) springframework-beans-0:3.2.18-4.fc28.noarch
mvn(org.apache.tomcat:tomcat-el-api) is needed by (installed) springframework-web-0:3.2.18-4.fc28.noarch
nfs-utils is needed by (installed) libvirt-daemon-driver-storage-core-5.1.0-9.fc30.x86_64
libcmis-0.5.so.5()(64bit) is needed by (installed) libreoffice-core-1:6.2.6.2-1.fc30.x86_64
/sbin/zfs is needed by (installed) libvirt-daemon-driver-storage-zfs-5.1.0-9.fc30.x86_64
/sbin/zpool is needed by (installed) libvirt-daemon-driver-storage-zfs-5.1.0-9.fc30.x86_64
mvn(commons-logging:commons-logging) is needed by (installed) springframework-0:3.2.18-4.fc28.noarch
libiscsi is needed by (installed) libvirt-daemon-driver-storage-iscsi-direct-5.1.0-9.fc30.x86_64
libiscsi.so.8()(64bit) is needed by (installed) libvirt-daemon-driver-storage-iscsi-direct-5.1.0-9.fc30.x86_64
libneon.so.27()(64bit) is needed by (installed) libreoffice-core-1:6.2.6.2-1.fc30.x86_64
check-devel is needed by (installed) gstreamer-devel-0.10.36-18.fc27.x86_64
kate4-part(x86-64) is needed by (installed) kdelibs-ktexteditor-6:4.14.38-15.fc30.x86_64
mvn(aopalliance:aopalliance) is needed by (installed) springframework-aop-0:3.2.18-4.fc28.noarch
cairo-devel(x86-64) >= 1.12.10 is needed by (installed) pango-devel-1.43.0-4.fc30.x86_64
pkgconfig(cairo) >= 1.12.10 is needed by (installed) pango-devel-1.43.0-4.fc30.x86_64
gstreamer1(element-gtksink)()(64bit) is needed by (installed) libreoffice-gtk3-1:6.2.6.2-1.fc30.x86_64
xdg-utils is needed by (installed) google-chrome-stable-76.0.3809.100-1.x86_64
xdg-utils is needed by (installed) kdelibs-6:4.14.38-15.fc30.x86_64
libserf-1.so.0()(64bit) is needed by (installed) subversion-libs-1.12.2-1.fc30.x86_64
libabw-0.1.so.1()(64bit) is needed by (installed) libreoffice-writer-1:6.2.6.2-1.fc30.x86_64
/usr/bin/lsb_release is needed by (installed) google-chrome-stable-76.0.3809.100-1.x86_64
cmake >= 2.8.9 is needed by (installed) kdelibs-devel-6:4.14.38-15.fc30.x86_64
openssl-devel is needed by (installed) kdelibs-devel-6:4.14.38-15.fc30.x86_64
/usr/sbin/gluster is needed by (installed) libvirt-daemon-driver-storage-gluster-5.1.0-9.fc30.x86_64
radvd is needed by (installed) libvirt-daemon-driver-network-5.1.0-9.fc30.x86_64
lvm2 is needed by (installed) libvirt-daemon-driver-storage-logical-5.1.0-9.fc30.x86_64
libc-client.so.2007()(64bit) is needed by (installed) php-imap-7.3.8-1.fc30.x86_64
cyrus-sasl-gssapi is needed by (installed) libvirt-libs-5.1.0-9.fc30.x86_64
libattica.so.0.4()(64bit) is needed by (installed) kdelibs-6:4.14.38-15.fc30.x86_64
libspectre.so.1()(64bit) is needed by (installed) evince-libs-3.32.0-3.fc30.x86_64
numad is needed by (installed) libvirt-daemon-5.1.0-9.fc30.x86_64
udisks2 is needed by (installed) kdelibs-6:4.14.38-15.fc30.x86_64
osinfo-db-tools is needed by (installed) libosinfo-1.4.0-4.fc30.x86_64
mvn(org.apache.geronimo.specs:geronimo-interceptor_3.0_spec) is needed by (installed) springframework-context-0:3.2.18-4.fc28.noarch
libnautilus-extension.so.1()(64bit) is needed by (installed) evince-nautilus-3.32.0-3.fc30.x86_64
pentaho-reporting-flow-engine is needed by (installed) libreoffice-base-1:6.2.6.2-1.fc30.x86_64
wget is needed by (installed) google-chrome-stable-76.0.3809.100-1.x86_64
libenchant.so.1()(64bit) is needed by (installed) kdelibs-6:4.14.38-15.fc30.x86_64
mvn(org.hibernate.javax.persistence:hibernate-jpa-2.0-api) is needed by (installed) springframework-context-0:3.2.18-4.fc28.noarch
libqca.so.2()(64bit) is needed by (installed) kdelibs-6:4.14.38-15.fc30.x86_64
imsettings-desktop-module(x86-64) = 1.8.1-1.fc30 is needed by (installed) imsettings-1.8.1-1.fc30.x86_64
nautilus(x86-64) is needed by (installed) evince-nautilus-3.32.0-3.fc30.x86_64
libQt3Support.so.4()(64bit) is needed by (installed) kdelibs-6:4.14.38-15.fc30.x86_64
libQtDeclarative.so.4()(64bit) is needed by (installed) kdelibs-6:4.14.38-15.fc30.x86_64
libQtDesigner.so.4()(64bit) is needed by (installed) phonon-4.10.2-3.fc30.x86_64
libQtGui.so.4()(64bit) is needed by (installed) phonon-4.10.2-3.fc30.x86_64
libQtGui.so.4()(64bit) is needed by (installed) kdelibs-ktexteditor-6:4.14.38-15.fc30.x86_64
libQtGui.so.4()(64bit) is needed by (installed) kdelibs-webkit-6:4.14.38-15.fc30.x86_64
libQtGui.so.4()(64bit) is needed by (installed) kdelibs-6:4.14.38-15.fc30.x86_64
libQtOpenGL.so.4()(64bit) is needed by (installed) kdelibs-6:4.14.38-15.fc30.x86_64
libQtSvg.so.4()(64bit) is needed by (installed) kdelibs-6:4.14.38-15.fc30.x86_64
mvn(net.sf.cglib:cglib) is needed by (installed) springframework-0:3.2.18-4.fc28.noarch
libHUpnp.so.1()(64bit) is needed by (installed) kdelibs-6:4.14.38-15.fc30.x86_64

It seems a bit risky, but we can proceed if temporary ignore the dependencies and install them back later:

sudo rpm --nodeps -e $(rpm -q -a | grep -e fc29)

In case this fails, prepare a Fedora 30 Live CD/USB and be ready to use a chroot.

Before running this command - is there any output that I should be expecting to see and should I do a reboot after the command runs? (the USB key is ready!)

You can download the latest versions of all the installed packages.
It may help in case of network issues.

mkdir -p rpms
cd rpms
dnf --refresh --skip-broken download \
$(dnf --queryformat="%{NAME}" repoquery --installed)

Hard to say because the problem is difficult to reproduce.

It may worsen because of missing dependencies, so better not.
We have more chances in the current session while dnf/rpm still work.

okay - the rpms directory was created and files downloaded.

Ran the ‘rpm --nodeps -e $(rpm -q -a | grep -e fc29)’ and now I have a problem. I was connected via cockpit and the connection to it was disconnected during the running of the command. Went to the main screen and as the screensaver was active, pressed the return key - and was presented with the screen to enter your password - no ids were listed nor the id that I had logged in with - the password field was blank and underneath it was “Authorization failed”. If I tried to enter my password, no change. The only options available where ‘Cancel’ or ‘Next’ (the next was greyed out). If I pressed cancel, I was returned to the gdm screen - pressing enter here returned me to the screen with the 'Authorization failed" message.

Try to connect directly using SSH or login locally in a text VT.

Okay - am able to login via text VT. What should I do next?

I hope, we still have rpm/dnf and network working.

sudo rpm --rebuilddb
sudo dnf clean all
sudo dnf check all
sudo dnf remove --duplicates
sudo dnf distro-sync

was able to run the rpm command but when attempted the first dnf command received the message “dnf command not found”

If you downloaded the packages locally beforehand as I mentioned above, you should be able to install it with rpm, otherwise you can still download the packages with wget/curl or transfer them via ssh.

Yes - the rpms were downloaded - just tried to do an install of the dnf modules and received the message that there were dependencies - is it possible to for the system to install the dependencies without know what they are in advance, i.e. the system will determine the dependencies and install them?

Direct `dnf` dependencies
$ dnf -q repoquery --requires --resolve --queryformat "%{NAME}" dnf
bash
python3-dnf
systemd
Recursive `dnf` dependencies
$ dnf -q repoquery --recursive --requires --resolve --queryformat "%{NAME}" dnf
acl
alternatives
audit-libs
basesystem
bash
brotli
bzip2-libs
ca-certificates
coreutils
coreutils-common
coreutils-single
cracklib
crypto-policies
cryptsetup-libs
curl
curl-minimal
cyrus-sasl-lib
dbus
dbus-broker
dbus-common
device-mapper
device-mapper-libs
dnf-data
elfutils-default-yama-scope
elfutils-libelf
elfutils-libs
expat
fedora-gpg-keys
fedora-release
fedora-release-cinnamon
fedora-release-cloud
fedora-release-common
fedora-release-container
fedora-release-coreos
fedora-release-iot
fedora-release-kde
fedora-release-matecompiz
fedora-release-server
fedora-release-silverblue
fedora-release-snappy
fedora-release-soas
fedora-release-workstation
fedora-release-xfce
fedora-repos
file-libs
filesystem
gawk
gdbm-libs
generic-release
generic-release-common
glib2
glibc
glibc-all-langpacks
glibc-common
glibc-langpack-en
glibc-minimal-langpack
gmp
gnupg2
gnutls
gpgme
grep
gzip
ima-evm-utils
iptables-libs
json-c
keyutils-libs
kmod-libs
krb5-libs
libacl
libarchive
libargon2
libassuan
libattr
libblkid
libcap
libcap-ng
libcom_err
libcomps
libcurl
libcurl-minimal
libdb
libdb-utils
libdnf
libfdisk
libffi
libgcc
libgcrypt
libgpg-error
libidn2
libksba
libmetalink
libmodulemd
libmodulemd1
libmount
libnghttp2
libnsl2
libpcap
libpsl
libpwquality
librepo
libreport-filesystem
libseccomp
libselinux
libsemanage
libsepol
libsigsegv
libsmartcols
libsolv
libssh
libssh-config
libstdc++
libtasn1
libtirpc
libunistring
libusbx
libutempter
libuuid
libverto
libxcrypt
libxml2
libyaml
libzstd
lua-libs
lz4-libs
mpfr
ncurses
ncurses-base
ncurses-libs
nettle
npth
openldap
openssl-libs
p11-kit
p11-kit-trust
pam
pcre
pcre2
popt
publicsuffix-list-dafsa
python-pip-wheel
python-setuptools-wheel
python3
python3-dnf
python3-gpg
python3-hawkey
python3-libcomps
python3-libdnf
python3-libs
python3-rpm
qrencode-libs
readline
rpm
rpm-build-libs
rpm-libs
rpm-sign-libs
sed
setup
shadow-utils
sqlite-libs
systemd
systemd-libs
systemd-pam
systemd-rpm-macros
tzdata
util-linux
xz-libs
zchunk-libs
zlib

As you downloaded the previously installed packages from the Fedora 30 repository, reinstalling them should fix the most critical issues:

sudo rpm -i rpms/*.rpm
sudo rpm -i --nodeps rpms/*.rpm

Use the second command only if the first fails to resolve the dependencies.

Wow! that is quite a list of dependencies. I have stored the rpms in the directory /root/rpms so should I execute the above command(s) from that directory or from / and specify the path to the rpms or does it matter?

oh - I see my answer - missed the cd in the first line

Argh - no success with the first command (rpm -i *.rpm) as the system noted there were dependencies. When tried the second command (rpm -i --nodeps *.rpm) there were multiple screens of messages - an example of which was /usr/bin/jemalloc.sh conflicts between attempted install of jemalloc-5.1.0-3.fc30.i686 and jemalloc-5.1.0-3.fc30.x86_64 (not sure where the i686 module is coming from). Didn’t think that was a good sign but tried the rpm --rebuilddb and then the ‘dnf clean all’ command - received the message the dnf command was not found (it was likely one of those that flew off the screen in the long list of the conflicts between the i686 and x86_64 modules.

You can try to remove the i686-packages to avoid multilib-related issues:

sudo rpm --nodeps -e $(rpm -q -a | grep -e i686)
mkdir -p ~/rpms-i686
mv -f rpms/*.i686.rpm ~/rpms-i686

Also move the i686-packages in a separate directory if any and repeat the previous step.

A bit of progress. Moved the i686 rpms to their own directory. Ran the ‘rpm -i --nodeps’ on the remaining x86_64 modules - all looked good - a number of messages about some were already installed. Next ran the ‘rpm --rebuilddb’ and then tried the 'dnf clean all" and received the message ‘-bash: dnf: command not found’. Not sure where the command was installed to but looked in the /etc directory and did find a dnf directory.

What does it say if you try to install these packages specifically?

sudo rpm -i rpms/dnf-*.rpm
sudo rpm -i rpms/python3-dnf-*.rpm

This issue might be even more serious than I assumed initially.
If you do not have much progress, then it’s probably better to save your time and just reinstall the system.

1 Like