F33 and UHD Graphics 630

Hello!
I’m novice in Linux and start to use Fedora after friend advise, Yesterday I upgraded my PC to CPU: Intel Core i5-10600K (Graphic: Intel CometLake-S GT2 [UHD Graphics 630], MB: ASRock B560 Pro4, RAM: 32GB) and installed the Fedora release 33 (Thirty Three) with KDE Plasma 5.20.5. But after installed system booted I saw resolution only 800x600 instead of 1980x1024 (!!!) and Kde shows me notification about kernel error. I fully upgraded system (Kernel: 5.10.22-200.fc33.x86_64 x86_64) but resolution wasn’t improved and error was present.
The details of error are:

not-reportable: $DATA_DIRECTORY/not-reportable

reason: mce: [Hardware Error]: Machine check events logged

backtrace: The kernel log indicates that hardware errors were detected.
The data was saved by kernel for processing by the mcelog tool.
However, neither /var/log/mcelog nor system log contain mcelog messages.
Most likely reason is that mcelog is not installed or not configured
to be started during boot.
Without this tool running, the binary data saved by kernel
is of limited usefulness.
(You can save this data anyway by running ‘cat </dev/mcelog >FILE’).
The recommended course of action is to install mcelog.
If another hardware error would occur, a user-readable description
of it will be saved in system log or /var/log/mcelog.

cmdline: BOOT_IMAGE=(hd0,gpt6)/root/boot/vmlinuz-5.10.22-200.fc33.x86_64 root=UUID=c50f8dcd-5625-47c9-8de0-f0d3819f9f6b ro rootflags=subvol=root nomodeset rhgb quiet

package: kernel-core-5.10.22-200.fc33

component: kernel

user: unknown user

type/analizer: Kerneloops/abrt-oops

pkg_fingerprint: 49FD 7749 9570 FF31

mcd: non-fatal

pkg_vendor: Fedora Project

runlevel: unknown

os_release: Fedora release 33 (Thirty Three)

architecture: x86_64

abrt_version: 2.14.5

kernel: 5.10.22-200.fc33.x86_64

And in dmesg i found some “interesting”:
[ 0.170050] smpboot: CPU0: Intel® Core™ i5-10600K CPU @ 4.10GHz (family: 0x6, model: 0xa5, stepping: 0x5)
[ 0.170095] mce: [Hardware Error]: Machine check events logged
[ 0.170096] mce: [Hardware Error]: CPU 0: Machine Check: 0 Bank 6: ee0000000040110a
[ 0.170098] mce: [Hardware Error]: TSC 0 ADDR fef20000 MISC 43880000086
[ 0.170101] mce: [Hardware Error]: PROCESSOR 0:a0655 TIME 1615746162 SOCKET 0 APIC 0 microcode e2
[ 0.170142] Performance Events: PEBS fmt3+, Skylake events, 32-deep LBR, full-width counters, Intel PMU driver.
[ 0.170149] … version: 4
[ 0.170150] … bit width: 48
[ 0.170150] … generic registers: 4
[ 0.170151] … value mask: 0000ffffffffffff
[ 0.170151] … max period: 00007fffffffffff
[ 0.170151] … fixed-purpose events: 3
[ 0.170152] … event mask: 000000070000000f

What can I do? Please help me, otherwise I will forced to refuse learning Linux and using one in general!!!
Sorry for my English. Best regards!!!

Hello, your kernel command line has the option nomodeset in it. I don’t know it got there but it’s unwanted and cripples your GPU to a mere display output. Maybe it is a remnant from the infamous mess the proprietary Nvidia driver is. If so please remove that beforehand. If not or if that does not suffice please go ahead like this:

To change that do the following: Edit the GRUB configuration:

sudo nano /etc/default/grub 

Find the the string nomodeset and delete it, save the file afterwards with CTRL+o and exit nano with CTRL+x.

Then rebuilt the grub.cfg (for UEFI systems):

sudo grub2-mkconfig -o /etc/grub2-efi.cfg 

Reboot.

And, by the way, multiple punctuation marks won’t make your words better or better understandable. Please keep to single ones, nobody likes to be screamed at. Thank you.

1 Like

Thanks for you answer and sorry for multiple punctuation.
Method, that you consider is not working in my case - after reboot, i see 4 lines on monitor:

[ 0.170095] mce: [Hardware Error]: Machine check events logged
[ 0.170096] mce: [Hardware Error]: CPU 0: Machine Check: 0 Bank 6: ee0000000040110a
[ 0.170098] mce: [Hardware Error]: TSC 0 ADDR fef20000 MISC 43880000086
[ 0.170101] mce: [Hardware Error]: PROCESSOR 0:a0655 TIME 1615746162 SOCKET 0 APIC 0 microcode e2

after that monitor become to suspend mode (indicator is blinking) because no signal on it. I reboot computer again and edit grub menu (add “nomodeset”) and boot Fedora in 800x600 again.
But now I receive new error:

reportable: The backtrace does not contain enough meaningful function frames to be reported. It is annoying but it does not necessarily signalize a problem with your computer. ABRT will not allow you to create a report in a bug tracking system but you can contact kernel maintainers via e-mail.

reason: WARNING: CPU: 7 PID: 419 at drivers/gpu/drm/i915/display/intel_display.c:11160 hsw_get_pipe_config+0xf4b/0x12a0 [i915]

package: kernel-core-5.10.22-200.fc33

component: xorg-x11-drv-intel

Hope of your help!

Regarding my previous answer, have you had the proprietary Nvidia driver installed beforehand? If yes, have you uninstalled it? If yes, check for any blacklisted kernel modules in /etc/modprobe.d.

No. It’s clear installation of Fedora KDE without any additional components and drivers. As is.

Now folder /etc/modprobe.d contains:
appletalk-blacklist.conf
l2tp_eth-blacklist.conf
netrom-blacklist.conf
ax25-blacklist.conf
l2tp_netlink-blacklist.conf
nvdimm-security.conf
batman-adv-blacklist.conf
l2tp_ppp-blacklist.conf
rds-blacklist.conf
firewalld-sysctls.conf
lockd.conf
rose-blacklist.conf
floppy-blacklist.conf
mlx4.conf
truescale.conf

Maybe I have to give content of a specific file?

I‘m running out of ideas. Is the appropriate Intel firmware installed? You may check on available packages with dnf search intel and picking some fitting for installation. Otherwise I don‘t know anymore. Try again with a live image, if that works correctly your installation may be borked in some way.

1 Like

I haven’t installed appropriate Intel firmware - result of
dnf search installed “intel
gives empty string.
It’s my fourth image that I write to flash and install to my SSD, but I’m trying to use than one on other device (old laptop), choosing menu item “Test this media & start Fedora-KDE-Live 33” working perfect, without errors in time. I’m very distressed by this situation because finding dnf search intel gives firmwares of only wireless network adapters and I can’t choose nothing.
Thanks for trying to help!

Keep cool, nobody is born as linux pro. It needs time to get in to it.
My computer also has an intel graphic adapter but i also not find anything.

When i use the program inxi -Fzx it shows me :

Graphics: Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel bus ID: 00:02.0 Display: x11 server: X.Org 1.20.10 driver: loaded: modesetting unloaded: fbdev,vesa resolution: 2560x1080~60Hz OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) v: 4.2 Mesa 21.0.0 direct render: Yes

Could you please give us this information too from your computer?

And by the way, KDE is a nice Desktop but I’m not sure if it is the best to start with Linux. You might try a other desktop like Mate etc.

microcode_ctl provides microcode for Intel CPUs and linux-firmware for GPUs.
Live booted Fedora works fine, right?
Post here output of inxi -CGaz run on both live-booted and installed system (make sure to format them here using Ctrl+Shift+C) - will see if there’s a difference of CPU microcode in use.

2 Likes

“backtrace” sounds heavy

it would be nice to see the full boot log, just after an fresh boot. maybe this way:
in an terminal key in:

dmesg > my_dmesg.txt

  • open your webbrowser and open https://paste.ubuntu.com/
  • key in your name in the field after “Poster:”
  • change the field “Expiration:” to “A year”
  • open my_dmesg.txt with an editor, select the whole text and copy&paste it into the text field named “Content:”
  • hit button “Paste!”

you’ll see the address field of your browser has changed from “https://paste.ubuntu.com/” to something like “https://paste.ubuntu.com/p/HXBXWMqfPG/”

  • mark/select the address field from the browser.
  • paste the link here

hint:
*I* quick check kernel boot’s for misbehaviour with this command line:

dmesg | grep -iEw ‘bad|bug|conflict|corrupted|error|fail|failed|fault|fatal|invalid|Lock|NULL|segfault|stack|trace|warn’

- note: this is one line (NOT 2) with a blank between …-iEw and 'bad| … -

if this command has found something I do a deeper investigation with:

dmesg | more

AFAIK, you don’t need to install any firmware, cause the firmware (in this case microcode) is usually installed on the box during Fedora installation. And in the case your motherboard has WIFi, the last FW is also automatically installed.
Both (?) are under /lib/firmware/ and gets loaded on each boot.

I guess your problem is a kernel/driver bug or missing support regarding your CPU or GPU.
key words “backtrace” and “Warning …drivers/gpu/drm/i915/display/intel_display …” sounds just like that.

what was the graphic resolution during fedora install ?
also 800x600 ?

Hi! Usually I use Cinnamon on my weak laptop but on this machine I decide try to use KDE - it’s beautiful :slight_smile:
This info about graphics from inxi:
Graphics:
Device-1: Intel CometLake-S GT2 [UHD Graphics 630] vendor: ASRock driver: N/A
bus ID: 00:02.0
Display: x11 server: Fedora Project X.org 1.20.10 driver: loaded: vesa
unloaded: fbdev,modesetting resolution: 800x600~75Hz
OpenGL: renderer: llvmpipe (LLVM 11.0.0 256 bits) v: 4.5 Mesa 20.3.4
direct render: Yes

Live Fedora works only through start “Troubleshooting → Start Fedora-KDE-Live 33 in basic graphic mode”. But in live Fedora I have resolution 1920x1080!
It’s Fedora live inxi -CGaz output:

CPU:
Info: 6-Core model: Intel Core i5-10600K bits: 64 type: MT MCP
arch: Comet Lake family: 6 model-id: A5 (165) stepping: 5
microcode: E2 L2 cache: 12 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 98397
Speed: 1265 MHz min/max: 800/4800 MHz Core speeds (MHz): 1: 1265
2: 1582 3: 1583 4: 1662 5: 1428 6: 1373 7: 1518 8: 1635 9: 1501
10: 1492 11: 1609 12: 1614
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel vendor: ASRock driver: N/A alternate: i915
bus ID: 00:02.0 chip ID: 8086:9bc5 class ID: 0300
Display: x11 server: Fedora Project X.org 1.20.8 compositor: kwin_x11
driver: loaded: vesa unloaded: fbdev,modesetting display ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.0x11.3")
s-diag: 583mm (23")
Monitor-1: default res: 1920x1080 hz: 77
OpenGL: renderer: llvmpipe (LLVM 11.0.0 256 bits) v: 4.5 Mesa 20.2.0
compat-v: 3.1 direct render: Yes

And this is inxi -CGaz output of installed system:

CPU:
Info: 6-Core model: Intel Core i5-10600K bits: 64 type: MT MCP arch: Comet Lake
family: 6 model-id: A5 (165) stepping: 5 microcode: E2 L2 cache: 12 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 98397
Speed: 800 MHz min/max: 800/4800 MHz Core speeds (MHz): 1: 800 2: 800 3: 800
4: 800 5: 800 6: 800 7: 800 8: 800 9: 800 10: 799 11: 800 12: 800
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel CometLake-S GT2 [UHD Graphics 630] vendor: ASRock driver: N/A
alternate: i915 bus ID: 00:02.0 chip ID: 8086:9bc5 class ID: 0300
Display: x11 server: Fedora Project X.org 1.20.10 compositor: kwin_x11 driver:
loaded: vesa unloaded: fbdev,modesetting display ID: :0 screens: 1
Screen-1: 0 s-res: 800x600 s-dpi: 96 s-size: 212x159mm (8.3x6.3")
s-diag: 265mm (10.4")
Monitor-1: default res: 800x600 hz: 75
OpenGL: renderer: llvmpipe (LLVM 11.0.0 256 bits) v: 4.5 Mesa 20.3.4
compat-v: 3.1 direct render: Yes

All done!
https://paste.ubuntu.com/p/YvJ8FZYwC2/
And this command:

gives me:

[ 0.088137] mem auto-init: stack:off, heap alloc:off, heap free:off
[ 0.169264] mce: [Hardware Error]: Machine check events logged
[ 0.169265] mce: [Hardware Error]: CPU 0: Machine Check: 0 Bank 6: ee0000000040110a
[ 0.169267] mce: [Hardware Error]: TSC 0 ADDR fef20000 MISC 43880000086
[ 0.169270] mce: [Hardware Error]: PROCESSOR 0:a0655 TIME 1615795088 SOCKET 0 APIC 0 microcode e2
[ 0.332022] PCI: Using host bridge windows from ACPI; if necessary, use “pci=nocrs” and report a bug

I see word “bug” it’s bad, I think :frowning:

I can start Fedora Live only through “Troubleshooting → Start Fedora-KDE-Live33 in basic graphic mode” but I had 1920x1080 resolution on live system. After installing I have only 800x600.

1 Like

Please check by the motherboard website if there is an bios update alias firmware upgrade.

That was my idea too.
but, it seem he is on the last (asrock website):

ASRock > B560 Pro4

and from the dmesg:

[ 0.000000] DMI: To Be Filled By O.E.M. To Be Filled By O.E.M./B560 Pro4, BIOS P1.50 01/28/202

if you download the bios and unzip it, it you’ll see the date matches too.

No, I see this as well.
from the data you provided:

[ 0.711400] efifb: mode is 800x600x32, linelength=3200, pages=1

and

[ 0.086417] You have booted with nomodeset. This means your GPU drivers are DISABLED

you should remove [1] the “nomodeset” and “rhgb quiet” (to see the messages during boot) too
and then do the dmesg > my_dmesg.txt again and post that.

It’s curious that you see with the live DVD the correct resolution and after installation anymore …(?!)

you could also try to:

  • try to reflash the bios, even though it’s the same
    and/or
  • reset the Bios to it’s default
  • try another monitor or monitor cable

But all the 3 above seems not really essential (I’m digging in the dust), cause with the live dvd the resolution is correct.
my last idea’s:
do you still have the kernel on the box which came the Fedora installation and have you tried to boot with it ?

another option could be loading the GPU Firmware [2] via “i915.enable_guc=2”

[2]
it’s default NOT loaded cause it might cause bug/misbehaviour, but -AFAIK- it switches on GPU power management and some more

[1]
at grub bootloader:

  • highlight/select a kernel (don’t press Enter)
  • type e (for edit)
  • move the cursor in front of the line with “initrd” (or so)
  • backspace the “nomodeset rhgb quiet”
  • hit “Crtl+x”
  1. Downloaded from asrock bios update and did it under windows with rebooting many times. After that I did reset BIOS to defaults and started Fedora - no result.

  2. Chosе in GRUB old kernel (from box), edited Grub like you sad - Fedora not booted.
    After restart I save dmesg:
    Ubuntu Pastebin

  3. Chose in GRUB new kernel and made same tricks - Fedora did non boot. After restart - give you dmesg:
    Ubuntu Pastebin

I think playing with other cable and monitor don’t have any sense because windows on this machine works perfect.

Will helpful if I boot from flash Fedora KDE Live and give dmesg log here?

Sorry, but I don’t understand. :frowning: What I have to do?