F33 - OOM and Sound issues

I run Fedora 33 on ThinkPad . I’ve done dnf upgrade 2 days ago for all packages/kernel. Kernel version 5.9.16-200.fc33.x86_64. I’ve had 3 strange symptoms lately:

1.) Voice/Video calls across all applications will have total audio failure. OS and browser/app detect the audio device, the device is selected, but they pick up (mic) and output (speaker) no audio at all. Forcing me to dial in with my phone. Video works fine. This occurs across both desktop apps and browsers, and I’ve tested with Google Meet and Microsoft Teams.

2.) YouTube videos “load forever” with a spinning circle and don’t ever play.

3.) The entire machine will slow to a lock up, and looking at dmesg output, “Web Content” (firefox) and “teams” (MS Teams) are causing the OOMs… I have 20GB of swap, and there is some insane leak that will eat up all my 32GB of RAM and all of that swap before OOM kill… There must be a leak, as this occurs with only a browser open with a few tabs, not like 50 tabs…

Reboot will solve these symptoms temporarily, but it will come back after a call or 2, or some undisclosed amount of time.

Please see attached dmesg logs: dmesg OOM/Audio issue - Pastebin.com

Also note that I’ve had some similar issue to 1874782 – Fails to resume external monitor but difference is that for me, changing the resolution helped my monitor recognize the second monitor again, and I’m no longer having that issue. The point is, this all may be related, as the 2 procs causing OOM are procs involving audio usage, the kernel errors are involving audio driver it seems, and the errors also seem to involve the audio portion of HDMI?

Anyone have any suggestions? For OOM, I plan to run htop and firefox in-browser performance monitor, as well as try more with Chrome. But again, this may be a part of a bigger issue and not sure what to do for the audio issues. Does anyone else spot any issues that I haven’t noticed in dmesg? Thanks.

1 Like
1 Like