F34 - Mouse Box - Graphical Error

Hello,

There is this really strange graphical (artifact?) that I’ve ignored for a bit, but I’m hoping there is a fix for it.

It’s hard to explain but if I use my mouse to move anything (like an image) or hover my mouse above text as I write the mouse seems to disappear and the text will “disappear” along with the mouse symbol.

It’s pretty jarring, I believe it’s an issue with maybe the GPU or the Nvidia driver but this is just a guess

Below are screenshots (unfortunately I can only post 1 screenshot)–hopefully the screenshot makes sense, any commands I can run to assist in the troubleshooting process?

Thanks in advance!

Screenshot below…this is what the graphical error looks like:
image

Try moving the mouse so it is not hovering over where you are typing.

Are you running the default gnome config?
Are you using wayland or xorg?
Have you installed the nvidia driver or using the default foss nouveau driver?
Is your system fully updated?

There are lots of interleaved pieces that could affect that issue so more info is needed to even start to troubleshoot it.

Yeah, I mean, I understand that I could just move my mouse out of the way as a work around but sometimes I have to click somewhere in the text to make edits and the mouse cursor will glitch out like the screenshot above… This graphical error makes it a difficult to make edits, because not only does hovering over the text break, highlighting text and place the cursor in-between text is broken.

Thanks, needed a head start I’ll pull that info later

Are you running the default gnome config?

Gnome config is default (now) ran the config below to rule out a GNOME config issue, same issue:

  • dconf reset -f /org/gnome/

Are you using wayland or xorg?

X11

Have you installed the nvidia driver or using the default foss nouveau driver?

Installed NVIDIA, Tue Sep 21 22:49:10 2021
±----------------------------------------------------------------------------+
| NVIDIA-SMI 470.63.01 Driver Version: 470.63.01 CUDA Version: 11.4 |

Is your system fully updated?

Fully updated > dnf check-update> dnf upgraded (same issue, but this never fixed the issue)

Fixed this issue by switching to KDE using this post:

Then once I swapped over to KDE:

  • Display and Monitor > Compositor > Rendering Background change from OpenGL to xRender. (Bug disappears).
  • Another work around, from the same section, uncheck “Enable compositor on startup”, then reboot.

As far as I can tell, GNOME and Cinnamon does not have these options ^, or they are not easily accessible unlike KDE.


Not sure why this is an issue but:

  • F34
  • NVIDIA-SMI 470.82.00 latest nvidia drivers installed (as of this post)
  • Nothing seems to fix the issue other than the work around above ^.

More screenshots below to add context:

Just a heads up that the xrender engine is dropped in the most recent version of plasma so this probably won’t work once you upgrade to F35 or later.

Well…looks like I’m not upgrading to F35, I was actually working on this as we speak.

Thank you for the heads up, would you know why xRender fixes the issue?

I decided to upgrade, eventually I hope there will be a fix for this issue.

It’s an annoying bug, but not world ending, + I think the upgrade fixed whatever was causing my laptop fans to spin at medium - high.

Now my fans sound like they would when idle (like on Windows or other Linux distros) so, I’m much happier with that vs this graphical bug.

I’ll try to get Wayland to work again, I’ve been having issues, but if I recall correctly this issue didn’t exist when I was on Wayland. I switched to Wayland for application support, but it was only 1 app I used.

I don’t know definitively, but if switching to xrender an/or disabling the compositor fixes the issue it seems likely there is something wrong in graphics stack somewhere.

1 Like

Hello,

I fixed the issue again after upgrading to F35. You were correct xRender was removed and the bug came back. Unfortunately disabling the compositor helped slightly with the bug.


First:
I fixed the issue doing the following:

  • Upgrading to the latest NVIDIA drivers using [Akashdeep Dhar] nvautoinstall:

* List item

Second:
I disabled LightDM and swapped over to GDM (I read Wayland only works on GDM)

* List item
* List item

Third:
I enabled Wayland using the following post and making the edits referenced in the post:

  • Edit the following: /etc/gdm/custom.conf
  • Add the following line: WaylandEnable=true
  • Comment or remove the following line: DefaultSession=gnome-xorg.desktop

Lastly, referring to this post:

  • Edit the following file: /usr/lib/udev/rules.d/61-gdm.rules
  • I commented everything out in the file and added the following line: DRIVER==“nvidia”, RUN+="/usr/libexec/gdm-runtime-config set daemon WaylandEnable true"
  • Move to the directory: cd /usr/lib/udev/rules.d/
  • Copy to the directory: sudo cp 61-gdm.rules /etc/udev/rules.d/
  • sudo reboot

List item


Confirm Wayland is active via CLI:

└─[0] loginctl
SESSION UID USER SEAT TTY
2 1000 gns3s3 seat0 tty2

1 sessions listed.
┌─[gns3s3@gns3s3] - [~] - [2021-12-13 02:23:52]
└─[0] loginctl show-session 2 -p Type
Type=wayland


What’s great about switching to Wayland, this thing is SMOOOOOOOTHHHHHH, it’s not choppy at all (for example on xORG most graphical items like moving the window looked unnatural). Moving windows and animations look snappy and beautiful.

Also, my mouse issue has been fixed, and I’m on the latest F35.

All in all, happy with the fixes, mouse works, animation are smooth and fluid switching to Wayland, upgrading to F35 fixed my laptops fan issue, and I’m on Plasma Wayland, which is my favorite so far :smiley:

3 Likes