F34 Server Running in Boxes network connection

Given F34 Server running in Boxes on an F34 Workstation. The server has a very simple web page that should be presented to a connecting client. This is a captive situation (all clients in the same building and on the same network as the server). I have tried to access the server from another pc on the network using Firefox and entering the ip addresses (one per try) found by issuing the commands “ip address” and ip route on the server. All attempts failed.

I have a friend who knows about setting up web pages on servers and he installed Apache and the other things he needed for the web page along with the web page. I’m trying to help him with the web connection, but this is my first involvement with a server. Can someone please help me figure this out or point me to something I can read that will help with this?

Thanks in advance for your help and Have a Great Day!

1 Like

External network requests not seen in KVM guest - #2 by vgaetera

I ran into trouble right at the beginning. On the host I did “sudo systemctl --all” the libvertd.service is shown in the list,but “inactive” and “dead”. Then I start Boxes and reran “sudo systemctl --all” and libvertd.service is still shown in the list,but “inactive” and “dead”. Then I started Server in Boxes and reran “sudo systemctl --all” and libvertd.service is shown “active” and “running”. This seemed hopeful, but after that did “ip addr show virbr0” I got “virbr0” does not exist. Then I retried “sudo systemctl --all” and the libvertd.service is back to shown in the list,but “inactive” and “dead”.

Advice on where to look next will be appreciated.

Have a Great Day!

Pat

You should start with creating a bridged connection on the host:
Host bridge with NetworkManager

I used the commands referenced in the web page to set up the bridge and the bridge slave.

nmcli connection add type bridge ifname br0 stp no
nmcli connection add type bridge-slave ifname virb0 master br0
nmcli connection up bridge-br0

I could not figure out whet “connection” to use for the Down. I tried br0 and eno1 but they returned “no active connection”.

These may show what I’ve done wrong:

$ nmcli connection show
NAME UUID TYPE DEVICE
bridge-br0 60018225-d07a-46dc-ac3b-7f7d019978fb bridge br0
Wired connection 1 0ea6ff10-ddf4-4d59-be87-1f2a4cc4869e ethernet eno1
bridge-slave-virb0 ff7a1b02-b9ad-4946-849f-1ffccf38b717 ethernet –

$ nmcli device status
DEVICE TYPE STATE CONNECTION
eno1 ethernet connected Wired connection 1
br0 bridge connecting (getting IP configuration) bridge-br0
lo loopback unmanaged

$ ip link show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
link/ether fc:4d:d4:d3:72:cc brd ff:ff:ff:ff:ff:ff
altname enp0s25
9: br0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN mode DEFAULT group default qlen 1000
link/ether fa:2e:22:92:08:a6 brd ff:ff:ff:ff:ff:ff

$ netstat -i
Kernel Interface table
Iface MTU RX-OK RX-ERR RX-DRP RX-OVR TX-OK TX-ERR TX-DRP TX-OVR Flg
br0 1500 0 0 0 0 0 0 0 0 BMU
eno1 1500 23827 0 0 0 4649 0 0 0 BMRU
lo 65536 67 0 0 0 67 0 0 0 LRU

Wrong, that needs to be your wired interface:

I tried it like this:

nmcli connection add type bridge ifname br0 stp no
nmcli connection add type bridge-slave ifname eno1 master br0
nmcli connection up bridge-br0
nmcli connection down virb0

When I did the nmcli connection down virb0 The return was “no active connection provided”. I looked at the libvirtd.service and it shows Active Running. So I would guess that virb0 should be available. Does the libvirt-guests.service need to be running? That one is showing Inactive Dead.

The br0 bridge seems to be stuck (several minutes) on getting IP.

$ nmcli connection show
NAME UUID TYPE DEVICE
bridge-br0 b85987b5-8a7a-41b9-becd-1d6cb5c19a72 bridge br0
Wired connection 1 0ea6ff10-ddf4-4d59-be87-1f2a4cc4869e ethernet eno1
bridge-slave-eno1 43ce0571-27dd-4466-a90b-d3ceb903f3da ethernet –

$ nmcli device status
DEVICE TYPE STATE CONNECTION
eno1 ethernet connected Wired connection 1
br0 bridge connecting (getting IP configuration) bridge-br0
lo loopback unmanaged

$ ip link show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
link/ether fc:4d:d4:d3:72:cc brd ff:ff:ff:ff:ff:ff
altname enp0s25
15: br0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN mode DEFAULT group default qlen 1000
link/ether fa:2e:22:92:08:a6 brd ff:ff:ff:ff:ff:ff

Thanks for your continued help with this.

Have a Great Day!

Boxes already has a bridged connection created. You should start by checking that your firewall isn’t blocking it:

firewall-cmd --list-all

After that you would want to check your virtual networks:

sudo -i
virsh net-list
virsh net-info default
virsh net-port-list

Then you’ll likely need to add a port to the virtual network.

All the nmcli commands I was doing were on the host not the server on Boxes I’m trying to connect.

Here are the results:

Cockpit is listed in this first one because I was trying to use it to set this up with no luck. a while back.

$ sudo firewall-cmd --list-all
FedoraWorkstation (active)
target: default
icmp-block-inversion: no
interfaces: br0 eno1
sources:
services: cockpit dhcpv6-client mdns samba-client ssh
ports: 1025-65535/udp 1025-65535/tcp
protocols:
forward: no
masquerade: no
forward-ports:
source-ports:
icmp-blocks:
rich rules:

virsh net-list

Name State Autostart Persistent

(None listed)

virsh net-info default

error: failed to get network ‘default’
error: Network not found: no network with matching name ‘default’

virsh net-port-list

error: command ‘net-port-list’ requires option

virsh net-port-list virb0

error: failed to get network ‘virb0’
error: Network not found: no network with matching name ‘virb0’

virsh net-port-list eno1

error: failed to get network ‘eno1’

Thanks for continuing to help me with this.

Have a Great Day!

Right. The default network is owned by root, so you have to run your virsh commands with sudo, or do sudo -i and become root before running the virsh commands.

I did the sudo -i before running the virsh commands.

I just tried it again logging in as root with SU passwprd and got the same result

what about virsh net-list --all ?

Just tried it and nothing is listed.

Forget about it, you don’t need the virb0 bridge and the NAT network that it offers.

Now you can remove the original connection to avoid conflicts and restart networking on the host.
Then verify that you have internet connectivity over the br0 bridge.

nmcli connection delete uuid 0ea6ff10-ddf4-4d59-be87-1f2a4cc4869e
sudo systemctl restart NetworkManager.service
nmcli connection show
nmcli general status

If everything is fine, then you can proceed with the VM configuration:
Guest network configuration

We are creating a shared host bridge to access the resources of the guest from the LAN.
Please don’t confuse it with the default virtual networking over NAT.

The results look good to me:

nmcli connection show

NAME UUID TYPE DEVICE
bridge-br0 b85987b5-8a7a-41b9-becd-1d6cb5c19a72 bridge br0
bridge-slave-eno1 43ce0571-27dd-4466-a90b-d3ceb903f3da ethernet eno1

nmcli general status

STATE CONNECTIVITY WIFI-HW WIFI WWAN-HW WWAN
connected full enabled enabled enabled enabled

I will start on the Guest network configuration.

Thanks and Have a Great Day!

1 Like

The web page Guest network configuration shows some XML that is to be applied. I’m guessing that since I’m running Boxes I should put this XML in using Boxes Properties → System → Edit XML. If so, that’s so, I see the following in the existing code:

<address type="pci" domain="0x0000" bus="0x01" slot="0x00"

Should the guest parameters replace this add on to this or go someplace else?

1 Like

Replace the entire original interface section, you can use pastebin.com to post the result.
The Apply button can glitch by resetting the changes, but it works on the second try.