F34: Switch default from Wayland to X11 (SDDM)

Not documented anywhere. In any event Wayland doesn’t scroll properly (at least for me) and I cannot figure out a way to change the default.

2 Likes

Have a look here:
https://docs.fedoraproject.org/en-US/quick-docs/configuring-xorg-as-default-gnome-session/

3 Likes

Thank you for the advice.
The OP and myself are looking for a way to configure KDE(sddm) and not Gnome(gdm) to not use Wayland. Although “rock solid” as in it does not crash, there are several bugs that occur, Yakuake settings not working among others. I have issued bug reports, but am trying to find a way to not use Wayland as it seems to be the different programs interaction with Wayland that are causing the issue (I think).
I have checked in
/etc/sddm.conf
/etc/sddm.conf.d
/etc/sddm
/etc/kde
/etc/X11

And have not found anywhere yet a similar option to the one presented for a Gnome environment to force the use of X11 instead of Wayland.

So…
Make sure you don’t have auto-login set.

When you turn your computer on. Bottom left corner there is an option which says (plasma-wayland) click that and you can change to (plasma-X11).
As opposed to having to edit a conf file.

1 Like

There also is a way editing
/etc/sysconfig/desktop

https://docs.fedoraproject.org/en-US/quick-docs/switching-desktop-environments/

Alternatively, edit the /etc/sysconfig/desktop file as root . This file specifies the desktop for new users and the display manager to run when entering runlevel 5.

Correct values are:

DESKTOP="<value>" , where <value> is one of the following:

  1. GNOME — Selects the GNOME desktop environment.
  2. KDE — Selects the KDE desktop environment.

DISPLAYMANAGER="<value>" , where <value> is one of the following:

  1. GNOME — Selects the GNOME Display Manager.
  2. KDE — Selects the KDE Display Manager.
  3. XDM — Selects the X Display Manager.

The desktop environment (Plasma in this case) is independent of the compositor (Wayland or X11). A third element, the desktop manager (SDDM in this case) adds further complications.

The issue relates to the default compositor.

I am only pointing this out in case someone has a similar issue.

That is correct. The issue is not resolved where one expects it to be resolved. With a manual login, the default compositor is the last one selected. However, with auto login (which I require for a number of reasons) it defaults only to Wayland which, IMHO, is not ready for prime time.

The simpler question is: “Where the &^%$# is the default set using SDDM?”

The desktop manager for gnome is gdm, not sddm which is required for KDE/Plasma.

Usually you would have to disable gdm and enable sddm with systemctl, like:
systemctl enable sddm.service ; systemctl disable gdm.service (**) ; systemctl start sddm.service

You may have to reboot.

But better try this in a vm at first.

If this does not work, you also could try the tool “Desktop Switcher” that is mentioned in the link:
https://docs.fedoraproject.org/en-US/quick-docs/switching-desktop-environments/

edit (**)
Or what display manager you are actually using