F35 KDE cannot detect my builtin sound

So I had the misfortune of corrupting my disks after a battery death. Before the death, F35 cannot detect my Builtin Analog Stereo Output unless I had plug a headphone in (yanking it out and it still can detect it). Now it just cannot detect any sound output even after plugging in a headphone.

I’ve checked the common bug section on wiki and they don’t work.

I have noted wireplumber complaining about <WpSiStandardLink:0x7f23600042c0> failed to configure si-standard-link but I don’t know why

Some output:

$ lspci -nnk | grep -i -A7 audio
00:03.0 Audio device [0403]: Intel Corporation Haswell-ULT HD Audio Controller [8086:0a0c] (rev 0b)
        Subsystem: Dell Device [1028:0652]
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel
00:14.0 USB controller [0c03]: Intel Corporation 8 Series USB xHCI HC [8086:9c31] (rev 04)
        Subsystem: Dell Device [1028:0652]
        Kernel driver in use: xhci_hcd
00:16.0 Communication controller [0780]: Intel Corporation 8 Series HECI #0 [8086:9c3a] (rev 04)
--
00:1b.0 Audio device [0403]: Intel Corporation 8 Series HD Audio Controller [8086:9c20] (rev 04)
        Subsystem: Dell Device [1028:0652]
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel
00:1c.0 PCI bridge [0604]: Intel Corporation 8 Series PCI Express Root Port 1 [8086:9c10] (rev e4)
        Kernel driver in use: pcieport
00:1c.2 PCI bridge [0604]: Intel Corporation 8 Series PCI Express Root Port 3 [8086:9c14] (rev e4)
        Kernel driver in use: pcieport

Alsa diagnosis script: http://alsa-project.org/db/?f=32440ffc3ba1b099548da982f7ce9e3455a3a76a

● session.slice - User Core Session Slice
     Loaded: loaded (/usr/lib/systemd/user/session.slice; static)
    Drop-In: /run/systemd/user/session.slice.d
             └─99-uresourced.conf
     Active: active since Thu 2022-03-17 22:34:15 CST; 1 day 20h ago
       Docs: man:systemd.special(7)
      Tasks: 78
     Memory: 566.6M (min: 250.0M)
        CPU: 20min 58.015s
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice
             ├─at-spi-dbus-bus.service
             │ ├─3651 /usr/libexec/at-spi-bus-launcher
             │ ├─3656 /usr/bin/dbus-broker-launch --config-file=/usr/share/defaults/at-spi2/accessibility.conf --scope user
             │ └─3657 dbus-broker --log 4 --controller 9 --machine-id 990550c116ce47b3a8f05206ac86542b --max-bytes 100000000000000 --max-fds 6400000 --max-matches 5000000000
             ├─dbus-broker.service
             │ ├─1951 /usr/bin/dbus-broker-launch --scope user
             │ └─1952 dbus-broker --log 4 --controller 10 --machine-id 990550c116ce47b3a8f05206ac86542b --max-bytes 100000000000000 --max-fds 25000000000000 --max-matches 5000000000
             ├─pipewire-pulse.service
             │ └─2247 /usr/bin/pipewire-pulse
             ├─pipewire.service
             │ └─2244 /usr/bin/pipewire
             ├─plasma-kded.service
             │ ├─27943 /usr/bin/kded5
             │ └─27976 /usr/bin/xsettingsd
             ├─plasma-ksmserver.service
             │ └─27938 /usr/bin/ksmserver
             ├─plasma-kwin_x11.service
             │ └─27944 /usr/bin/kwin_x11 --replace
             ├─plasma-plasmashell.service
             │ ├─27983 /usr/bin/plasmashell --no-respawn
             │ ├─28299 "kdeinit5: Running..." "" "" "" "" "" "" ""
             │ ├─28301 /usr/libexec/kf5/klauncher --fd=8
             │ ├─29177 "kio_file.so [kdeinit5] file local:/run/user/1000/klauncherfzSpoI.1.slave-socket local:/run/user/1000/kded5eWjjCC.1.slave-socket"
             │ ├─29178 "kio_file.so [kdeinit5] file local:/run/user/1000/klauncherfzSpoI.1.slave-socket local:/run/user/1000/kded5xurrsH.2.slave-socket"
             │ ├─46212 "kio_file.so [kdeinit5] file local:/run/user/1000/klauncherfzSpoI.1.slave-socket local:/run/user/1000/dolphinEgwLWP.4.slave-socket"
             │ ├─46216 "kio_file.so [kdeinit5] file local:/run/user/1000/klauncherfzSpoI.1.slave-socket local:/run/user/1000/dolphinuIhBlk.6.slave-socket"
             │ ├─46220 "kio_file.so [kdeinit5] file local:/run/user/1000/klauncherfzSpoI.1.slave-socket local:/run/user/1000/dolphintKIvlO.10.slave-socket"
             │ └─46222 "baloosearch.so [kdeinit5] baloosearch local:/run/user/1000/klauncherfzSpoI.1.slave-socket local:/run/user/1000/dolphinnEQJLQ.12.slave-socket"
             └─wireplumber.service
               └─2245 /usr/bin/wireplumber

Mar 17 22:34:15 fedora systemd[1911]: Created slice User Core Session Slice.

Are there any devices listed under System Settings → Audio?
What does wpctl status say?

wpctl status:

Audio
 ├─ Devices:
 │      42. Built-in Audio                      [alsa]
 │      44. Built-in Audio                      [alsa]
 │  
 ├─ Sinks:
 │  
 ├─ Sink endpoints:
 │  
 ├─ Sources:
 │  *   46. Built-in Audio Analog Stereo        [vol: 1.00]
 │  
 ├─ Source endpoints:
 │  
 └─ Streams:

The System Settings → audio shows something like Pro Audio and cannot find the Buit-in Audio Analog Stereo as a playback device. It however recognizes it as a recording device.

Right, I guess you can only select Off and Input for the second device. What profiles are available for the first one? Pro audio appeared for me too in 35 I think and I’m using that profile for my FiiO K5 pro (usb dac + headphone amplifier)

If I select Pro Audio, no sound will come out but audio players are happy to ‘play’ (Instead of returning an error)

1 Like

As far as I know,

Intel Corporation Haswell-ULT HD Audio Controller [8086:0a0c]
Intel Corporation 8 Series HD Audio Controller [8086:9c20]

should work fine.

Would you like to install pavucontrol and check on each tab if there any muted devices.

Or you could post the result of aplay -Ll with lowercase and uppercase L letter.

aplay -Ll: Ubuntu Pastebin

It seems that the music is “playing” in the sense that the volume bars of “pro audio” in pavucontrol are happily jumping around. But no sound comes out.

image

On very bottom window of pavucontrol select “Show: All Output Devices”. Then go to tab “Output Devices” to check the drop down selection to select the output and check if it currently muted or not. You could also need to check the far right of tab menu “Configuration” and check the drop down menu to select the card.

From your aplay your cards are detected just fine.

Problem is: I can’t find it even when I have enabled all output devices

In System settings - Audio there’s a volume bar like in pavucontrol when a playback device has a profile selected, I see a speaker with a red line over and a dimmed out volume bar if I select Force mute all output devices from the right click context menu of the lower right audio settings speaker icon.

When the K5 is powered on and in use it has a sink visible and streams:

Audio
 ├─ Devices:
 │      44. TU106 High Definition Audio Controller [alsa]
 │      63. Starship/Matisse HD Audio Controller [alsa]
 │      85. FiiO K5 Pro                         [alsa]
 │  
 ├─ Sinks:
 │  *   83. FiiO K5 Pro Pro                     [vol: 1.00]
 │  
 ├─ Sink endpoints:
 │  
 ├─ Sources:
 │  
 ├─ Source endpoints:
 │  
 └─ Streams:
        40. QtPulseAudio:54043                                          
             39. output_FR       > FiiO K5 Pro:playback_AUX1
             58. output_FL       > FiiO K5 Pro:playback_AUX0
        47. Firefox                                                     
             53. output_FL       > Plasma PA:input_FL
             78. output_FR       > Plasma PA:input_FR

I don’t know why there are a number of Pro profiles on your system (there’s likely nothing wrong except with my knowledge of wireplumber and alsa and such :slight_smile: )

Anyway if your wpctl status has a sink with vol 1.00 and shows streams and there’s still no sound output I have no other suggestion than physical ones, ie headphones and the port, but will be watching the thread to perhaps learn a thing or two.

(And yes, at first I was looking at the journal error messages about missing audio bits and couldn’t figure out why Elisa failed to playback my flacs suddenly but rather just seemed to stall in a malfunctioning way…because the only audio device with a profile (my K5) was turned off. I had perhaps expected that Elisa would play silently)

My battery did completely die, but I don’t think that will kill my headphone jack and my builtin output at the same time.

Anyway, I’m rebooting now and see if Dell’s diagnositics can make it work.

I’m back from my reboot. The Dell pre-boot diagnostics found no error with the hardware.

So it’s most likely a Fedora problem.

Anyway, it’s 23:55 my time and I have to save it for the day, please forgive me for untimely replies in the next 12 hours.

The problem resolved (to the previous plug-it-once-and-play) state when I upgraded to kernel 5.16.

Maybe it’s a regression

1 Like