F36: problems with fedora-cisco-openh264

Hi there,

I’m getting an error updating with the cisco repos:
Errors during downloading metadata for repository ‘fedora-cisco-openh264’:

  • Downloading successful, but checksum doesn’t match. Calculated: 0db88912f19858ae04ce3d89ad818679f2844afc63a4cf2ead17ecfe158be012cf9fc6b233ce61563b7215cc8583f3d0c585fd7d84769eed381eea49d9c51fd6(sha512) Expected: 402d3374ade9cd9a8a35f738f1e215c1962d6aedc411524d2050d359519474f92c3826779ac518773fb44a88f0275981ec24976c7eb845dc775d146a18de1376(sha512)
    Error: Failed to download metadata for repo ‘fedora-cisco-openh264’: Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried

image

The file itself does not look wrong:

Is that a problem with the repo? It’s a fedora repo afterall. There is no new repo file to switch to. Is there something I can do or is this a bug worth reporting (if not already done)?

I did a dnf clean all, but that didn’t really help.

Best regards,
// STi

Did you see this ?

Or this

1 Like

It is a cisco repository, actually. For legal reasons etc.etc.

If you still have problems you can run

dnf --disablerepo=fedora-cisco-openh264 update --refresh

I believe, though, that the issue is fixed by now.

1 Like

For users, the issue is already solved: Just do sudo dnf clean all and then sudo dnf update, or directly sudo dnf update --refresh. After that, you can work as usual with sudo dnf update or whatever interface you use for updates. The error should be gone now. The unsigned packages are no longer in the updates, which is not a problem because they are not security/compatibility critical at the moment. They will be added again when the issue in general is solved. But the users do not need to care about that.

1 Like