F37 install media don't boot in UEFI mode on certain motherboards

Problem

Fedora 37 install media don’t boot on certain motherboards. You might see an error similar to the following (or none at all):

Invalid image 
Failed to read header: Unsupported 
Failed to load image: Unsupported 
start_image() returned Unsupported

Cause

A problem was identified and fixed in shim, an initial UEFI bootloader. Unfortunately, the fix isn’t present on Fedora 37 install media (but should be included in Fedora 38).

Related Issues

Bugzilla report: 2113005 – Live image made with BOOTX64.EFI from latest shim-x64-15.6-2 fails to boot on some boards

Workarounds

If you’re affected, several workarounds exist:

  • Option A) Install Fedora 36 and upgrade.
  • Option B) Switch your motherboard to BIOS mode instead of UEFI and install Fedora 37 this way.
  • Option C) If you really insist on booting the Fedora 37 install media in UEFI mode and you’re a power user, then you can do the following:
    1. Burn a Fedora 37 Live media to a USB flash drive.
    2. Mount the second partition from the flash drive, which is the ESP (10 MB size, FAT filesystem).
    3. Remove EFI/BOOT/BOOTX64.EFI from that partition.
    4. Download shim-x64-15.4-5.x86_64, extract it, and find boot/efi/EFI/BOOT/BOOTX64.EFI in it.
    5. Copy the BOOTX64.EFI from the extracted RPM into the original location EFI/BOOT/ on the mounted ESP.
    6. The flash drive should now boot in UEFI mode on your system. Skip the media verification process during boot, it’s expected to fail (you’ve modified the install image).
4 Likes