F37 Invalid image error while booting

So far, I’ve tried to boot these images:

  • Fedora-Everything-netinst-x86_64-37_Beta-1.5.iso
  • Fedora-Workstation-Live-x86_64-37_Beta-1.5.iso
  • Fedora-KDE-Live-x86_64-37_Beta-1.5.iso

When I try to boot them on my hardware, this is the output I get:

Invalid image
Failed to read header: Unsupported
Failed to load image: Unsupported
start_image() returned Unsupported

I have tried these measures:

  • Verify file integrity
  • Toggle secure boot
  • Boot from USB 2.0 and 3.0 ports
  • Write to media using dd and Fedora Media Writer
  • Format media with MBR and GPT partition tables

Yet, these images refuse to boot on my hardware. The images boot fine in VMs. Fedora 36 live images boot on my hardware just fine. What relevant info should I provide?

Solved thanks to Reddit user liwindowsnux’s comment under a post by someone experiencing a similar problem on r/RockyLinux.

  • You’ll need a tool (such as Rufus) to burn the installer ISO into the USB stick in ISO mode (not dd mode) to get access to the /<USB_Stick>/EFI folder. I guess you can also use dd mode if you can get access to the EFI partition.
  • After the burning process, backup /<USB_Stick>/EFI to somewhere else just in case.
  • Get into /<USB_Stick>/EFI/BOOT, delete the original BOOTX64.EFI and BOOTIA32.EFI.
  • Rename grubx64.efi and grubia32.efi to BOOTX64.EFI and BOOTIA32.EFI respectively.
  • Boot your system with this USB stick in UEFI mode and you should be able to boot into the installer.