Failed offline updates

I got this notification today:
image

Failed to update 1 packages
cannot update repo 'fedora': Cannot prepare internal mirrorlist: Curl error (6): Couldn't resolve host name for https://mirrors.fedoraproject.org/metalink?repo=fedora-35&arch=x86_64 [Could not resolve host: mirrors.fedoraproject.org]; Last error: Curl error (6): Couldn't resolve host name for https://mirrors.fedoraproject.org/metalink?repo=fedora-35&arch=x86_64 [Could not resolve host: mirrors.fedoraproject.org] 

I already clicked Repair System once and rebooted but nothing change :slight_smile:
Is there something I should do?

1 Like

Hi, did you made modification to /etc/resolv.conf?

If not would you like to share the result of systemctl status systemd-resolved.

1 Like

It’s just a case of your system not being able to find the mirror list. Please check that your network is working and you can access the internet. If it is, it’s probably a temporary issue with the mirror list etc., so just trying again later should fix it.

No I didn’t edit /etc/resolve.conf!

It looks like it’s working now, I updated with dnf directly :+1: and then rebooted.

Thanks guys!

Mm I just rebooted and the notification is still there :thinking:

systemctl status systemd-resolved
● systemd-resolved.service - Network Name Resolution
     Loaded: loaded (/usr/lib/systemd/system/systemd-resolved.service; enabled; vendor preset: enabled)
     Active: active (running) since Tue 2022-02-22 13:20:36 CET; 1min 25s ago
       Docs: man:systemd-resolved.service(8)
             man:org.freedesktop.resolve1(5)
             https://www.freedesktop.org/wiki/Software/systemd/writing-network-configuration-managers
             https://www.freedesktop.org/wiki/Software/systemd/writing-resolver-clients
   Main PID: 895 (systemd-resolve)
     Status: "Processing requests..."
      Tasks: 1 (limit: 19029)
     Memory: 16.1M
        CPU: 180ms
     CGroup: /system.slice/systemd-resolved.service
             └─895 /usr/lib/systemd/systemd-resolved

Feb 22 13:20:36 littlebeast systemd-resolved[895]: . IN DS 20326 8 2 e06d44b80b8f1d39a95c0b0d7c65d08458e880409bbc683457104237c7f8ec8d
Feb 22 13:20:36 littlebeast systemd-resolved[895]: Negative trust anchors: home.arpa 10.in-addr.arpa 16.172.in-addr.arpa 17.172.in-addr.arpa 18.172.in-addr.arpa 19.172.in-addr.arpa 20.172.in-addr.arpa 21.172.in-addr.arpa 22.172.in-addr.arpa 23.172.in-add>
Feb 22 13:20:36 littlebeast systemd-resolved[895]: Using system hostname 'littlebeast'.
Feb 22 13:20:36 littlebeast systemd[1]: Started Network Name Resolution.
Feb 22 13:20:50 littlebeast systemd-resolved[895]: wlp3s0: Bus client set search domain list to: station
Feb 22 13:20:50 littlebeast systemd-resolved[895]: wlp3s0: Bus client set default route setting: yes
Feb 22 13:20:50 littlebeast systemd-resolved[895]: wlp3s0: Bus client set DNS server list to: 192.168.1.1, 1.1.1.1, 8.8.8.8
Feb 22 13:21:06 littlebeast systemd-resolved[895]: enp4s0: Bus client set search domain list to: station
Feb 22 13:21:06 littlebeast systemd-resolved[895]: enp4s0: Bus client set default route setting: yes
Feb 22 13:21:06 littlebeast systemd-resolved[895]: enp4s0: Bus client set DNS server list to: 192.168.1.1, 1.1.1.1, 8.8.8.8

My network is working very well, it’s ethernet connected :+1:

May be you want to try to remove your custom DNS 1.1.1.1, 8.8.8.8 and leave it on automatic setting on your network configuration.

1 Like

I removed my custom DNSs, but Fedora still fails to update with the new big update.
It notify updates, I click update all, it asks to reboot but nothing happens, nothing have been updated and at reboot it asks me to do the same update again!

I’m waiting to go for the dnf way just because I hope I can debug and help to improve something here, maybe.
(I’m a developer, even if not skilled in these software here :slight_smile: )

Awesome! Nice.

Btw I no longer have KDE installed. May be you want to install/reinstall PackageKit-Qt5.

Maybe the update cache is in a bad state.

Does

pkcon refresh force

followed by

pkcon get-updates

show all updates?

Have you looked at your journal? There should be an entry for the boot with the failed upgrade. So looking at that would be useful. Upgrades can fail for many reasons, one of them being lack of space, for example. Take a look here for more information on viewing logs:

https://docs.fedoraproject.org/en-US/quick-docs/viewing-logs/

2 Likes

Yes, pkcon get-updates show all updates.

I’ve looked at my journal and I see a lot of:

Feb 28 08:23:47 littlebeast packagekitd[2069]: Failed to get cache filename for xxx

Complete journal here

Update: after pkconf refresh force; pkconf get-updates offline updates worked!

2 Likes

Probably just an outdated cache then that was causing the issue. Not sure why this happens tbh.

Thanks @ankursinha @oprizal for the answers!

1 Like