Failed open WPS on Fedora 34 KDE

hello everybody, today I decided to re-install my laptop with Fedora 34 KDE, before re-install, I’m using Fedora 33 KDE…
my problem is when I open some documents with WPS in Fedora 34 KDE, its not working, WPS is open but just show some gray background… when I’m in Fedora 33 KDE, its working without any problem…

I tested with 2 version WPS, one is the old that working good in Fedora 33 KDE, and one the latest version from WPS, none of them working in Fedora 34 KDE…

this is the old version WPS that working good in Fedora 33 KDE :
wps-office-11.1.0.9080.XA-1.x86_64.rpm
and this the latest version from WPS :
wps-office-11.1.0.10161.XA-1.x86_64.rpm

this the picture when I open WPS

is there anything I can do to solve this problem??
or if you guys need some log, tell me what to do, I will provide it…

  • Test from another user with default settings.
  • Try to log in with Xorg/Wayland.
  • Check the output when opening from a terminal.
3 Likes

waw, awesome…

  • I try to use another user, its working, WPS running without problem…
  • I’m use Xorg, can’t use Wayland because I need NVIDIA…
  • output from WPS when run in terminal is nothing, no error/debugging message…

I wonder, why some user account can affect the whole application??

1 Like

Try to remove the app-specific configs and caches from the user profile.

Delete or rename the file office.conf under /home//.config/Kingsoft/
reopen wps office

1 Like

I can confirm that that fixed the issue for me.