Failed to start nvidia-powerd service. Kernel 5.16.5

Hey folks,

After upgrading to the kernel version 5.16.5 or at least its the first I’ve noticed this, I get this message on start up saying it failed to Failed to start nvidia-powerd service, I haven’t noticed any problems while using the system though. I couldn’t find any information on this so far, does anyone here knows what this is about ?

If you want you may try booting a older kernel and install newer kernel with
sudo dnf reinstall kernel-core

3 posts were split to a new topic: Failed to start nvidia powerd service after update

The nvidia-powerd service is a feature designed to assist with properly saving and restoring GPU status (including GPU memory) when a user has an nvidia GPU installed and wants to use suspend and/or hibernate.

If you do not have an nvidia GPU installed then that package is not needed and can be removed with sudo dnf remove xorg-x11-drv-nvidia-power which will remove the related services. My concern is that it likely would have never been installed if there were no nvidia GPU installed. It only gets installed when the user explicitly installs it.

Please post the output of inxi -Gxx so we can see the hardware config for the graphics.

@oyster We don’t know if your issue matches the problem of the OP since he has not posted again. You should open your own issue since jumping in on a new thread with a “my problem is similar” can be considered hijacking. It is difficult to follow and the answers are difficult to identify as directly related to one or the other. I split the threads for this reason

@sojonny please provide us with the output of inxi -Gxx as requested above so we can see if this is actually related to your hardware. Also please provide the output of dnf list installed \*nvidia\*

You certainly may ignore it if you choose, but having a desktop does not preclude you having an nvidia gpu and wanting to suspend or hibernate.

If you never suspend or hibernate then the nvidia-powerd service is not needed. Yet the cleanest way to handle that is to either disable the powerd service or to remove that package completely. Either of those will completely stop the errors.

@sojonny I’m sorry for my impolite conduct. This is my first topic which I send a comment to, but I should have learned more about communication in the forum.

Thank you.

1 Like