Failed to update qt5 packages

Hi,
I’m using Fedora 32 Kde spin. I have an issue updating my current installation.

Here is the output:

sudo dnf update

package qt5-qtwebengine-freeworld-5.13.2-3.fc32.x86_64 requires qt5-qtbase(x86-64) = 5.13.2, but none of the providers can be installed
  - cannot install both qt5-qtbase-5.14.2-5.fc32.x86_64 and qt5-qtbase-5.13.2-5.fc32.x86_64
  - cannot install both qt5-qtbase-5.13.2-4.fc32.x86_64 and qt5-qtbase-5.14.2-5.fc32.x86_64
  - cannot install the best update candidate for package qt5-qtwebengine-freeworld-5.13.2-3.fc32.x86_64
  - cannot install the best update candidate for package qt5-qtbase-5.13.2-5.fc32.x86_64
problem with installed package qt5-qtwebengine-freeworld-5.13.2-3.fc32.x86_64
  - package qt5-qtwebengine-freeworld-5.13.2-3.fc32.x86_64 requires libQt5Gui.so.5(Qt_5.13.2_PRIVATE_API)(64bit), but none of the providers can be installed
  - cannot install both qt5-qtbase-gui-5.14.2-5.fc32.x86_64 and qt5-qtbase-gui-5.13.2-5.fc32.x86_64
  - cannot install both qt5-qtbase-gui-5.13.2-4.fc32.x86_64 and qt5-qtbase-gui-5.14.2-5.fc32.x86_64
  - cannot install the best update candidate for package qt5-qtbase-gui-5.13.2-5.fc32.x86_64

What’s wrong?

Thanks

1 Like

Hi,
the qt5-qtwebengine & qt5-qtbase packages got updated to 5.14.2 fairly recently in the main Fedora repositories, but it seems like RPMFusion (which is where qt5-qtwebengine-freeworld comes from) hasn’t updated from 5.13.2 yet - that’s why it is looking for the older version of qt5-* packages. You’ll have to

  • wait for RPMFusion to get the update as well, or
  • uninstall qt5-webengine-freeworld if you can live without it or
  • add the packages causing the problem to excludepkgs='' in /etc/dnf/dnf.conf to prevent them from being updated, for now.
4 Likes

or simply:
sudo dnf update --exclude=qt5-qtwebengine-freeworld --skip-broken

3 Likes

This is the suggested solution.

RPMFusion has to wait for packages to go “stable” in the Fedora updates repositories before they can kick off their corresponding builds. This applies for kmods and all the -freeworld packages pretty much. There will always be a bit of a lag. So, just keep working and when RPMFusion pushes updates, your updates will proceed. Really nothing that needs to be done here.

6 Likes

Thank you. Solved after latest update.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.