Failed to write boot loader configuration, Fedora 30 UEFI dual-boot with Win10

I am hoping someone can help me. I can’t install Fedora 30. My set up is basic, a single hard drive laptop, dual-booted with Windows 10 (yes UEFI). I have previously installed Fedora 25 and 27 on this very same machine in this very same configuration successfully. But no matter what configuration I try I always get the error;

“The following error occurred while installing the boot loader. The system will not be bootable. Would you like to ignore this and continue with installation?”

The only errors in /tmp/anaconda.log are;

13:45:37,700 ERR modules.storage.partitioning.base_partitioning: Bootloader configuration has failed: Failed to find a suitable stage1 device: EFI System Partition must be mounted on one of /boot/efi.; EFI System Partition cannot be of type None.; EFI System Partition cannot be of type ntfs.; EFI System Partition must be mounted on one of /boot/efi.; EFI System Partition cannot be of type ntfs.; EFI System Partition must be mounted on one of /boot/efi.

and

18:58:45,752 ERR bootloader.grub2: failed to set menu_auto_hide=1
18:59:08,997 ERR bootloader.installation: bootloader.write failed: failed to write boot loader configuration

If I create the partitions completely manually the first error seems to not happen, but the second one still does. I don’t know what else to try other than an older Fedora image, any help greatly appreciated.

I just installed Fedora 29 first try. Something is broken in 30.

Hello @chebegeek and welcome to the community! Please take a minute to go through the posts in #start-here if you haven’t already.

There is another post that seems similar to your issue, but upgrading from F29 and not while performing a fresh installation. However you could find some useful information.

Hi @alciregi, thank you for the welcome! That posts describes a different problem, and luckily one I did not encounter when I upgraded my fresh 29 install to 30. I’m beginning to suspect I just have better luck with the odd numbered versions :slight_smile:

Well and I’m just going by the error messages in your first post…

…is your EFI partition formatted as FAT (FAT32 I think actually to be more specific)?

An EFI boot partition has a special type GUID (in the new format, GPT, partition table) it’s not identified by its file system type.

It is conceivable that Windows created this partition as NTFS and has no trouble with it - but Fedora can’t use it.

One possible workaround would be to try manual partitioning and create a new EFI boot partition just for Fedora.

1 Like

Hi @kmansoft, thank you for your reply.

I tried manually creating the partitions, it didn’t help. The only thing that helped was installing Fedora 29, which worked, so the boot partition must be just fine.

I have been having the same problem with Fedora 30. I will try 29 and see if it works.