FAS login button hidden with ad-blocking

#1

After removing btn-social class from FAS button, it reappears.
uBlock Origin doesn’t indicate that it blocked anything on this site.

#2

Ah, I guess because it’s considered a “social” login method like Google etc. This is worth an upstream bug report I reckon. I’ll check to see if there’s any discussion about this already.

1 Like
#3

This is also already reported. Can you check your blocking lists? The post suggests that default lists should not block these buttons. You’re not using Adblock, though, so it could be a configuration thing with your blocker:

1 Like
#4

I’ve got some additional block-lists.
Anyway, I don’t see option to connect FAS account to my profile and it doesn’t matter if I’m using password manager to get FAS or this site’s credentials. So it’s up to you, whether it’s worth devoting time to help (probably few) tracker fighters by differentiating FAS button from FB/Google or removing btn-social class.

Now I’ll test marking an answer as correct :wink:

#5

I can’t seem to find a setting that lets us modify the HTML of the page. There are settings to add a new Oauth mech which is where FAS is set up, but the html tags that are applied to the buttons seem to be part of the default html template.

From the looks of it, all accounts that use the same email address are considered to be of the same profile. Can you try setting your secondary e-mail to the e-mail specified in FAS and then logging in using FAS? That should hopefully set your current profile up for use with both FAS and the e-mail login that you are using now.

#6

I just successfully logged in with FAS, changing the email address here, to match FAS, sufficed.

3 Likes
#7

obraz
Should Associated Accounts section in my profile preferences still be empty, after I’ve logged in with FAS?

#8

Yep. Mine is empty too. Seems OK.

#9

Weird, but not really an issue, thanks for checking.