Fedora 30 as VMWare Player 15.1.0 Guest with Gnome 3.32/Wayland always starting with low screen resolution

I’m using a Fedora 30 installation as guest under a VMWare Player 15.1.0 build-13591040, problem still occuring after update from 14. It’s running Gnome 3.32 with the default Wayland. open-vm-tools and open-vm-tools-desktop 10.3.10 are installed. I have choosen to run the guest in full screen mode by default. It has 1GB Video RAM and 3D-accelaration activated.
Unfortunately the startup messages, the login screen and the Gnome desktop are running with 800x600. I can manually change to 1920x1200 (the physical monitor resolution) and after manual change everything runs as expected. After a reboot the same issue is back again.
Release Notes https://docs.vmware.com/en/VMware-Workstation-Player/15/rn/VMware-Workstation-151-Player-Release-Notes.html indicate a issue with RHEL8. My setup has mesa-libxatracker and xorg-x11-drv-vmware installed, issue still occuring.
Detailled system config (inxi) https://pastebin.com/K4cZMHbP

How can I fix this permanent? I would prefer a system wide, all user solution. But user specific would be second best welcome.
(Please do not post Google first hit “xrantr” solutions - they do not apply to Wayland/mutter!)

The following solution does not work, or I’m still doing something wrong. Yes, I have tried some modedb params:
https://bugzilla.redhat.com/show_bug.cgi?id=1134885
https://www.kernel.org/doc/Documentation/fb/modedb.txt
https://docs.fedoraproject.org/en-US/Fedora/20/html/Installation_Guide/sn-medialess-editing-grub-conf.html

Updated: VMWare Player 14.1.7 updated to 15.1.0