Fedora 30 Continuously Rebooting after F29-->F30 upgrade

Yesterday, I tried upgrading from Fedora 29 to Fedora 30. Everything seemed to work fine.
Frankly speaking, since yesterday, it never occured to me any issue with Fedora upgrading!
It took a couple hours to upgrade!
After that, the PC keeps rebooting, without seeing the GRUB menu!
It seems that something went wrong with the HDD MBR or the GRUB installation.

What can I do to overcome this issue?
Is there any specific process to follow?

Hi @pjhavariotis! Welcome to Ask Fedora! Please have a look at the introductory posts in the #start-here category if you haven’t had a chance to do so.

  1. Do you know if your Fedora 29 installation was using BIOS/Legacy mode or UEFI boot?

  2. Do you see something beside grub (some logos, text scrolling, etc) or does system reboot right when you’re expecting to see the grub menu?

One thing that can help is booting into live session with USB or DVD drive (I think it better be F30 one, but F29 can help too) – if you have one or can make one.

1 Like

Hi!

My Fedora 29 installation is using BIOS/Legacy mode.

The system reboots right when I am expecting to see the grub menu.

I have already created a live USB with F30.

I would appreciate if you can help me with this.

1 Like

:fedora: default GRUB is hidden by default is you don’t have not another O.S in your System on it…, you should read the information below…

1. What is the GRUB hidden menu change?

See the Detailed Description on the change page. The main motivation for adding this is to get to a fully flickerfree boot.

2. How to enable hidden GRUB menu?

On new Fedora 29 Workstation installs this will be enabled by default. If your system has been upgraded to F29 from an older release, see the page below…

more info here -> https://hansdegoede.livejournal.com/19081.html

Regards.,

2 Likes

@pjhavariotis, are you by any chance running from fast SSD drive – so that Fedora actually starts booting and you just don’t see it?

Does your computer have any other OS installed? Did you have some proprietary drivers installed in Fedora 29 – such as nvidia or amd ones?

Please also confirm by manually choosing a boot device in you BIOS settings that your computer doesn’t try to boot from something else for some reason.

Next priority is ensuring you can interact with grub – (by seeing either a grub menu or command prompt – both will do here). Then we’ll be able to determine if there’s something wrong with grub itself, the boot entry for Fedora – or is Fedora actually trying to start up and reboot happens after that.

As @hhlp pointed out, grub menu can be hidden by configuration parameter.

At this point I’d suggest booting from live USB, chrooting into your installation and doing some more tests. Follow this document, steps 1 through 8:

https://docs.fedoraproject.org/en-US/quick-docs/bootloading-with-grub2/#restoring-bootloader-using-live-disk

If something from the doc isn’t clear enough to you – feel free to ask for clarifications.

Then run

grub2-editenv list

And post the output here.

If the output contains line menu_auto_hide=1 then run to force grub menu to be visible.

sudo grub2-editenv - unset menu_auto_hide

Exit chroot environment by typing exit or pressing [Ctrl+D], reboot your system and see if it made any difference.


If it doesn’t change anything and if you’re sure you should be seeing Fedora starting to boot (you don’t have a very fast ssd) – then I’d suggest reinstalling grub – to be sure it’s installed correctly. It’s not very hard and it’s not destructive.

Also you can be bitten by this known Fedora 30 bug – though as far as I understand, it shouldn’t result in constant rebooting, just in empty grub menu or grub dropping to cli. Still the solution suggested is also reinstalling grub.

Boot again from live USB. This time be sure to boot your live USB in BIOS/Legacy mode (not UEFI mode) or you can further damage your system. You can check which mode you’ve booted into by running:

test -d /sys/firmware/efi && echo EFI || echo Legacy

Follow again the same steps you’ve followed previously, this time up to and including step 9. After you’ve reinstalled grub and regenerated grub menu, run again

sudo grub2-editenv - unset menu_auto_hide

Then proceed with steps 10 an 11. Post the results here.


If you can see/interact with grub menu but reboot still happens after choosing Fedora’s boot entry – it’ll need further debugging.

But actually it could be faster and easier just reinstalling F30 cleanly – saving you data, of course. On the one hand it’s sort of last resort thing – but on the other sometimes it’s really faster to do so than to find elusive problem.

To do this you need your /home on separate partition (which is a default option).

To be safe (or safer) you should backup all you data to other harddrive (internal or external) or some network storage. If you format partition containing your data – it’ll be gone.

When installing, you should choose manual partitioning (I personally find option advanced using blivet-gui more clean and easier to use), then you should point installer to your home partition (mountpoint /home) and ensure the option to format it is not checked.

It’s really easy – though can be a bit scary first time – I do it instead of upgrading my Fedora installation. Again, please ask if something is unclear or you’re unsure.

1 Like

Hi.

Please find attached the output you asked for.

As you can see, there is no menu_auto_hide option!

I booted the PC and the same problem occurred.

Now I will try to recreate the grub menu.

1 Like

Yep – I see it.

How about this questions:

At this point it’s still unclear, when does reboot actually happen: before grub (wrong boot device in BIOS), during grub itself – never seen such a thing, or after grub when new kernel tries to boot.

Let’s see if grub reinstall clears anything (as you’re already doing it).


Another useful info can be your /etc/default/grub file. You can access it either through chroot or by mounting /dev/fedora/root (can be done in GUI using Disks) – later being quicker/simpler.

After recreating the GRUB menu, the problem is gone!

@pjhavariotis, I’m very glad the problem is gone :+1:

Please clarify, was it enough to recreate grub menu with

grub2-mkconfig -o /boot/grub2/grub.cfg

Or did you reinstall grub as well with

grub2-install /dev/sda

It would be useful to someone with similar problem.

To be specific, I ONLY reinstalled GRUB2:
sudo grub2-install --no-floppy --recheck /dev/sda

The recreation of the GRUB2 config files, failed with the following message:
device-mapper: reload ioctl on osprober-linux-sdb1 failed: Device or resource busy

2 Likes

In this case the most probable cause was this known Fedora30 bug – or something very similar.

Reinstalling grub as pointer to in the first link and detailed in this Fedora quick doc helped you.

Can you please mark this post as solution for your thread so that other users with similar problem can find it easier.

Once again congratulations on resolving your issue!

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.