Fedora 30 Dual Boot Windows 10

Just updgraded from Fedora 29 to 30. I was running 29 in dual boot with Windows 10. I noticed after upgrading that Windows was not listed in the GRUB menu. Initially I ran grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg thinking this would fix it, but it turns out this no longer works, I believe since F30 is using BLS. Is there a way to add Windows to the GRUB menu using BLS?

1 Like

Even if it use BLS ,grub2-mkconfig must find windows ,The problem is that sometimes he does not succeed ,try restart your system and mount all partitions from files manager and try again grub2-mkconfig.

For me here are many of the questions that I have asked and I have not found an answer yet.
https://bugzilla.redhat.com/show_bug.cgi?id=1703821
(google translate)

Can you see the entry of windows boot manager when you execute in the console the comand

efibootmgr if you can see the entry does it be active?

Just an idea.

grub2-mkconfig finds windows, it actually doesn’t find anything else, but the menu entries at boot are all fedora, no windows.

# grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg
Generating grub configuration file ...
Found theme: /boot/grub2/themes/dark_squares/theme.txt
Found Windows Boot Manager on /dev/nvme0n1p1@/EFI/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for EFI firmware configuration
done

efibootmgr shows an entry for windows and for fedora, and both are active

Maybe someone with more experience than me can help you but it is what i could try do:

Try boot windows before Grub will be show in the screen (key F11, DEL depend of your MB …( if there is entry and it s active you should see it and can select this one, like USB,etc…) After reboot and jump in Fedora, first try update the grub again:

sudo os-prober
sudo update-grub

If this didn’t works try reinstall the grub in the partion that sudo os-prober showed up when you did run the command with sudo grub-install /dev/sda (if it is not sda change and select the one where you do have your windows installation)

If it is not working you should read your grub config and see if your windows entry is right if this is not a is not present you can add manually like this posts -->


https://wiki.debian.org/DualBoot/Windows10

Regards.

This would mean that windows is bootable from BIOS, not from grub. It solves the problem but can be inconvenient and doesn’t actually answer the question.

You are definitely using UEFI? Modifying the wrong config file would explain why nothing changes after you regenerate the configuration.

Either way, look inside /boot/loader/entries for an entry for Windows and check sudo tree /boot/efi for “Microsoft” files.

Correct, can boot windows from the bios menu, but I would like it back in Grub…

Yes, definitely UEFI. And no entry for Windows in /boot/loader/entries. Microsoft Files are present in /boot/efi.

Does BLS override the other settings in grub.cfg? My grub.cfg file has an entry for windows, but it seems like once grub populates the menu from blscfg it stops processing the grub.cfg file.

Try using grubby to add an entry, it could be related to this: https://bugzilla.redhat.com/show_bug.cgi?id=1691004. Check if you’re running an affected version of grubby. However, that wouldn’t explain why os-prober won’t do it, so I guess I don’t know. Sorry.

1 Like

The one thing you get during mkconfig that I don’t is “Found theme:…” I wonder if this is causing a problem?

This is my grub.cfg
https://paste.fedoraproject.org/paste/gGBnsTYeRZY~qFOjQFdPcg/raw
This is my /etc/default/grub
https://paste.fedoraproject.org/paste/~HB-HQNbMYDRPnIf6iF1YA/raw

Either compare the grub.cfg’s if you’re able to parse the code and figure out the problem; or I suggest regression testing where you make your setup more like an out of the box setup. Another option is you can edit your grub.cfg and insert a line set debug=all immediately before suspect sections, and disabled it (I think) with set debug=off or maybe it’s none. Anyway, you don’t want to enable debugging across the whole grub.cfg because it is extremely verbose. It’ll show multiple pages of debug just for inserting a single GRUB module.

Figured it out, I was just being stupid. The entries were there, but my grub theme only showed 3 in the box, I just had to scroll down. I added a scroll bar to my theme to hopefully prevent me doing this again. Thanks everyone for the help.

2 Likes