Fedora 30 gnome-shell high cpu utilization

I have some kind of problem with the gnome-shell using all 12 cpu’s on my desktop.
It doesn’t do it every time, but it does it most of the time.
I have also seen it when I boot from the Fedora 30 usb.
It makes my system so busy that I can hardly use it.
I have updated all of the software, so there are no more updates.
I do have an NVIDIA Display adapters NVIDIA GeForce GTX 1070
Intel i7-8700
BIOS Mode UEFI
Any suggestions?
Thanks!

The first thing to do would be to see what is using your CPU. Could you please install either top or htop, and run them in a terminal when your CPU usage goes high to see what process is using it?

yes, I run top and it shows gnome-shell using like 400% cpu.

That’s still only 4 of your 12 cores but still high if it’s happening all the time. Here’s the next test: do you have any extensions installed? Can you please disable them all, log out and log back and check if the issue persists?

I think I have figured out kind of what is causeing it.
This system has dual boot it has Windows 10 and Fedora 30 they have their own drives.
If I power off the system and then boot to Fedora I have the problem. If I boot to Windows and then reboot without powering off and then boot into Fedora it is fine.
I am thinking something isn’t getting initialized.

Please view the logs to see what is happening:

https://docs.fedoraproject.org/en-US/quick-docs/viewing-logs/

(It’s very hard to diagnose without having some concrete information to go on)

I don’t think I have any extensions installed, how would I verify that?


May 27 12:05:50 omen kernel: ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20181213/dsopcode-197)
May 27 12:05:50 omen kernel: ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
May 27 12:05:50 omen kernel: ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20181213/psparse-529)

May 27 12:05:50 omen kernel: kauditd_printk_skb: 43 callbacks suppressed
May 27 12:05:50 omen kernel: audit: type=1130 audit(1558980350.732:54): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-rfkill comm="systemd" exe="/usr/lib/systemd/>
May 27 12:05:50 omen kernel: r8822be: module is from the staging directory, the quality is unknown, you have been warned.
May 27 12:05:50 omen lvm[899]:   /dev/sdc: open failed: No medium found
May 27 12:05:50 omen kernel: kvm: disabled by bios

May 27 12:05:52 omen firewalld[1079]: ERROR: Failed to load zone file '/usr/lib/firewalld/zones/libvirt.xml': PARSE_ERROR: rule: Unexpected attribute priority

May 27 12:05:55 omen dhclient[1416]: Timeout too large reducing to: 2147483646 (TIME_MAX - 1)

May 27 12:05:55 omen dbus-broker-launch[1459]: Service file '/usr/share/dbus-1/services/org.gnome.evolution.dataserver.UserPrompter.service' is not named after the D-Bus name 'org.gnome.evolution.dataserver.Use>
May 27 12:05:55 omen dbus-broker-launch[1459]: Service file '/usr/share/dbus-1/services/org.gnome.evolution.dataserver.Calendar.service' is not named after the D-Bus name 'org.gnome.evolution.dataserver.Calenda>
May 27 12:05:55 omen dbus-broker-launch[1459]: Service file '/usr/share/dbus-1/services/org.gnome.evolution.dataserver.AddressBook.service' is not named after the D-Bus name 'org.gnome.evolution.dataserver.Addr>
May 27 12:05:55 omen dbus-broker-launch[1459]: Service file '/usr/share/dbus-1/services/org.gnome.evolution.dataserver.Sources.service' is not named after the D-Bus name 'org.gnome.evolution.dataserver.Sources5>

May 27 12:06:05 omen gnome-session[1875]: gnome-session-binary[1875]: GLib-CRITICAL: g_child_watch_add_full: assertion 'pid > 0' failed
May 27 12:06:05 omen gnome-session-binary[1875]: GLib-CRITICAL: g_child_watch_add_full: assertion 'pid > 0' failed

This is just some of the stuff from journalctl that might be related.

You can install gnome-tweak-tool and run it by looking for “tweaks” in the Gnome overview. It’ll have a section on extensions. If you haven’t installed any, though, that should be fine.

How about creating a new user and checking if the issue persist there in the clean, pristine environment? That will tell us if it’s some user-configuration that one of the apps you are using may have done?

I don’t think it has anything to do with the user, since it does the same thing when booting from the USB image.
Even before I login I can tell there is a problem, The pointer for the mouse is very jerky and entering the password is slow. I turned off all the extensions, I had just changed the background images is all.
This is pretty much default install. I think I have some kind of hardware that isn’t gettting setup correctly from a cold boot.

Maybe consider using the proprietary NVIDIA driver using the instructions by the fedora magazine.

1 Like

Installed the NVIDA driver, but then it couldn’t find the module. I am pretty sure that is because I have secure boot turned on. But it also seems to be working without the NVIDIA driver, so I am thinking maybe this was what changed:

set “WaylandEnable=false” in */etc/gdm/custom.conf

When I looked at it is was already set to false.

I know if I power off the system and power it on and boot the Workstation - LiveCD 30 that it will have the problem with the gnome-shell using most of the cpu.
If I boot Windows 10 first and just do a reboot so that the system doesn’t power off then the Workstation - LiveCD 30 works just fine.

care to post the output of:

dmesg|grep -iEw 'bad|bug|conflict|corrupted|error|fail|failed|fault|fatal|Lock|NULL|segfault|stack|trace|warn'
  • from dmesg until warn’ it’s ONE line -

P.S.
that your issues disappears after warm reboot sounds known.
years ago I was unable to enable Wifi under fedora after I turned it off under windows (a setting in HW register).

So I guess your issue has sometime to do with your graphics (=> gnome shell 400 % …) !
I guess there is an Intel AND an nvidia in your box, right ?
I further guess there will some hardware register for your graphics set if you boot to windows.
These setting remain during warm boot to Fedora and they are NOT set if cold boot.

did you and how did you installed your nvidea ?
is intel firmware loaded for your intel graphic card to ?

  • HINT: I have NO experiences with dual graphics, so I’m somewhat in the wild -

more to read:
https://wiki.archlinux.org/index.php/intel_graphics#Enable_GuC_/

anyhow my /etc/default/grub for an Skylake (i7-6700) looks like this:

GRUB_CMDLINE_LINUX="... i915.enable_guc=3 i915.enable_fbc=1 rhgb quiet ..."

Hints:

  • fbc is nowerdays default I guess
  • i915 option may provided via boot parameter too.
    So for a single use test case you could edit via key “e” at grub boot prompt the line containing rhgb and add the above i915 options.
    hit key “x” afterwards to boot with it.
  • you need to do run grub2-mkconfig if you put it in /etc/default/grub

maybe more on vendor foren and/or an Bios update …, don’t know !


dmesg|grep -iEw 'bad|bug|conflict|corrupted|error|fail|failed|fault|fatal|Lock|NULL|segfault|stack|trace|warn'
[    0.000000] [Firmware Bug]: TSC ADJUST: CPU0: -30092769 force to 0
[    0.000423] [Firmware Bug]: TSC ADJUST differs within socket(s), fixing all errors
[    0.265930] MDS CPU bug present and SMT on, data leak possible. See https://www.kernel.org/doc/html/latest/admin-guide/hw-vuln/mds.html for more details.
[    0.320178] PCI: Using host bridge windows from ACPI; if necessary, use "pci=nocrs" and report a bug
[    1.288117] ata1.00: ACPI cmd f5/00:00:00:00:00:00 (SECURITY FREEZE LOCK) filtered out
[    1.288150] ata3.00: ACPI cmd f5/00:00:00:00:00:00 (SECURITY FREEZE LOCK) filtered out
[    1.291860] ata3.00: ACPI cmd f5/00:00:00:00:00:00 (SECURITY FREEZE LOCK) filtered out
[    1.293082] ata1.00: ACPI cmd f5/00:00:00:00:00:00 (SECURITY FREEZE LOCK) filtered out
[    1.294428] ata5.00: ACPI cmd f5/00:00:00:00:00:00 (SECURITY FREEZE LOCK) filtered out
[    1.301120] ata5.00: ACPI cmd f5/00:00:00:00:00:00 (SECURITY FREEZE LOCK) filtered out
[    2.432560] Call Trace:
[    2.433016] ---[ end trace 078c1a2fd28c2e78 ]---
[    4.495136] nouveau 0000:01:00.0: secboot: error during falcon reset: -110
[    4.495142] nouveau 0000:01:00.0: gr: init failed, -110
[    4.953182] EXT4-fs (dm-0): mounted filesystem with ordered data mode. Opts: (null)
[    6.697535] EXT4-fs (dm-0): re-mounted. Opts: (null)
[    7.033817] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20181213/dsopcode-197)
[    7.033821] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[    7.033825] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[    7.033862] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20181213/dsopcode-197)
[    7.033864] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[    7.033867] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[    7.033905] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20181213/dsopcode-197)
[    7.033908] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[    7.033911] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[    7.040574] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20181213/dsopcode-197)
[    7.040578] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[    7.040584] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[    7.040628] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20181213/dsopcode-197)
[    7.040631] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[    7.040635] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[    8.309866] EXT4-fs (dm-2): mounted filesystem with ordered data mode. Opts: (null)
[    8.312755] EXT4-fs (sdb2): mounted filesystem with ordered data mode. Opts: (null)
[   10.704056] nouveau 0000:01:00.0: gr: init failed, -16
[   18.655637] nouveau 0000:01:00.0: gr: init failed, -16

I just have the 1 NVIDIA graphics card.

I just used the software tool and searched for NVIDIA and installed it, but when it boots it can’t find the module because of the secure boot in the BIOS and I wasn’t ready to disable that, so I just uninstalled the NVIDIA software it seems to be working, but I am also getting
xorg-x11-drv-nouveau System Failure in the Gnome-abrt tool.

The backtrace does not contain enough meaningful function frames to be reported. It is annoying but it does not necessary signalize a problem with your computer. ABRT will not allow you to create a report in a bug tracking system but you can contact kernel maintainers via e-mail.

The only thing I can think to do in just reinstall the OS and then edit the /etc/gdm/custom.conf file and see what it looks like? And see if that is what fixed it. I am not seeing the cpu problem now, but I am still getting those xorg-x11-drv-nouveau system failures.
Thanks!

sure ?
according to your infos you provides:

=> Intel® UHD Graphics 630

Intel is the cpu, not the graphics card.
I reloaded Fedora 30 and ran the update and it looks like removing the comment from the /etc/gdm/custom.conf appears to fix the issue. So the line WaylandEnable=false is normally commented out and if I remove the # at the beginning of that line then the high cpu issues seems to go away.

That seems to indicate a Wayland issue. It’s known to cause some with nvidia hardware, especially with the free/open source nouveau driver:

https://nouveau.freedesktop.org/wiki/

It may be worth reporting your issue here:

PS: could I please request you to use the formatting tools that the editor provides? It makes posts much easier to read. I’ve edited your posts now to do so, but please keep this in mind in future.

See this
https://discourse.gnome.org/t/high-cpu-usage-by-gnome-shell/940/6