Fedora 30 halts on boot after update

Fedora 30 5.2.11-200.fc30.x86-64 was working smoothly.
An update download and install was suggested and I accepted.
And went to do some other things leaving the computer alone.
Apparently, version 5.3.6-200.fc30.x86_64 was installed.

When I came back I found a screen halted with the screen full of this log.

And this is the last screen of the boot log.

No matter the attempt, the process halts at some point.
The last instruction varies.

One more thing.
I can boot with the Fedora 12 version.
Very limited though, but it works.
Nautilus shows my HDD is intact with all of my data in it.

Only doubt I can have when version 5.2.11 update was taking place is if any of my cats stepped on the keyboard while I was away.

You should see more details if you remove ‘quiet’ from the kernel command line. On the grub menu you see when you boot, press E to edit the entry, locate the ‘linux’ line and remove the word ‘quiet’ from it. Press Ctrl-X to go ahead and boot. The change is not permanent, it’ll be noisy, but it’ll help you see more details.

Hi @mackissack

Your issue look similiar to the issue of this user what was solved ( It is in case you have a Nvidia card and did install the privative driver in the same way that the user commented).

Regards

No improvement.
I even used the Fedora 30 rescue mode deleting the ‘quiet’ instruction.
Halted the same.
This is the log screen:

It may be an SELinux issue. Try booting with an additional kernel parameter enforcing=0 and see if that gets you through. Ref. https://danwalsh.livejournal.com/10972.html

Thank you.
Got it.
Now, where do I write the command?

Right after ‘quiet’ on the linux line

Didn’t help.
It halted after this.

Let me tell you it halts after different instructions.
If printer is on or not, according to the command you suggested and so on.

The messages you see may make it seem like the instructions are happening in a sequence but systemd is actually starting services in parallel, as fast as it can :slightly_smiling_face: Try booting into the single user mode with the parameter single. This goes in the same place where you wrote enforcing=0 on the linux line. You should find yourself in single user mode where it’ll ask for the root password. Enter that and you should be able to look through journalctl for clues on what’s keeping the machine from fully booting. Incidentally, you don’t have nvidia drivers or other custom shenanigans going on right?

Thank you so much.
I’ll try tomorrow.
Am going to bed now.

I am connected to the mother built-in video card.
It is an ASRock or another built.

Fine.
It asked the root pwd and finally showed the root prompt
[root@hy ~]#

I even asked an ls and the files were shown.

Now, what next? Call gnome?
How do I fix the booting bug?

I ordered the system to exit.
And it went idle after this