Fedora-30 | horizontal touchpad speed much higher than vertical touchpad speed

Hello everyone,

On my new fedora installation the touchpad speed in the vertical direction is much higher than the speed in the vertical direction, which makes using the touchpad nearly impossible.
$ libinput list-devices returns the following information for my touchpad:

Device:           SynPS/2 Synaptics TouchPad
Kernel:           /dev/input/event4
Group:            8
Seat:             seat0, default
Size:             50x91mm
Capabilities:     pointer 
Tap-to-click:     disabled
Tap-and-drag:     enabled
Tap drag lock:    disabled
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   *two-finger edge 
Click methods:    none
Disable-w-typing: enabled
Accel profiles:   none
Rotation:         n/a

I have the suspicion that the touchpad reports it’s dimensions in the wrong order (50x91mm instead of 91x50mm) and therefore doubles the speed vertically while halving the speed horizontally. Unfortunately i don’t know how to change these settings with libinput. I googled a bit but only found commands involving “xinput” which had no effect on my machine, except glitching the cursor in firefox (probably because it’s running in some kind of xorg emulation). Thanks to everyone for your time.

If you need some more information here is the output of some commands i found in other threads about similar problems:

[midori@localhost ~]$ xinput list
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ xwayland-relative-pointer:16            	id=7	[slave  pointer  (2)]
⎜   ↳ xwayland-pointer:16                     	id=6	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ xwayland-keyboard:16                    	id=8	[slave  keyboard (3)]

[midori@localhost ~]$ udevadm info  /dev/input/event4
P: /devices/platform/i8042/serio1/input/input5/event4
N: input/event4
L: 0
S: input/by-path/platform-i8042-serio-1-event-mouse
E: DEVPATH=/devices/platform/i8042/serio1/input/input5/event4
E: DEVNAME=/dev/input/event4
E: MAJOR=13
E: MINOR=68
E: SUBSYSTEM=input
E: USEC_INITIALIZED=24298367
E: EVDEV_ABS_00=1284:5696:88
E: EVDEV_ABS_01=1287:4838:39
E: EVDEV_ABS_35=1284:5696:88
E: EVDEV_ABS_36=1287:4838:39
E: ID_INPUT=1
E: ID_INPUT_TOUCHPAD=1
E: ID_INPUT_WIDTH_MM=94
E: ID_INPUT_HEIGHT_MM=42
E: ID_BUS=i8042
E: ID_SERIAL=noserial
E: ID_PATH=platform-i8042-serio-1
E: ID_PATH_TAG=platform-i8042-serio-1
E: ID_INPUT_TOUCHPAD_INTEGRATION=internal
E: LIBINPUT_DEVICE_GROUP=11/2/7:isa0060/serio1
E: LIBINPUT_FUZZ_00=8
E: LIBINPUT_FUZZ_01=8
E: LIBINPUT_FUZZ_35=8
E: LIBINPUT_FUZZ_36=8
E: DEVLINKS=/dev/input/by-path/platform-i8042-serio-1-event-mouse

Hi @midory! Welcome to the community! Please have a look at the introductory posts in the #start-here category if you haven’t had a chance to do so.

If you haven’t solved your problem, then

It looks like you’re spot on here.

I’ve booted a Fedora Live session on a work laptop I have access to. Here’s my output of libinput:

Device:           SynPS/2 Synaptics TouchPad
Kernel:           /dev/input/event6
Group:            9
Seat:             seat0, default
Size:             98x49mm
Capabilities:     pointer 
Tap-to-click:     disabled
Tap-and-drag:     enabled
Tap drag lock:    disabled
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   *two-finger edge 
Click methods:    none
Disable-w-typing: enabled
Accel profiles:   none
Rotation:         n/a

As you can see on this notebook dimensions are reported correctly. That’s with kernel 5.2.6.

Output of udevadm:

P: /devices/platform/i8042/serio4/input/input11/event6
N: input/event6
L: 0
S: input/by-path/platform-i8042-serio-4-event-mouse
E: DEVPATH=/devices/platform/i8042/serio4/input/input11/event6
E: DEVNAME=/dev/input/event6
E: MAJOR=13
E: MINOR=70
E: SUBSYSTEM=input
E: USEC_INITIALIZED=14016537
E: ID_INPUT=1
E: ID_INPUT_TOUCHPAD=1
E: ID_INPUT_WIDTH_MM=97
E: ID_INPUT_HEIGHT_MM=48
E: ID_BUS=i8042
E: ID_SERIAL=noserial
E: ID_PATH=platform-i8042-serio-4
E: ID_PATH_TAG=platform-i8042-serio-4
E: ID_INPUT_TOUCHPAD_INTEGRATION=internal
E: LIBINPUT_DEVICE_GROUP=11/2/7:isa0060/serio4
E: LIBINPUT_FUZZ_00=8
E: LIBINPUT_FUZZ_01=8
E: LIBINPUT_FUZZ_35=8
E: LIBINPUT_FUZZ_36=8
E: DEVLINKS=/dev/input/by-path/platform-i8042-serio-4-event-mouse

So if your problem still isn’t solved, I’d look up something about configuring libinput devices.

Don’t know anything about it, can try to help searching if you’re still interested.