Fedora 30 - Install GFORTRAN_7

I am running a program on f30 which requires GFORTRAN_7. When I try to execute it I get the following error

$ ./sammy
./sammy: error while loading shared libraries: libgfortran.so.4: cannot open shared object file: No such file or directory

The first thing I thought of doing was a softlink that will point to libgfortran.so.5 which in my system is in the /usr/lib64/libgfortran.so.5 directory. So I did

sudo ln -s /usr/lib64/libgfortran.so.5 /usr/lib64/libgfortran.so.4

and when running the code I got a different error

$ ./sammy
./sammy: /lib64/libgfortran.so.4: version `GFORTRAN_7’ not found (required by ./sammy)

I’ve searched with dnf provides \*/libgfortran.so.4 to find a package that provides the library but the result is

Error: No Matches found

Any idea on how to install GFORTRAN_7 on my system?

Thanks in advance.


The up to date links:

Thank you very much!
It seems that it is working!

However, since I would like to learn…how can somebody build these files and use them in the future for other cases and other versions?

For example, I would like to install Qtiplot in f30. The repository found here https://copr.fedorainfracloud.org/coprs/scorpionit/qtiplot/package/qtiplot/ has it, but only until f28 so it would be useful to know how to do it myself!

1 Like

You have the following options to run old/incompatible software:

2 Likes