Fedora 30 - Network card not found on first boot

Hi,

I have been successfully using Fedora on my ancient I3 desktop for more than a year, starting in Fedora 27 and now running Fedora 30.
Here are the details of my machine|:
#uname -srvpo
Linux 5.2.9-200.fc30.x86_64 #1 SMP Fri Aug 16 21:37:45 UTC 2019 x86_64 GNU/Linux

Earlier this week I found that network is unavailable - the device: eno1 is missing.
A second reboot - solves it all - until the next shutdown and reboot.

Looking in /var/log/messages after the first boot, we can find the following messages:
ep 1 07:30:43 myLinux kernel: e1000e: Intel® PRO/1000 Network Driver - 3.2.6-k
Sep 1 07:30:43 myLinux kernel: e1000e: Copyright© 1999 - 2015 Intel Corporation.
.
.
Sep 1 07:30:43 myLinux kernel: e1000e 0000:00:19.0: Interrupt Throttling Rate (ints/sec) set to dynamic conservative mode
Sep 1 07:30:44 myLinux kernel: e1000e: probe of 0000:00:19.0 failed with error -3

The relevant messages, after rebooting the machine - show no error and things are OK:
ep 1 08:21:47 myLinux kernel: e1000e: Intel® PRO/1000 Network Driver - 3.2.6-k
Sep 1 08:21:47 myLinux kernel: e1000e: Copyright© 1999 - 2015 Intel Corporation.
Sep 1 08:21:47 myLinux kernel: e1000e 0000:00:19.0: Interrupt Throttling Rate (ints/sec) set to dynamic conservative mode
Sep 1 08:21:48 myLinux kernel: logitech-djreceiver 0003:046D:C534.0003: hidraw2: USB HID v1.11 Keyboard [Logitech USB Receiver] on usb-0000:
00:1a.0-1.3/input0
Sep 1 08:21:48 myLinux systemd-udevd[392]: link_config: autonegotiation is unset or enabled, the speed and duplex are not writable.
Sep 1 08:21:48 myLinux kernel: e1000e 0000:00:19.0 0000:00:19.0 (uninitialized): registered PHC clock
Sep 1 08:21:48 myLinux kernel: nouveau 0000:01:00.0: NVIDIA GK208B (b060b0b1)
Sep 1 08:21:48 myLinux kernel: e1000e 0000:00:19.0 eth0: (PCI Express:2.5GT/s:Width x1) 38:60:77:e0:26:f6
Sep 1 08:21:48 myLinux kernel: e1000e 0000:00:19.0 eth0: Intel® PRO/1000 Network Connection
Sep 1 08:21:48 myLinux kernel: e1000e 0000:00:19.0 eth0: MAC: 10, PHY: 11, PBA No: FFFFFF-0FF
Sep 1 08:21:48 myLinux systemd-udevd[363]: Using default interface naming scheme ‘v240’.
Sep 1 08:21:48 myLinux systemd-udevd[363]: link_config: autonegotiation is unset or enabled, the speed and duplex are not writable.
Sep 1 08:21:48 myLinux kernel: e1000e 0000:00:19.0 eno1: renamed from eth0

I am posting my issue here since I only found reported bugs regarding the -3 error during “e1000e’s probe”, and I hope you’ll be able to assist me solving the issue.
Thanks
Shay

sudo rmmod e1000e
sudo modprobe e1000

echo blacklist e1000e | sudo tee /etc/modprobe.d/e1000e.conf
echo e1000 | sudo tee /etc/modules-load.d/e1000.conf

Check your EFI/BIOS settings. Most have an option to have the built in network hardware initialized during boot.

Hi,

Well, nothing really helped and I still need to reboot the computer twice for having my network setup correctly.
The above suggested actions - removing the e1000e module and replace it with e1000 did not solve the problems so I reverted that.

Anymore ideas before I turn into stupid workarounds like writing a shell script, which reboots the computer if the network is not setup?

Many thanks for your help
Shay

1 Like