Fedora 30 (SilverBlue), screen sharing

Hi,

Granted that Wayland and Gnome do not support the old Vino and Xvnc and so on, for desktop sharing, and that Gnome has recently implemented new desktop sharing software on top of Wayland. After installing Fedora 30 (SilverBlue if that matters), I saw in the settings that the screen sharing option was available by default, without having to enable experimental features and install pipewire and so on, like in previous Gnome versions.

My prior GNU/Linux installation was a PureOS/Debian10 frankenhybrid running Gnome 3.30, where I was successfully able to install and enable desktop sharing and connect to my desktop using RealVNC’s VNC Viewer and the macOS Screen Sharing application included by default, which uses VNC.

Now migrating to SB, after enabling screen sharing, I can see that port 5900 is available, however when I attempt to connect to with either VNC Viewer or Screen Sharing, I get a message explaining that the protocol is incompatible or encryption level should be changed. I’ve tried without encryption as well from VNC Viewer, with no change to the error message.

Are there changes to the protocol used by screen sharing? Has anyone encountered this issue?

I can provide logs later once I’m back at my desktop…

thanks in advance

https://bugs.launchpad.net/ubuntu/+source/vino/+bug/1281250
It seems that some clients such as TightVNC do not support the encryption method.
You should be able to workaround this with:

gsettings set org.gnome.Vino require-encryption false

To secure the connection, utilize SSH or VPN tunneling.

2 Likes

That however is quite old isn’t it? Vino isn’t being used anymore… (I also tried it and it had no effect)

How about this:

gsettings set org.gnome.desktop.remote-desktop.vnc encryption "['none']"
sudo firewall-cmd --permanent --add-service=vnc-server
sudo firewall-cmd --reload

And reboot/relogin to make sure the settings are applied correctly.

1 Like

That gsettings line worked! Noting it down for future reference, thanks!

2 Likes

Hi @pajux! Welcome to Fedora! Please take a minute to go through the introductory posts in the #start-here category if you’ve not had the chance to do so yet.

For this particular thread, could you please mark @vgaetera’s post as the answer if it worked for you? That way, it’ll be visible to others too.

2 Likes