Fedora 30 with GDM Login Issue

Hi guys,
I have been using fedora for quite some time now. from my last system update, I am not getting password prompt when I turn on my laptop, It directly take me in to it. Although password is there and it prompts for installations and to boot back from the lock screen.

Linux nuke 5.2.11-200.fc30.x86_64 #1 SMP Thu Aug 29 12:43:20 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

`

1 Like

Do you see any thing that indicates GDM is started when you boot fedora?
Also check output of this command. Is GDM service enabled there?
sudo systemctl list-unit-files | grep gdm

below is the response of the command

gdm.service enabled

GDM doesn’t show off when laptop is turned on and get loaded up to the GUI directly. Do not ask for any password. but after that it it works fines i.e. if I lock the screen and then get back to login it properly asks for the password as it should. but fails on the first boot.

Let’s check your settings:

head -n -0 /etc/gdm/*.conf /var/lib/AccountsService/users/*

Please also check Gnome settings --> Details --> Users – there’s an option Automatic login. Isn’t it the culprit?

1 Like

HI @nightromantic yea it was on and problem fixed. however I wonder how it got turned on. but Thanks for the help.

1 Like

I’m glad good it was this simple )

I have no idea ) Can say one thing for sure: it never happened to me without me explicitly enabling it in the Settings.

The most simple/obvious way would be for it to be clicked/enabled by mistake.

Here’s also a way to do it with config file:

https://help.gnome.org/admin/system-admin-guide/stable/login-automatic.html.en

I’d say there’s quite a low probability of it to be done maliciously: someone who could enable this setting (or edit the config file) could change your password or simply use it to login.

1 Like