Fedora 31 blinking underscore after succesfull boot

I run Fedora 31 with Grub on my machine, alongside Windows 10. Recently, Fedora boots only with my oldest kernel selected 5.3.6. If I try to start the machine with a newer Linux Kernel, everything seems to start up fine, there are no errors but it gets stuck somehow and a underscore is just blinking forever. I removed rhgb to see what is happening - everything seems to succeed.

Computer Specifications:

Motherboard: ASRock x470 Fatality Gaming K4
CPU: AMD Ryzen 2700X
GPU: Asus GTX 1080Ti Strix

If more hardware specifications are needed, I can follow up with it.

Hi @hertelukas
Welcome to the Fedora Community.
That’s an Nvidia GPU you’ve got there. Have you tried booting with “Basic Graphics” on the newer kernels? Add nomodeset to the kernel parameters and see how far it goes.

Here’s how:
GRUB2 Menu – highlight the kernel – hit “E” – scroll down to the line that starts with “linux” – go to the end of that line and add nomodeset – hit CTRL+x

How far did it go?

1 Like

The last message I get is:

Started GNOME Display Manager
Starting Manage, Install and Generate Color Profiles…

The boot process seems to get stuck here.
I installed the NVIDIA Drivers half a year ago, following this article: Fedora NVIDIA Guide

You need to take a look at the log files to see what’s going on.

Boot one kernel (the newest) that gets stuck. Then boot a kernel that boots successfully, then

journalctl -b -1

to see the logs of the second to last boot process. Gnome also has a Log app in case you’re not yet familiar with journalctl.

The last view log messages I receive, if I boot a new Kernel are:

10:12:45 kernel: virbr0: port 1(virbr0-nic) entered disabled state
10:12:44 kernel: device virbr0-nic entered promiscuous mode
10:12:44 kernel: virbr0: port 1(virbr0-nic) entered disabled state
10:12:44 kernel: tun: Universal TUN/TAP device driver, 1.6
10:12:44 kernel: bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
10:12:43 kernel: RPC: Registered tcp NFSv4.1 backchannel transport module.
10:12:42 kernel: squashfs: version 4.0 (2009/01/31) Phillip Lougher
10:12:42 kernel: EXT4-fs (dm-2): mounted filesystem with ordered data mode. Opts: (null)
10:12:42 kernel: loop: module loaded
10:12:41 kernel: input: HDA NVidia HDMI/DP,pcm=12 as /devices/pci0000:00/0000:00:03.1/0000:0b:00.1/sound/card2/input25
10:12:41 kernel: EDAC amd64: Node 0: DRAM ECC disabled.
10:12:40 kernel: input: HD-Audio Generic Front Headphone as /devices/pci0000:00/0000:00:08.1/0000:0d:00.3/sound/card3/input18
10:12:40 kernel: EDAC amd64: Node 0: DRAM ECC disabled.
10:12:40 kernel: usbcore: registered new interface driver snd-usb-audio
10:12:40 kernel: snd_hda_codec_realtek hdaudioC3D0: Line=0x1a
10:12:40 kernel: EDAC amd64: Node 0: DRAM ECC disabled.
10:12:40 kernel: MCE: In-kernel MCE decoding enabled.
10:12:40 kernel: SVM: Virtual GIF supported
10:12:40 kernel: kvm: Nested Paging enabled
10:12:40 kernel: snd_hda_intel 0000:0d:00.3: enabling device (0000 -> 0002)
10:12:40 kernel: usb 3-1: Focusrite Scarlett Gen 2 Mixer Driver disabled; use options snd_usb_audio device_setup=1 to enable and report any issues to g@b4.vu
10:12:40 kernel: usbcore: registered new interface driver xpad
10:12:40 kernel: ccp 0000:0c:00.2: ccp enabled
10:12:40 kernel: sp5100-tco sp5100-tco: Watchdog hardware is disabled
10:12:40 kernel: sp5100_tco: SP5100/SB800 TCO WatchDog Timer Driver
10:12:40 kernel: ccp 0000:0c:00.2: enabling device (0000 -> 0002)
10:12:40 kernel: mc: Linux media interface: v0.10
10:12:40 kernel: piix4_smbus 0000:00:14.0: Using register 0x02 for SMBus port selection
10:12:40 kernel: input: PC Speaker as /devices/platform/pcspkr/input/input11
10:12:40 kernel: acpi_cpufreq: overriding BIOS provided _PSD data