Fedora 31 Cannot open access to console, the root account is locked in emergency mode

Hi team,

I am having this issue - here is the page I used to attempt troubleshooting: [Howto] Cannot open access to console, the root account is locked in emergency mode (dracut emergency shell)

I also did the 8 steps from the page linked in the step 1 of the above link.

Now I login to this new root…and can’t do anyhing else. This comment from the above link summarizes my situation…

dimgs
Aug '19
Now, when I boot it asks the root password, which I set with the above instructions.
After that, I put the new root password and I am to the shell as root. What I should do to bring the GUI and login to my desktop?
I tried the “startx” command, but nothing happened.

…I will continue troubleshooting as I want to recover some files from this installation - otherwise I would have just installed Fedora again. I haven’t used my Fedora laptop for more than two weeks, typing this from Windows.

Live USB or DVD?  And then recover things, then reinstall Fedora?

Optionally:  Then replace Win’ with Debian!

1- if selinux enabled ,at boot set selinux permissive .

Set kernel parameter enforce=0 to grub.
https://docs.fedoraproject.org/en-US/fedora/rawhide/system-administrators-guide/kernel-module-driver-configuration/Working_with_the_GRUB_2_Boot_Loader/#sec-Making_Temporary_Changes_to_a_GRUB_2_Menu

2- check all partitions .

fsck /dev/sda… or for lvm fsck /dev/mapper/…

3-enable and check display manager service ex:gdm.service .

systemctl status gdm.service

systemctl enable gdm.service

4- set default target to graphical.target.

systemctl set-default graphical.target

5- if selinux enabled run this command and reboot .

touch /.autorelabel

reboot

(google translate)

1 Like

By default, Fedora Workstation installations do not have an enabled root (no password is set). As a workaround, you can boot with parameter systemd.debug-shell=1 and then you can switch to tty9 to find a root shell, no authentication required. Here you can troubleshoot the failed boot, or even passwd root if you want to enable root.

1 Like

@znam, just so you’d better understand the problem you’re having.

When Fedora can’t boot normally (that’s the problem number one – the root of your troubles), it tries to launch an emergency console. In some cases it can’t do so (problem number two) – which makes it harder to troubleshoot the first / real issue.

You’ve managed to resolve problem number two and are able to login to emergency console. Now we need to understand why Fedora can’t boot in the first place. Please post here any error messages you see before you get dumped to emergency console (maybe as screenshots).

Also @youssefmsourani provided some general steps which can help in your case (step number 2 with fsck being my favorite) – have you tried them?

@znam

I also ran into this problem with Fedora 31.

After I followed these instructions https://ask.fedoraproject.org/t/howto-cannot-open-access-to-console-the-root-account-is-locked-in-emergency-mode-dracut-emergency-shell/2010/2

I did: https://unix.stackexchange.com/questions/529285/emergency-mode-on-fedora-30#new-answer?newreg=cd5af4d11fd64dfb8b892feb8954ff34

After that I was able to type ‘exit’ in the console and fedora rebooted normally.