Fedora 31 Disable Autoupdate

I use the GNOME desktop.
No additional apps than the basic OS install.
I would like to disable Automatic Updates yet still be able to perform manual updates via a terminal window.
I would prefer to not extend timers, but disable auto updates all together.
All assistance will be appreciated.

1 Like

You need disable packagekit and Gnome Software… I only use dnf…

sudo systemctl stop packagekit.service

sudo systemctl disable packagekit.service

sudo systemctl mask packagekit.service

sudo systemctl stop packagekit-offline-update.service

sudo systemctl disable packagekit-offline-update.service

sudo systemctl mask packgekit-offline-update.service
3 Likes

This service downloads updates in the background then send a notification that they are ready to be installed, that there are new updates?

2 Likes

Hi;

Fedora has not automatic updates by default only show a notification of that there are updates available and you can take the decision of update trough gnome-software or with the console (nothing more).

Other thing is what you have enabled, in this case you can see how it does work to enable or disable it.

https://fedoraproject.org/wiki/AutoUpdates#Automatic_Updates

Regards.

@xtym but, on a default scenario, packages are downloaded in the background or the gnome notification is… only a notification?

2 Likes

@alciregi I think it is only a notification to me, if i run gnome-software it says search the updates and after reboot to apply them but also it is true than sometimes just the updates was downloaded but I don’t know if it was because i did run in terminal sudo dnf --refresh upgrade and i did go to a new cache with the newpackages ready to install. It is something than i need see too but normally trough gnome-software i need donlowad first the packages to after reboot and execute the update.

It is than i see but maybe i missing something with gnome-software because i never did check the options of gnome-software like it:

Skärmbild från 2019-12-04 18-16-56

Maybe disabling automatic updates always do sure than never it will go downloaded. But like said before normally i need push the bottom search the updates after i did received the notification.

Append: Here I found a bit more of information i dont know the state in 3.34

https://blogs.gnome.org/hughsie/2018/08/08/gnome-software-and-automatic-updates/

Edit2: Today i did pay more atteting @alciregi and yes the updates was downloaded by default just only reboot and install buttom was present maybe the others times i did check this direct after i received the notification from gnome-software and there was the buttom download preview to reboot and install So i maybe it was just a question of time what it is logical… you are right !.

Regards

Thanks to everyone for their suggestions.
Much appreciated.

It’s a very good idea! I will do it.

thank you

What was a good idea? To read the docs of the app?
To block the service?
It’s not clear what was your conclusion?
systemctl list-timers *dnf-*

1 Like

I have noticed that with F33 and running gnome it automatically selects to install pending updates whenever I shutdown or restart, forcing me to either uncheck that box or allow the gnome software app to update for me. The link about the auto updates in gnome says it only works for flatpacks and I do not use flatpacks but it is still interfering for me.

I DO NOT WANT THAT TO BE THE STANDARD because it interferes with my normal system administration habits and can cause unintended system issues. It also can cause problems with software installs when the mirror repos are not yet in sync and the user has no way to tell there has been a problem.

Blocking that should not be necessary as it would be much more user friendly to make it optional as has always been the case in the past. Forcing the update seems eerily similar to the way M$ has taken control of the users PC away from them.

If this continues I will regretfully switch away from gnome to avoid having my personal control absconded with.

I have investigated dnf-automatic and confirmed that it is not installed nor configured so the only possibility for this inappropriate behavior is gnome.

If you don’t use flatpaks (or even if you use them) an you are so disgruntled, you have the option to uninstall gnome-software.

1 Like

A new update of “Software” ignores these preferences. I understand this is a bug?

Did you try disabling automatic updates in Gnome-Software? or

F31 disable auto update

It does look like it will notify you if no updates have been received in a week.

As far as I know, on workstation all of the automatic updates are handled by gnome-software and package-kit. DNF-automatic is not installed by default.

As a side note you could also build with the everything iso and pick the exact setup and packages you think are needed.

I followed the steps for the packagekit.service and disabled those.
I then checked in the gnome settings and already had both the update and notifications for auto update turned off there.

I hope this works, but still think it is a bug for the updates to be ON by default. The auto update should be something you select, not forced on everyone.

I think distributions should strive for sane defaults, but the path to get there is filled with opinions and frustration.

IMHO the default should be to ease the life of newcomers. I know people that never update their systems because they don’t care and they are not aware of updates/DNF/packages and so on. They want a working system to achieve their work. Remember, Fedora is not only for developers. So a notification and somethig nearly automatic is useful for them.

For advanced and power users, well, they know what they want and they have the knowledge how to get it :slight_smile:

2 Likes

True, but maybe the “assist” for the masses could be tempered with an “on/off switch” at install or update time when changes are done that introduce something as intrusive as forced updates unless you opt out each time you shutdown.

KDE Spin comes with Discover (PackageKit), which is not forcing updates on you, moreover, update notifier can be easily silenced by removing it from panel.

remove “software” and “Packagekit”
do not forget the daily update