Fedora 31 fails to retrive shares

When I tried to access may NAS server through ‘Connect to Server’ in the graphic interface - Gnome - typing smb://192.168.1.xxx t I get the follow error: ‘Unable to access location. Failed to retrieve share list from server: Software caused connection abort.’
I can access all the other samba shares in Ubuntu servers through Connect to Server.
I can access the NAS shares if I double on the AFP.
Also I cannot connect to another NAS server in any way. The error given is ‘Unable to access location. Failed to retrieve share list from server: Function not implemented.’
Every thing was working fine in Fedora 30.
Any ideas will be very much appreciate. Thank you

to me it’s not quiet clear what you have done.
I guess you upgraded you box, but from the info you provided I can’t know for sure !

if an upgrade then how:

  • via dnf upgrade ?
  • via new install ?

in an terminal (as a short test):
smbclient -L 192.168.1.xyz does show what ?

one my F31 box with local shares (same box) it looks like this:

Unable to initialize messaging context
Enter SAMBA\ron’s password:

Sharename       Type      Comment
---------       ----      -------
Downloads       Disk      
Windoof         Disk      
IPC$            IPC       IPC Service (Samba Server Version 4.11.0)

SMB1 disabled – no workgroup available

p.s.
there is NO need to hide private IP adresses they aren’t routed through the internet anyway !
AFAIK they are just dropped, so no one is able to connect to your NAS !

I used dnf.
The outout is
[nano@localhost ~] smbclient -L 192.168.1.250 Unable to initialize messaging context protocol negotiation failed: NT_STATUS_CONNECTION_DISCONNECTED [nano@localhost ~] sudo smbclient -L 192.168.1.250
[sudo] password for nano:
protocol negotiation failed: NT_STATUS_CONNECTION_DISCONNECTED
Thank you

Hello,

Same issue for me. I experienced it by upgrading from 30 to 31 using DNF and also by doing a full reinstall.
I tried different flavours like the default Gnome interface but also KDE and XFCE spins (the latest being my favorite DE). Every time doing the full reinstall with the respective ISO.
I am no longer able to connect to my NAS share neither with file managers (eg. Thunar) nor within the terminal.
[gerard@quark ~] smbclient -L 192.168.0.254
Unable to initialize messaging context protocol negotiation failed: NT_STATUS_CONNECTION_DISCONNECTED

thanks for your help !

weird !
I did an upgrade too and no samba errors.
the prize question is: what has changed ?
was it working before upgrade ?

what does

testparm -v | grep protocol

show ?

my one:

client ipc max protocol = default
client ipc min protocol = default
client max protocol = SMB3
client min protocol = SMB2_02
server max protocol = SMB3
server min protocol = SMB2_02

As I said I’m running local shares (same box) and in my /etc/samba/smb.conf is this:

[global]
client max protocol = SMB3

needless to say that your F31 box needs to speak a protocol what your NAS is able to understand.
On my box during upgrade nothing has changed regarding protocol.
But it could be in your case (I’m no samba expert btw.)

man smbclient show a parameter “-m” to play with

-m|–max-protocol protocol
This allows the user to select the highest SMB protocol level that smbclient will use to connect to the server. By default this is set to highest available SMB3 protocol version. To connect using SMB2 or SMB1 protocol, use the strings SMB2 or NT1 respectively. Note that to connect to a Windows 2012 server with encrypted transport selecting a max-protocol of SMB3 is required.

so give this a try:

smbclient -L 192.168.0.254 -m SMB2

1 Like

Thank you but it is not working. Both NASs did work before. I can ping them but the error stands

Hi,

gerard@localhost:~ $ testparm -v | grep protocol
Load smb config files from /etc/samba/smb.conf
Loaded services file OK.
Server role: ROLE_STANDALONE

Press enter to see a dump of your service definitions

client ipc max protocol = default
client ipc min protocol = default
client max protocol = SMB3_10
client min protocol = SMB2_02
server max protocol = SMB3
server min protocol = SMB2_02

and after changing the smb.conf
gerard@localhost:~ $ testparm -v | grep protocol
Load smb config files from /etc/samba/smb.conf
Loaded services file OK.
Server role: ROLE_STANDALONE

Press enter to see a dump of your service definitions

client ipc max protocol = default
client ipc min protocol = default
client max protocol = SMB3
client min protocol = SMB2_02
server max protocol = SMB3
server min protocol = SMB2_02

And the tests :

gerard@localhost:~ $ smbclient -L 192.168.0.254
protocol negotiation failed: NT_STATUS_CONNECTION_DISCONNECTED

gerard@localhost:~ $ smbclient -L 192.168.0.254 -m SMB2_02
protocol negotiation failed: NT_STATUS_CONNECTION_DISCONNECTED

gerard@localhost:~ $ smbclient -L 192.168.0.254 -m SMB2
protocol negotiation failed: NT_STATUS_CONNECTION_DISCONNECTED

gerard@localhost:~ $ smbclient -L 192.168.0.254 -m SMB2_10
protocol negotiation failed: NT_STATUS_CONNECTION_DISCONNECTED

As you can see, not working

shit !

are the ports for samba on the firewall open ?
my ports (a samba server):

  • UDP: 137, 138
  • TCP: 139, 445
    in the firewall it’s just the string “samba” !

see:

sudo iptables -L -n

P.S.
I’m not 100 % sure, but I guess you need to do an

sudo systemctl restart smb

if you change smb.conf. Otherwise smb will run with the old setting.

One last shot on this bug:

moons ago I wrote in my changelog ( a file where I save changes/hints/etc.) the following:

“smb in Nautilus: remove /var/lib/sss/secrets/secrets.ldb”

I far remember that I was unable to retrieve shared directory from an samba server (also a local box) and removing “/var/lib/sss/secrets/secrets.ldb” fixed it.

a writeup is here:
https://fedoraproject.org/wiki/Common_F27_bugs

it is not really obvious why removing secrets.ldb fixed the samba problem too, but maybe it might help here again.
Therefore I suggest the following:

  • mv /var/lib/sss/secrets/secrets.ldb /var/lib/sss/secrets/secrets.ldb_BACKUP
  • try to retrieve the shares again in gnome/nautilus

P.S.
a reboot creates a new /var/lib/sss/secrets/secrets.ldb !

P.P.S
my very last idea’s on this bug:

  • setroubleshoot
  • investigating with wireshark

Hi everyone sorry to hijack this chat to change the subject a bit but I am kind of regretting moving to Fedora from windows 7 but i want to persist as I detest windows 10. With my windows 7 everything just worked.

I use this laptop for work and I am willing to pay anyone who can help me set it up. Can someone assist from this chat or one of the Fedora Engineers. I can setup Team viewer maybe or something so I can get it reconfigured,
Fedora runs beautifully on my system but I have some problems.

1- The CPU cooler fan stays on full blast after it wakes up after sleep.
2- My Printers and scanner drivers dont work.
3- I need the Zoom app to work with better volume
4- I need access to onedrive through a program call Insync but it wont run on Fedora
5- My virus scanner Eset “isn’t supported” on Fedora. So what virus scanner does Fedora use. ?

Really appreciate any help.

Hi,

I open the port in the firewall (they were not defined) I also renamed the secrets.ldb file, rebooted the laptop without success…

I continue investigating around, if anyone as an idea I’m ready to try.

Thanks sixpack13 for your help !

I need to correct myself: opening ports is only needed on the smba server.

to get somewhat further:

  • what is the OS of the NAS or on what OS are the shares running ?
  • for the NAS case: are there log files regarding samba ?

in general:
I just setup up a F31(Gnome) in an virtual machine with bridged network.
I test with another F31(Gnome) to access shares in both directions.

NO errors, all shares were accessable !

so I guess the bug is NOT in F31(Gnome) or the current samba packages.
I guess it’s an configuration problem somewhere … weird !

@bennyisaiah
You got and get any help, but -speaking for myself- only so far until you’re able to help yourself !

I personal miss your action cause I told your twice and here comes the third:

run your printer/scanner, Zoom app (what ever that is- I guess windows related - ), onedrive and the virus scanner in an virtual machine with windows 7 and your are done with point 2-5 !
It just costs < 2h work and btw. it could have been done yesterday already !

AFAIK there is no need to run virus scanner under linux.
only M$ needs virus scanner (and could have been paid for the brainsfxck they put into the world !)

How much help do you expect from the small info’s you provide (“The CPU cooler fan stays on full blast after it wakes up after sleep”)

It could be this and it could be that !
nobody knows for sure.
on unaccurate questions you will get unaccurate answers.
one need the typ of the notebook to find out if it’s typ-specific.
or an dmesg.
btw.: why do you put your notebook into sleep mode when it misbehaves afterwards ?
for a first step/ a temp. workaround: I would avoid that, even if I need my windows staff for my work at first !
all step by step and with some sort of priority.
btw: why do I need to sort your priorities ?

when do you want to start your action apart from hijacking threads, overreading info’s you were given and lamenting needing more help you’re unable to take and act on - for my taste -.

Your action is needed !!!
lamenting or win7 in an virtual box ?
that’s the question. :slight_smile:
your decision !

but be aware: linux means reading, reading, reading, trying, reading and trying !

Yes it may appear I am not applying what you said. I have been able to read through the literature and find a solution its all working okay now. Every problem is fixed now thanks in large part to your guidance and patience.

Sorry to take so long but its done now.

Any ideas how I can fix the CPU cooler fan staying on full after sleep ?

Are there other versions of Fedora that you could recommend or could I go back to Fedora 29 which had no teething / beta version.

@bennyisaiah please, it is a very bad behaviour to post questions totally unrelated to the topic of a thread. In addition, if you have many question on different issues, it is also advisable to open a distinct thread for each issue instead of writing a list of problems all in one post.
Thanks.

Sorry everyone, I will take onboard what you said. The main reason is I saw this forum and it appeared that the discussion had concluded and as such already people here seem very knowledgeable about fedora and linux systems in general. Didnt want to be rude, just really lost, i’ll keep reading. my apologies @alciregi

best is to open an new thread, topic e.g.

“CPU cooler fan staying on full blast after sleep mode”

AND

  • provide the full name of the notebook !!!
  • provide a dmesg AFTER sleep mode

in an terminal do

dmesg > dmesg_after_sleep_mode.txt [1]

to @all
is there a way to make (large) text files to the forum visible WITHOUT copy&paste it here ???

[1]

for a first quick view it’s maybe sufficing to do

dmesg|grep -iEw ‘bad|bug|conflict|corrupted|error|fail|failed|fault|fatal|invalid|Lock|NULL|segfault|stack|trace|warn’

- last command is one line (from “d” to " warn’ ") and between "-iEW and “'bad” is a blank -

usually the output are few lines and could be copy&pasted here (if it’s not large)

@bennyisaiah
Why do you want to change Distro/Distro version on the contrary to fix the problems with the current one ???
And why to an distro which is short on EOS (end of support) ?

one might thinks
“okay this guy intend to change distro, so why should I further think about solutions for the current problems ?”
do you see ?

What was the solution for “Every problem is fixed now…” ???
so everybody could see/learn the solution.

yup @vgaetera I had it in my queue to post the solution here, but …

thanks !

Thank you I did it already but still not working