Fedora 31 fails to retrive shares

yup @vgaetera I had it in my queue to post the solution here, but …

thanks !

Thank you I did it already but still not working

and you did an

sudo systemctl restart smb

before your tests after you changed smb.conf, too ?

Any log file on the NAS ???

Something is broken in Fedora 31 and i can repro with smbclient on the same local host.

I have an HP Printer (8600) that scan’s to shares on my fedora box. On upgrading to fedora 31, it can’t access the shares from the printer. Looks like it’s using NTLM 0.12. So i set “client min protocol = core”.
Authentication still fails with “No Protocol Supported.”

** Failure on login attempt from printer**

[2019/11/10 07:45:50.903388,  3] ../../lib/util/access.c:369(allow_access)

Allowed connection from 192.168.192.105 (192.168.192.105)
[2019/11/10 07:45:50.904809, 3] …/…/source3/smbd/oplock.c:1414(init_oplocks)
init_oplocks: initializing messages.
[2019/11/10 07:45:50.905009, 3] …/…/source3/smbd/process.c:1955(process_smb)
Transaction 0 of length 51 (0 toread)
[2019/11/10 07:45:50.905101, 3] …/…/source3/smbd/process.c:1548(switch_message)
switch message SMBnegprot (pid 1930457) conn 0x0
[2019/11/10 07:45:50.905910, 3] …/…/source3/smbd/negprot.c:635(reply_negprot)
** Requested protocol [NT LM 0.12]**
[2019/11/10 07:45:50.906088, 3] …/…/source3/smbd/negprot.c:756(reply_negprot)
** reply_negprot: No protocol supported !**
[2019/11/10 07:45:50.906539, 3] …/…/source3/smbd/server_exit.c:243(exit_server_common) Server exit (no protocol supported)

Things tried:

  1. “client min protocol = core”. Fails

  2. “client min protocol = NT1”. Still fails same way when accessed by printer.
    from localhost (192.168.192.97) to a local share using smbclient

    smbclient --max-protocol nt1 \\192.168.192.97\Scan

//Local server log
==> log.smbd <==
[2019/11/10 08:08:05.268670, 3] …/…/lib/util/access.c:369(allow_access)
Allowed connection from 192.168.192.97 (192.168.192.97)
[2019/11/10 08:08:05.269963, 3] …/…/source3/smbd/oplock.c:1414(init_oplocks)
init_oplocks: initializing messages.
[2019/11/10 08:08:05.270134, 3] …/…/source3/smbd/process.c:1955(process_smb)
Transaction 0 of length 66 (0 toread)
[2019/11/10 08:08:05.270191, 3] …/…/source3/smbd/process.c:1548(switch_message)
switch message SMBnegprot (pid 1934508) conn 0x0
[2019/11/10 08:08:05.270929, 3] …/…/source3/smbd/negprot.c:635(reply_negprot)
** Requested protocol [NT LANMAN 1.0]**
[2019/11/10 08:08:05.270991, 3] …/…/source3/smbd/negprot.c:635(reply_negprot)
** Requested protocol [NT LM 0.12]**
[2019/11/10 08:08:05.271161, 3] …/…/source3/smbd/negprot.c:756(reply_negprot)
** reply_negprot: No protocol supported !**
[2019/11/10 08:08:05.277525, 3] …/…/source3/smbd/server_exit.c:243(exit_server_common)
Server exit (no protocol supported )

Of course I run sudo systemctl restart smb

Make sure you apply the setting on the client.

Don’t know if you are still reading this topic, but @bennyisaiah please go to this page https://ask.fedoraproject.org/categories and thoroughly read the very first category “New Users, Start Here” so you understand what you should do to get help and avoid irritating others which can prevent assistance. After all, everyone here is freely assisting others and they likely will not help those who are not polite and don’t follow the rules.

After a fresh install of Fedora 31 I encounter the same problem with identical error-messages when trying to connect to SMB on my locaL NAS.
(the needed ports are open / protocol versions match / on other Box with Fedora 30 everything is working fine.)

Would be nice to get some help,too!

Apologies for my ignorance what do u mean exactly. If you refer the client as the NAS setting are already been applied. As I said the Ubuntu servers can be access without problems. Only the NAS units cannot be access at all from Fedora 31 but can be access in Windows from XP to 10 and the Ubuntu distro.
Anyhow thank your for yoru reply.

I’m running out of idea’s, so I could need some help too !
:sunglasses:

As I said:
I setup a second F31 in an virtual box.
accessing shares (main F31 <=> VM F31) in both directions works !
all I changed after install was IIRC: open firewall ports, samba server install, a run of smbpasswd on the samba server, restarting smb service

so I wonder what is so different on your boxes when accessing samba shares from an F31 box and from other OS’s.

one part could be:
comparing the log files ON THE NAS during connection establishing [1]

  • once from -lets say - ubuntu (in any case it should be an linux box)
  • once from the (faulty ?!) F31 box

another part would be investigating with wireshark (a protokoll analyzer, it’s in the fedora repos)

weird !!!

[1]
e.g.
as root user

tail -f /var/log/samba/*

In your /etc/samba/smb.conf, add

client min protocol = NT1

It looks like the minimum was bumped to SMB2.
https://bugzilla.redhat.com/show_bug.cgi?id=1773149

What is NT1 please. Anyhow thank you still it doesn’t work.

yup, thank you for your laziness to NOT read what was answered in a thread you started.

unbelievable !

Thank you for your reply.
Well simple questions have been answered and sometimes searching the net could be frustrating and misleading. Finally not everyone has got lots of time to search they have to work.

I use a smb client on F31 box and a smb server on a NAS (older debian)…
on my F30 laptop the client server connection works, on the F31 it did not.

But now it does, too, since I found “my” error some days ago…

F31 had introduced a protocol change from NT1 to SMB2.

Since I added “client min protocol = NT1” to smb.conf everything’s running fine! (no restart needed)

Thanx for make me find the cause myself :slight_smile:

Thank you for sharing that information

I found this thread while trying to search for a solution to my issue. My issue is not the same as OP’s, however, the 1st reply to OP’s question (from sixpack13) is relevant to my issue.

sixpack13’s reply to OP shows output for the smbclient command. My output for the same command matches sixpack13’s output, which, based on his comment seems to be correct and without any problems. However, this output is not the same as that which is recorded in the official instructions located here . (See output below):

$ smbclient -L localhost -U%
Domain=[SAMDOM] OS=[Unix] Server=[Samba x.y.z]

    Sharename       Type      Comment
    ---------       ----      -------
    netlogon        Disk      
    sysvol          Disk      
    IPC$            IPC       IPC Service (Samba x.y.z)
Domain=[SAMDOM] OS=[Unix] Server=[Samba x.y.z]

    Server               Comment
    ---------            -------

    Workgroup            Master
    ---------            -------

All of the output (from me and sixpack13) matches the output for the walkthrough until after the “IPC” line. Our output says “SMB1 disabled…”, however, the instruction’s output has info about the domain, workgroup, etc.

sixpack13 seems to imply that their output for this command is normal, however, it is different than the output used in the instructions. I am still in the process of configuring my DC so I have not finished the walkthrough but I would like to solve this before going further. How can I begin to troubleshoot this discrepancy? If it is not a problem, might somebody be able to explain why my output is different than that printed in the instructions and why it is not a problem? Any assistance would be greatly appreciated!

You might want to mark your post as a solution so that others who find this topic will be able to quickly benefit from your hard won knowledge. Good job in figuring it out!

2 Likes

Okay so I have continued on with the Samba AD setup instructions. I have verified DNS and Kerberos using these tests
My output matches that of the tutorial. Everything on my DC seems to be functioning, however, there is still the SMB1 discrepancy. I have added the following line to smb.conf

client min protocol = NT1

and restarted samba. The output for the smbclient command has changed but still seems to be problematic:

smbclient -L localhost -U%

    Sharename       Type      Comment
    ---------       ----      -------
    sysvol          Disk      
    netlogon        Disk      
    Share           Disk      
    IPC$            IPC       IPC Service (Samba 4.11.2)
Reconnecting with SMB1 for workgroup listing.
smbXcli_negprot_smb1_done: No compatible protocol selected by server.
protocol negotiation failed: NT_STATUS_INVALID_NETWORK_RESPONSE
Unable to connect with SMB1 -- no workgroup available

I do not know the implications this will have on a working domain, if any at all. Might anybody be able to provide me with some info on why this is happening and how it will impact my system? Perhaps there is something I can change so that my system’s output will reflect that of the tutorial? Any assistance is greatly appreciated.

I was able to access the samba share after setting

client min protocol = NT1

Now I’m seeing each file as a folder in my samba share. What must I do to get this fixed?