Fedora 31 & Intel Bay Trail

Hey everyone!
[English, Italian, Danish languages are all absolutely welcome]

I am still fighting and hoping with a Lenovo MIIX 300 tablet with a Bay Trail on it.

The issue is: it freezes randomly.

I understood from other articles about other distros (Mint) that the intel cstate could be the factor of the freezing phenomenon I am experiencing (together with all the other temerary ones trying som stuff like this).

How to force the state of the intel cstate to 1 or 2 in Fedora 31 “elegantly enought”?
I think I understood that in Mint they smack it on the a boot line in Grub,
but is it the (only) way, and does it work here as well?

Apart from cameras, I got all the rest working, including the gyro and the related rotation issue, touch, sound, wifi, bluetooth and battery management, so… I would be quite sad to have to go on distro-surfing… no other distro gave those results so fur, exept for this freezing thing I can´t get out of.

Cheers and thanks!

Dario

Hi @alu77

Can you post the output of this command to know first what is the driver in use for your CPU if it is acpi_idle or intel_idle?

cat /sys/devices/system/cpu/cpuidle/current_driver

Regards.

I will now explain the options in every case, you should test them first in mode temporal (i mean adding temporally one or 2 parameter to the boot kernel parameters to check if they do work to do they permanent in case positive. To add temporally parameters to kernel read this article

Lets start:

A) You are using the driver intel_idle

Here you have 2 options

  • A.1) Fix the max c-statet to this driver (best option)

You need add to this parameter to the boot:

intel_idle.max_cstate=1

note: set intel_idle.max_cstate=n (n= 1 to 6), then intel_idle is enabled and maximum cstate is set to n

  • A.2) Disable intel_idle drive to force to use acpi_idle and fix processor.max_cstate=1

You need add to these 2 parameters to the boot:

intel_idle.max_cstate=0 processor.max_cstate=1

note: set intel_idle.max_cstate=0 will disable intel_idle driver and processor.max_cstate=n (n= 1 to 6), maximum cstate is set to n

B) You are using the driver acpi_idle

You need add to this parameter to the boot:

processor.max_cstate=1

Note: Sometimes the best way is disable cstate in BIOS so that you don’t need do anything but sometimes the kernel trough the intel_idle driver is overriding the BIOS parameter so maybe be that if you just disable this in the BIOS it didn’t result enough and you need add this parameters in anyway .

Like said before test this parameter in mode temporal never permanent check what of them do work to you and when you know what is the best alternative you can do they permanent.

Now I will post some links that i did take of reference:






https://support.hpe.com/hpsc/doc/public/display?docId=emr_na-c03132537

Regards

That is Irony. Aren’t the Intel company is a one of the major contributors to the Linux kernel?