Fedora 31 upgrade issue due to wingpanel

Hey all :wave:, I’m using dnf to upgrade following along here: https://fedora.pkgs.org/30/fedora-updates-x86_64/wingpanel-indicator-datetime-2.1.3-4.fc30.x86_64.rpm.html

And I got this:

Error: 
 Problem: problem with installed package wingpanel-indicator-datetime-2.1.3-4.fc30.x86_64
  - package wingpanel-indicator-datetime-2.1.3-3.fc30.x86_64 requires libecal-1.2.so.19()(64bit), but none of the providers can be installed
  - wingpanel-indicator-datetime-2.1.3-4.fc30.x86_64 does not belong to a distupgrade repository
  - evolution-data-server-3.32.4-1.fc30.x86_64 does not belong to a distupgrade repository

I see I have a number of wingpanel packages when I run rpa -qa, so I’m not sure what to twiddle. Any tips to troubleshoot further?

Of course, as soon as I post, I came across the --allowerasing flag. Everything is now running smoothly.

If you are interested, you can follow the progress to fix that package here: https://bugzilla.redhat.com/show_bug.cgi?id=1736968

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.