Fedora 31 with older Kernel

Hi,
since my wlan is not working with newer kernel versions, I would like to know if it is possible to use an Fedora 29 kernel (4.20.7-200.fc29) with Fedora31?
Thank you very much!

It’s not likely to work. We can try to give you some support about your wlan card if you give us more details.

Hi x3mboy,
thank you very much for your reply! Ok, that is sad, then I’ll probably have to stick with f29. Wlan uses the rt2800usb driver (card is built in an old HP notebook). Seems to be a bug with newer kernels, sadly there is no solution yet: https://bugzilla.kernel.org/show_bug.cgi?id=202541
Jana

Hi Jana and welcome

As x3mboy says, using such an old kernel might be problematic. In principle, there’s no reason why it shouldn’t work, but it’s an untested combination and it’s definitely not to be recommended.

Are you sure your wlan card won’t work? That bug report is pretty old (Feb 2019) and has wandered all over the place in terms of what people think the real issue might be.

The real way to be sure whether the card will work or not is to boot a live USB of Fedora 31. You might have tried that already since it’s an easy way to test it.

However, you could also try booting the live USB of the Fedora respin (https://dl.fedoraproject.org/pub/alt/live-respins/). This is the up-to-date image of the latest version (currently F31 of course) - it’s an officially supported Fedora project (https://fedoraproject.org/wiki/Respins-SIG) so you don’t need to worry that it’s unreliable or malicious. (If you want the ordinary Gnome Workstation respin, that’s the F31-WORK-… file.) Using the respin will tell you whether your card works under the current F31.

2 Likes

Hi jonathans,
thank you very much for your reply! I sporadically test the live versions to check if the problem might be solved, sadly until today that seems not to be the case. Actually that was the reason for my question, I gave Fedora 32 Beta a try last weekend. Without success.

Can you send us an output of the dmesg command? I think we can help you to make it work.

Hi,
sorry, has been a while since I logged in the last time. Have been pretty busy lately. For testing purposes I installed fedora 32 beta on an Usb pen-drive and then installed the old 4.20 kernel on top of that. What shall I say, everything seems to work so far.
@x3mboy:
If you could help make the damn wlan thing work with newer kernels, that would be really cool. Sadly it seems not to be one of the ‘simple things’…

dmesg output (Kernel 5.6.6-300.fc32.x86_64):

usb 3-1: new high-speed USB device number 13 using xhci_hcd
usb 3-1: New USB device found, idVendor=148f, idProduct=3070, bcdDevice= 1.01
usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 3-1: Product: 802.11 n WLAN
usb 3-1: Manufacturer: Ralink
usb 3-1: SerialNumber: 1.0
cfg80211: Loading compiled-in X.509 certificates for regulatory database
cfg80211: Loaded X.509 cert ‘sforshee: 00b28ddf47aef9cea7’
usb 3-1: reset high-speed USB device number 13 using xhci_hcd
ieee80211 phy0: rt2x00_set_rt: Info - RT chipset 3070, rev 0201 detected
ieee80211 phy0: rt2x00_set_rf: Info - RF chipset 0005 detected
ieee80211 phy0: Selected rate control algorithm ‘minstrel_ht’
usbcore: registered new interface driver rt2800usb
rt2800usb 3-8:1.0 wlp0s20u8: renamed from wlan0
ieee80211 phy0: rt2x00lib_request_firmware: Info - Loading firmware file ‘rt2870.bin’
ieee80211 phy0: rt2x00lib_request_firmware: Info - Firmware detected - version: 0.36
ieee80211 phy0: rt2x00usb_vendor_request: Error - Vendor Request 0x06 failed for offset 0x0404 with error -71
ieee80211 phy0: rt2800_wait_csr_ready: Error - Unstable hardware
ieee80211 phy0: rt2800usb_set_device_state: Error - Device failed to enter state 4 (-5)

I already tried: Manually unload / load kernel modules, deactivating wpa_supplicant, deactivating random MAC scan.
Edit: rfkill says ‘unlocked’ for Soft & Hard