Fedora 32 crashes on boot, but not in command line

Hi everyone, I’m a first timer here, although I’ve been using Fedora on my main desktop machine for a year and a half now. I’m having an issue here that may take some time to describe. I’ve been scouring the internet all week, including here, to find a solution, and I can’t find anyone having the same problems I’m having.
The computer is running Fedora 32 right now with KDE Plasma. This may be relevant too, it has an NVidia GeForce 1060 graphics card.
So my computer just spent the last two months in a packing crate during an international move. After unpacking I can’t make the thing boot up. There are only two differences from when I last used it before packing it and shipping. One, there’s no wired internet connection here, because I’m temporarily in a cheap apartment that only has WiFi. I do have a USB WiFi transceiver but of course I can’t connect till after booting. The other thing is that the graphics card is inexplicably broken. It doesn’t seem to be running because the fans on it don’t move when the computer’s turned on. I have to connect my monitors to onboard graphics.
So whenever I boot it and turn on verbose mode, it always ends at “Starting notify NFS peers of a restart.” It can’t go on after that, and I’ve tried leaving it on for over a whole hour and it didn’t get any further. It doesn’t completely crash, though, because I can still do Ctrl-Alt-Del to restart, but that’s the ONLY thing I can do.
But I can boot it into command line mode! From there I’ve tried startkde and that just tells me “unable to connect to X server” or something like that. I tried “startx” and that also tells me it can’t connect to the X server, and also that it can’t find any screens.
So, can anyone tell me what the problem here is? Is this because of the lack of internet connection? Is it because of the suddenly broken graphics card? (and can it be fixed?) I’ve looked all over and can’t find any solution.

Did you remove the Nvidia card? If not, can you try to boot after removing the external video card?

Or at least look that in Bios you set just for using onboard video.

Did you also try F12 and the rescue mode?

Removing the card is something I’d hoped to avoid since installing it and replacing it is such a hassle. As for resetting the bios, would anyone here know what to change it to? I was thinking about doing that actually, but since I changed it once before, when I first installed the card, I don’t know how to find what settings to change it back to.

I think I did try the rescue mode but it didn’t work. I don’t remember why. I’ll try it again and post here what happens.

OK I tried rescue mode again. Its problem “Cannot open access to console, the root account is locked.” But it never asked me for a root password.

I tried changing some things in the BIOS menu (pressing F12 during bootup). Tried changing the graphics device from “Auto” to “IGFX” and that didn’t work. Tried disabling the internal LAN controller, that didn’t work. Still freezing up with “Notify NFS peers of a restart.”

If you diagnose the problem with the graphics drivers, may I propose installation of RPM Fusion drivers using GitHub - t0xic0der/nvidia-auto-installer-for-fedora: A CLI tool which lets you install proprietary NVIDIA drivers and much more easily on Fedora 32 and above?

RPM Fusion sounds familiar; I may have used that in the past to install drivers. Looking at the NVidia site, it seems they have released new drivers just last month. Maybe that’s the problem? I don’t know…the graphics card doesn’t even activate when I turn the computer on, I mean the fans aren’t even spinning. I’ll try updating the drivers anyway though.

You can manually boot into multi-user.target (text mode) at runtime:

  1. At Grub2 boot menu, highlight the entry you want to boot
  2. press ‘e’ to edit the entry
  3. append, without the quotes, “systemd.unit=multi-user.target” to the end of the kernel line
  4. presee Ctrl+x to boot the edited entry

If you can boot to text mode, you can furhter:

  • make boot to text mode permanent until you fixed your problem by
    $ sudo systemctl set-default multi-user.target

  • when you need to start GUI, you can run for GNOME
    $ sudo systemctl start gdm

  • for KDE
    $sudo systemctl start sddm

  • you can also check your network settings in text mode. It will be easier if you can have Internet access working.

  • activate your root account by setting the password for the root account if you need access to emergency shell
    $sudo passwd

Good luck!

ps. As part of troubleshooting, remove the add-on graphics card. When the system can boot normally, then you can reinsert the graphics card to check its status.

1 Like

Please avoid installing drivers from the RUN file which is directly obtainable from the NVIDIA site due to its generic nature.

I’ve removed the graphics card and it still hangs up when booting. I booted into command line mode and then did “sudo systemctl start gdm” only to get this message: “Unit gdm.service not found.” I’m now googling that.

Oh!

My fault, you are using KDE, gdm is for GNOME.

Please try below instead:
#sudo systemctl start sddm

Unfortunately this just makes it lock up. Blank screen with only a blinking cursor in the top left corner, doesn’t even respond to Ctrl-Alt-Del.

On your next boot, please check the output of:

  1. any errors in journal, by using a time period covering this recent hang, example below:
    $sudo journalctl --since “2021-02-06 11:00:00” --until “2021-02-06 11:15:00”

  2. the output of lspci -v, expecially the VGA related entries, a sample output from my machine:
    01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series] (prog-if 00 [VGA controller])
    Subsystem: Dell Vostro 3350
    Flags: bus master, fast devsel, latency 0, IRQ 37
    Memory at e0000000 (64-bit, prefetchable) [size=256M]
    Memory at f7b20000 (64-bit, non-prefetchable) [size=128K]
    I/O ports at e000 [size=256]
    Expansion ROM at f7b00000 [disabled] [size=128K]
    Capabilities: [50] Power Management version 3
    Capabilities: [58] Express Legacy Endpoint, MSI 00
    Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
    Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
    Capabilities: [150] Advanced Error Reporting
    Kernel driver in use: radeon
    Kernel modules: radeon

  3. your kernel version
    $uname -a

kernel 5.10.12 just pushed out earlier today. you might want to update to the latest kernel and try:
#sudo dnf update kernel

I personally do not use KDE, I am sorry that I cannot give you KDE specific suggestions.

1 Like

I looked at the error journal from the first time I started it up today, which was right after I removed the gfx card. There were two sddm error messages that popped up several times during that boot: “Failed to read display number from pipe” and “Display failed to start. Exiting.” There’s also a few core dumps that I can’t even begin to understand. After the core dumps and before the reboot I also see this repeated five times: “Process 1084 (sddm) crashed in qt_message_output (QtMsgType, QMessageContext const&, QString const&) clone .cold

1 Like

And also: I tried lspci and it only lists onboard devices. Even when the GPU is connected, it doesn’t see it.

Current kernel is 5.9.10.

1 Like

Yes, this is exactly what it does.

The solution is there … did you try to do it ?

Hmm, OK…I entered “sudo sulogin --force” and got into the console. I’m not sure what to do from here though. I’ll investigate this further…